Inconsistent Virtual Host access
Posted by: rnr501 (154.42.163.---)
Date: October 06, 2018 01:52PM

1 - Windows Sever 2016 Datacenter (64bit) v1607
2 - WampServer v3.1.4 (64bit)
3 - Apache v2.4.35
4 - PHP v7.2.10
5 - MySQL v5.7.23
5a - MariaDB N/A
6 - Icon is GREEN smiling smiley
7 - c:\Windows\System32\drivers\etc\hosts:

127.0.0.1 localhost
::1 localhost

127.0.0.1 mus
::1 mus

127.0.0.1 cs
::1 cs

# successful pings to ::1

8 - Do you have access to localhost (Homepage WampServer)? Y
8a - If so, is there an error message at the bottom of the page? N
9 - Do you have access to phpMyAdmin? Y
10 - If you refer to an error message, please include the EXACT wording of the error in your post
11 - If you use an Antivirus and / or Firewall, please include the names of these - BitDefender
12 - Wampserver: C:\wamp64\

13 - If you have one or more Virtual Hosts defined, please show their definition(s)

# Virtual Hosts

<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
    Require local
  </Directory>
</VirtualHost>

#
<VirtualHost *:80>
	ServerName mus
	DocumentRoot "c:/wamp64/www/music"
	<Directory  "c:/wamp64/www/music/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Allow from all	
		Require all granted		
	</Directory>
</VirtualHost>

#
<VirtualHost *:80>
	ServerName cs
	DocumentRoot "c:/wamp64/www/protrack"
	<Directory  "c:/wamp64/www/protrack/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Allow from all	
		Require all granted		
	</Directory>
</VirtualHost>

========================================================

Hi All,

I have implemented a new/clean installation of WampServer (as detailed above)

I have 2 Virtual Hosts configured (cs and mus - also detailed above)
Both work on the server when accessed from a web browser typing e.g. cs/ or mus/

When accessed remotely, cs/ works fine, but mus/ doesn't (irrespective of including http:// etc.
It just give the following error:

This site can’t be reached
mus’s server IP address could not be found.
Search Google for mus
ERR_NAME_NOT_RESOLVED

(The same happens when I try to access phpMyAdmin remotely too, although I suspect this is a different issue!)

I can't see why one works and the other doesn't. It is probably a very obvious thing.
I have worked my way through countless posts & all of the linked documentation trying to resolve, but have ground to a halt. I normally stick to PHP/MySQL, so the server stuff is new to me...so please go gentle!

Many thanks for any advice/help!

RnR



Edited 1 time(s). Last edit at 10/07/2018 10:00AM by RiggsFolly.

Options: ReplyQuote
Re: Inconsistent Virtual Host access
Posted by: RiggsFolly (Moderator)
Date: October 07, 2018 10:06AM

Hi,

Can we start by removing the "Allow from all" from both VH's.

The "Allow from all" is Apache 2.2 syntax and "Require all granted" is Apache 2.4 for the same things. Using both can often confuse Apache.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Inconsistent Virtual Host access
Posted by: rnr501 (154.42.163.---)
Date: October 08, 2018 09:04AM

Understood. Thank you for your quick response.

Removing "Allow from all" and restarting services has no effect. cs/ still available mus/ still not.

Any other ideas gratefully received!

Many thanks,
RnR

Options: ReplyQuote
Re: Inconsistent Virtual Host access
Posted by: Bobn (---.lightspeed.stlsmo.sbcglobal.net)
Date: October 17, 2018 06:32AM

Please show me the contents of your hosts file in c:\windows\System32\drivers\etc\

Bob

Options: ReplyQuote
Re: Inconsistent Virtual Host access
Posted by: RiggsFolly (Moderator)
Date: October 17, 2018 11:18AM

Hi,

Can I ask how you are attempting to access these site remotely.

By remotely do you mean from anothre PC in your network or do you mean from the internet?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.