Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 04, 2018 11:34PM

I upgraded to Windows 10. Started Wamp and it was stuck on red. Watched some videos that said to change the localhost to 8888. Went to open the appropriate file and it wouldn't open. I decided to uninstall and start over. Wamp wasn't in my programs list so I just deleted the folder. Downloaded wampserver3.1.4_x64 and started the install process and received the following warning.

"--- Installation of Wampserver ---
BEFORE proceeding with the installation of Wampserver, you must ensure that certain elements are installed on your system, otherwise Wampserver will absolutely not run, and in addition, the installation will be faulty and you need to remove Wampserver BEFORE installing the elements that were missing.
Make sure you are "up to date" in the redistributable packages VC9, VC10, VC11, VC13 , VC14 and VC15
See --- Visual C++ Packages below.
--- Do not install Wampserver OVER an existing version, follow the advice:"

What is my next step?

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: Otomatic (Moderator)
Date: October 05, 2018 09:58AM

Hi,

> What is my next step?
Apply the required prerequisites.

I'll simplify the task for you!

- 1 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 2 - Verify items 03 and 08 of TROUBLESHOOTING TIPS but there is absolutely nothing to prevent you from reading the entire document.

- 3 - Install Wampserver 3.1.4 as an administrator

- 4 - Read the file wamp64/instructions_for_use.pdf

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 06, 2018 09:18PM

Thanks for dumbing it down for me. Do these results mean I only need to update VC13?

VC_2008_SP1_ATL_SEC_UPD_REDIST_X86 ID={1F1C2DFC-2D24-3E06-BCB8-725134ADF989}
Visual C++ 2008 SP1 ATL Security (x86)
**** NOT INSTALLED ****
see: [www.microsoft.com]
----------------------------------------
VC_2013_REDIST_X86_MIN ID={8122DAB1-ED4D-3676-BB0A-CA368196543E}
Microsoft Visual C++ 2013 x86 Minimum Runtime - 12.0.40664
**** NOT INSTALLED ****
see: [support.microsoft.com]
----------------------------------------
VC_2013_REDIST_X86_ADD ID={D401961D-3A20-3AC7-943B-6139D5BD490A}
Microsoft Visual C++ 2013 x86 Additional Runtime - 12.0.40664
**** NOT INSTALLED ****
see: [support.microsoft.com]
----------------------------------------
VC_2017_REDIST_MIN_X86 ID={39E15475-23F2-345D-8977-B5DC47A94E26}
Visual C++ 2017 x86 Minimum Runtime - 14.15.26706
**** NOT INSTALLED ****
see: [aka.ms]
----------------------------------------
VC_2017_REDIST_ADD_X86 ID={2757496A-3E74-320A-B007-36120A9F126D}
Visual C++ 2017 x86 Additional Runtime - 14.15.26706
**** NOT INSTALLED ****
see: [aka.ms]
----------------------------------------
VC_2008_SP1_ATL_SEC_UPD_REDIST_X64 ID={4B6C7001-C7D6-3710-913E-5BC23FCE91E6}
Visual C++ 2008 SP1 ATL Security Update (x64)
**** NOT INSTALLED ****
see: [www.microsoft.com]
----------------------------------------
VC_2013_REDIST_X64_MIN ID={53CF6934-A98D-3D84-9146-FC4EDF3D5641}
Visual C++ 2013 x64 Minimum Runtime Update 5 - 12.0.40664
**** NOT INSTALLED ****
see: [support.microsoft.com]
----------------------------------------
VC_2013_REDIST_X64_ADD ID={010792BA-551A-3AC0-A7EF-0FAB4156C382}
Visual C++ 2013 x64 Additional Runtime Update 5 - 12.0.40664
**** NOT INSTALLED ****
see: [support.microsoft.com]
----------------------------------------
VC_2017_REDIST_MIN_X64 ID={C77195A4-CEB8-38EE-BDD6-C46CB459EF6E}
Microsoft Visual C++ 2017 x64 Minimum Runtime - 14.15.26706
**** NOT INSTALLED ****
see: [aka.ms]
----------------------------------------
VC_2017_REDIST_ADD_X64 ID={F106B700-BFF8-3065-B305-14D36AD40539}
Microsoft Visual C++ 2017 x64 Additional Runtime - 14.15.26706
**** NOT INSTALLED ****
see: [aka.ms]
----------------------------------------

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: Otomatic (Moderator)
Date: October 06, 2018 09:24PM

Hi,

VC_2008,, VC_2013 and VC_2017 are needed.

The result after running the tool must be
All VC packages needed by Wampserver are installed.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 07, 2018 04:52PM

Thank you! Wamp is up and running. One last question: I want to run Wordpress in Dreamweaver. Do I follow "WAMPServer 3 Create a Virtual Host, the easy way"?

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: RiggsFolly (Moderator)
Date: October 07, 2018 08:48PM

Hi

I would always create a Virtual Host to install Wordpress into, so yes.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 07, 2018 11:16PM

So I created my sitefolder as admin in explorer folder, launched localhost, clicked on "add a virtual host" and now I am stuck at "We arrive on the Add Virtualhost page in which it is required to validate the VirtualHost submenu, then:- Right-Click Wampserver Icon -> Wamp Parameters -> VirtualHosts submenu". I right-clicked the Wamp icon and nothing says Wamp Parameters.

Any help would be appreciated!

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: Otomatic (Moderator)
Date: October 08, 2018 09:22AM

Hi,

> I right-clicked the Wamp icon
Wampmanager tray icon

> Any help would be appreciated!
Please : READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 08, 2018 06:39PM

1 - Windows version used (Specify version number AND whether 32 or 64 bit) – Windows 10 64 bit
2 - Version WampServer (Specify version number AND whether 32 or 64 bit) – 3.1.4 64 bit
3 - Apache Version – 2.4.35
4 - PHP Version – 7.2.10
5 - MySQL Version – 5.7.23
5a - MariaDB version if applicable – N/A
6 - What color is the WampServer icon (in the notification area of the taskbar) – Green
7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines?
#
127.0.0.1 localhost
::1 localhost
If the WampServer icon is green:
8 - Do you have access to localhost (Homepage WampServer)? Yes
8a - If so, is there an error message at the bottom of the page? No
9 - Do you have access to phpMyAdmin? Yes
10 - If you refer to an error message, please include the EXACT wording of the error in your post – N/A
11 - If you use an Antivirus and / or Firewall, please include the names of these – Avast (free version) & Windows Defender Firewall
12 - What is the full path to the installation of WampServer (eg D:\wamp\) – C:\wamp64
13 - If you have one or more Virtual Hosts defined, please show their definition(s) – Your VirtualHost -
localhost

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: Otomatic (Moderator)
Date: October 08, 2018 06:51PM

Hi,

You have a problem installing Wampserver or making unwanted file changes.

With Wampserver 3.1.4, the menu item "Your VirtualHosts" is enabled by default:


And the right-click on the icon shows the item "Wamp Settings":


This may be due to the fact that you installed Wampserver 3.1.4 when you were not up to date with the VC++ redistributable packages.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 08, 2018 07:22PM

Thanks for the information. I will uninstall and start the process over again.

Options: ReplyQuote
Re: Uninstalled Wamp Wrong
Posted by: sauergirl (---.dhcp.fdul.wi.charter.com)
Date: October 08, 2018 08:49PM

My new virtualhost is all set up. On to my next adventure, setting up wordpress. Again, thank you both for all your help!

Options: ReplyQuote


Sorry, only registered users may post in this forum.