which wampserver does meet the below requirement
Posted by: binjoder (---.revip6.asianet.co.th)
Date: September 18, 2018 03:37AM

please help me i need wampserver that does meet this requirements Database client version: libmysql - 5.1.73

PHP version: 5.6.30 PHP extension: mysqli curl mbstring

i dont want mysqlnd in it at all.

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: Otomatic (Moderator)
Date: September 18, 2018 09:15AM

Hi,

You install Wampserver 3.1.3 32 bit and then you have dozens of PHP and MySQL versions in "addons".

Nevertheless, MySQL 5.1.73 is a very old version.
Note : The latest version in branch 5.1 is 5.1.72. Version 5.1.73 does not exist.

On http://wampserver.aviatechno.net/ clic on "See all available version"

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 09/18/2018 09:54AM by Otomatic.

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: binjoder (---.revip6.asianet.co.th)
Date: September 19, 2018 10:06AM

thank you for replay . infect my problem with mysqlnd in the php if it is possible to mod php 7 or 5.6 to use libmysql client instead of mysqlnd because the script am welling to work with reject mysqlnd and accept libmysql client.



please help

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: Otomatic (Moderator)
Date: September 19, 2018 12:30PM

Hi,

It is up to the script designer to ask which PHP and MySQL versions are supported.
And if it only supports very old versions, you have to change the script.

Wampserver supports PHP from version 5.3.0 to version 7.2.10 and MySQL from version 5.1.72 to version 5.7.23

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: binjoder (---.revip6.asianet.co.th)
Date: September 19, 2018 01:08PM

the script work with php 7 and mysql 5.1 and above the only problem it is not support mysqlnd it does support libmysql client as mysql connector and as standard php 5.3+ and above in windows are packed with mysqlnd connector but it can be changed manually modification. still big hosting companies didnt shift to mysqlnd and alot of scripts doesn't work with mysqlnd. hence also wampserver will be useless when it comes to this aspect. it should be there is two versions of wamp one does support mysqlnd and another support mysql library client connector as addon for each php ver from 5.6 and above. but all modification should be in the php.

I have been trying php.net to seek for help but i guess you are more expert than me in this modification part at least one php version ie php7 should be modified as wamp addon to use mysql library client instead of mysqlnd connector in php.

[php.net]

[www.phptutorial.info]



Edited 1 time(s). Last edit at 09/19/2018 01:16PM by binjoder.

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: Otomatic (Moderator)
Date: September 19, 2018 03:04PM

Hi,

> I have been trying php.net to seek for help but i guess you are more expert than me in this modification
> part at least one php version ie php7 should be modified as wamp addon to use mysql library
> client instead of mysqlnd connector in php.
mysql lib instead of mysqlnd is BEFORE php 5.3.0 i.e. PHP 5.2

We use all PHP versions exactly as they are provided by php.net in the download section: [windows.php.net] for recent versions
And in the archives section of php.net for older versions: [windows.php.net] All these PHP files are used as they are, without any modification.

It is impossible to modify a PHP distribution for Windows to replace the mysqlnd library by the mysql library.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: binjoder (---.revip6.asianet.co.th)
Date: September 19, 2018 03:23PM

alright thanks alot , I will wait feedback from php.net . might reach solution to resolve this problem

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: binjoder (---.revip6.asianet.co.th)
Date: September 19, 2018 03:38PM

[windows.php.net]

provide you the source file of the php"s . by modifying and recompiling I believe it will work . as for linux there are code while compiling choose between one of them.

compiles with mysqlnd
$ ./configure --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-mysql=mysqlnd

compiles with libmysql
$ ./configure --with-mysqli=/path/to/mysql_config --with-pdo-mysql=/path/to/mysql_config --with-mysql=/path/to/mysql_config

one compiler and one source file but different option

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: Otomatic (Moderator)
Date: September 19, 2018 04:01PM

Hi,

> by modifying and recompiling I believe it will work

Read my previous answer again: « We use all PHP versions exactly as they are provided by php.net in the download section »

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: which wampserver does meet the below requirement
Posted by: binjoder (---.revip6.asianet.co.th)
Date: September 19, 2018 04:23PM

alright got it smiling smiley

Options: ReplyQuote


Sorry, only registered users may post in this forum.