function.session-start not working with Zend optimizer
Posted by: iainmcwhirter (
Date: March 23, 2006 03:48PM

WAMP has worked fine for me for many years but I've installed Zend Optimizer today in order to try out an application that requires it. As soon as it is installed any of my current applications that were working fine now fail with an error similar to

Warning: session_start() [function.session-start]: open(../tmp\sess_25943a56182e4c3affc62b93ce16c08f, O_RDWR) failed: No such file or directory

Looking at php.ini the only changes before and after installing Zend are right at the bottom where the following two lines were added


Uninstalling Zend solves the error but I'm at a loss as to why the error should happen with Zend installed. Removing the lines from php.ini doesn't solve it so I'm guessing it's something more fundamental. Any idea ?

Re: function.session-start not working with Zend optimizer
Posted by: videogameplayer (
Date: March 23, 2006 08:55PM

if you look at the error message, it's written "./tmp\ses", there is a slash and an anti-slash, search in php.ini the paths where there is a / and change it to \ (search and replace, replace all is a good idee)

Re: function.session-start not working with Zend optimizer
Posted by: CyberSpatium (
Date: March 24, 2006 01:21AM

The problem is for some reason WAMP does not set the session directory setting in the php.ini file correctly. so, you need to change this setting.

FInd this liine:
session.save_path = "../tmp"

Change it to this:
session.save_path = "C:\WINDOWS\Temp"

Save the file, and restart apache for the settings to take effect.

Sorry, only registered users may post in this forum.