Upgrade MySql and php to latest version
Posted by: sandeep87 (137.59.66.---)
Date: August 26, 2018 12:10PM

Latest version of WAMP has below

Wampserver 3.1.0 64 bit x64 – Apache 2.4.27 – PHP 5.6.31, 7.0.23, 7.1.9 – MySQL 5.7.19 – MariaDB 10.2.8 – PhpMyAdmin 4.7.4 – Adminer 4.3.1 – PhpSysInfo 3.2.7

But versions of PHP and MySQL are not latest, PHP latest version is 7.2 where as MySQL 8

Can we upgrade them both with in WAMP to latest version ???

Or

Can we install all the components separately which are provided in WAMP and make them work together ??

Thanks in advance.

Options: ReplyQuote
Re: Upgrade MySql and php to latest version
Posted by: Otomatic (Moderator)
Date: August 26, 2018 01:38PM

Hi,

> Latest version of WAMP has below Wampserver 3.1.0 64
No. The latest version is 3.1.3
On Sourceforge:
Wampserver 3.1.3 64 bit x64
On the secondary deposit:
Wampserver 3.1.3 64 bit x64 - Apache 2.4.33 - PHP 5.6.35/7.0.29/7.1.16/7.2.4 - MySQL 5.7.21 - MariaDB 10.2.14

> Can we upgrade them both with in WAMP to latest version ???

- 1 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 2 - pply Update 3.1.3 to your version of Wampserver
Wampserver update 3.1.3

- 3 - Read WAMPserver 3 - All you need to know to see all available "addons" for Apache, PHP, MySQL, MariaDB and applications such PhpMyAdmin or Adminer.

- 4 - Download "addons" you want then install them "as an administrator"

- 5 - Launch Wampserver then Left-Click on Wampserver tray icon:
--- PHP -> Version -> to change the version
--- MySQL -> Version -> to change the version
and so on for Apache or MariaBD.

Important Reminder: The transfer of databases between different versions of MySQL or MariaDB should be performed by EXPORT / IMPORT of SQL files using phpMyAdmin or a similiar tools of your choice.
Do not copy the data folder between different versions of MYSQL. Databases from different versions of MYSQL are VERY unlikely to be compatible! You will also destroy the version of MYSQL that you copied the data folder to.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.10/7.1.22/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.9
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.10/7.1.22/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.9
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 08/26/2018 03:22PM by Otomatic.

Options: ReplyQuote
Re: Upgrade MySql and php to latest version
Posted by: sandeep87 (137.59.66.---)
Date: September 01, 2018 01:56PM

Thanks Otomatic

i have installed WAMP 3.1.3

Please look at the screenshot
[imgur.com]

in the wamp tray , i cannot see MySQL. Can someone help me here ??

Have i missed anything ???

I can see there is significant difference in the size of the installation file (.exe) for 3.1.0 and 3.1.3 (75 Mcool smiley

Options: ReplyQuote
Re: Upgrade MySql and php to latest version
Posted by: Otomatic (Moderator)
Date: September 01, 2018 02:34PM

Hi,

In the answer I gave you in private messaging I indicated that you had to answer first to : READ (and answer) BEFORE YOU ASK A QUESTION

> I can see there is significant difference in the size of the installation file (.exe) for 3.1.0 and 3.1.3
Wampserver 3.1.0 installers no longer exist.

And it is normal that the size of the installers is no longer the same, the versions of Apache, PHP, Mysql and MariaDB are no longer the same either.
What is important is not the size of the file but its MD5 signature which must correspond to the one indicated on the download page, for example

998d913775ce151d7e1c2de5db460a25 pour Wampserver 3.1.3 64 bit

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.10/7.1.22/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.9
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.10/7.1.22/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.9
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.