Upgrading to Apache 2.4.xx and PHP 7.X.X simultaneously - Solution to error: Versions not compatible
Posted by: rxrydre (103.218.102.---)
Date: August 13, 2018 10:13AM

In this thread, I am presenting solution to the error "PHP version not compatible with Apache version", and vice-versa "Apache version not compatible with PHP version" that you mat get after adding PHP 7.X.X and Apache 2.4.X files to the 'bin' folder

This is continuation of the thread [forum.wampserver.com] (How to update to Apache 2.4.X on WampServer).

I am using a Windows 7.

It is assumed that you have installed allow the required Windows Updates that are necessary.


Now, open the wampmanager.conf file and edit the following two lines:

phpVersion = "7.X.X" (7.X.X is whichever version you intend to use)
apacheVersion = "2.4.34"

It worked in my case.

Thank you WampServer!

Options: ReplyQuote
Re: Upgrading to Apache 2.4.xx and PHP 7.X.X simultaneously - Solution to error: Versions not compatible
Posted by: Otomatic (Moderator)
Date: August 13, 2018 10:50AM

Hi,

There's no need for any file editing or tricks to get the latest versions of Apache and PHP on Wampserver 3.
Simply download the appropriate addons and install them, even under Windows 7.
See WAMPserver 3 - All you need to know

Then, to change Apache or PHP version, there is no need to edit a file(*) just, after installing the necessary addons to perform :
- Left-Click Wampmanager tray icon -> Apache -> Version -> choose the version you want
same thing for PHP, MySQL or MariaDB.

(*) Editing the wampmanager.conf file to change an Apache or PHP version number can generate insoluble errors. You do not know all the implications that this can generate.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.5 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.5 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.