Windows user not administrator ??? Strange errors
Posted by: giovannino (178.236.161.---)
Date: August 07, 2018 03:14PM

Dear all,
I'm not a tech guy so I'm here to have some hints or help.
I did an installation of 3.1.3_x64 on a PC where run a PHP application and myslq db .
I used an administrator user i.e. admin to make installation. The icon of WS is green when I use this user.
This PC is within a hospital lan network and the internal security policy do not admit to have user with administrator grant level in any present PC.
They have created a normal netuser just to fulfill the company policy.
I created into mysql that user too with all priviledges just access to data.
When I login with this las1t netuser , wampserver runs on background, but , if I try to click on desktop icon then the small icon remains red. If I do refrest there are some errors about hosts... not possible to write...
Application run the same and data are recorded on db the same.

Now, after some time the browser stop with a error like that
(Fatal error: Call to undefined function mb_convert_encoding() in nm utf8.php on line 75) and the application stop to work.

Call to undefined function mb_convert_encoding()

I googled a bit but mb_string extension is active .... the installation was succesful .

I think is something more connected to the user than php setting..

Any help will be very appreciated.



Edited 1 time(s). Last edit at 08/07/2018 03:20PM by giovannino.

Options: ReplyQuote
Re: Windows user not administrator ??? Strange errors
Posted by: RiggsFolly (Moderator)
Date: August 07, 2018 03:16PM

The user that runs WAMPServer need to ba able to start services. Without that priviledge wampmanager cannnot do its job.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Windows user not administrator ??? Strange errors
Posted by: Otomatic (Moderator)
Date: August 07, 2018 05:38PM

Hello,

This is a translation of a contribution that I had posted on the French forum Wampserver.

I have test launching of WampServer - thus starting wampapache and wampmysqld services - in a "standard" user session that is to say without administrator privileges, and it works on my session W7 or W10 Pro 64-bit with two users:
- "Dominique" administrator
- "Otomatic" standard user

Everything that follows is to be performed in an administrator session:
This means that if you want to do this on a workstation that is part of an enterprise network, you will need to call your network administrator or IT manager.

Download the utility "Setacl.exe" the free version from the command line on the website [helgeklein.com]
This version:
Administrators: Download the EXE version of SetACL 3.0.6 for 32-bit and 64-bit Windows.

Unzip the file, which will create a folder: SetACL (executable Version)\ in which there are two other folder for 32 bit and 64 bit versions.
Open a command window into the 32 or 64 bits folder depending on the version of Windows. If you have a Windows 64-bit, it is imperative to run the 64-bit version of setacl.
In the command window, we will give the rights to a user to start, stop and read wampapache, wampmysqld and wampmariadb services, in my case the user without rights "Otomatic."
Generic command is:
setacl -on "service_name" -ot srv -ace "n:user_name_without_rights;p:start_stop,read" -actn ace
which gives the following two commands for WampServer:
setacl -on "wampapache" -ot srv -ace "n:Otomatic;p:start_stop,read" -actn ace
setacl -on "wampmysqld" -ot srv -ace "n:Otomatic;p:start_stop,read" -actn ace
setacl -on "wampmariadb" -ot srv -ace "n:Otomatic;p:start_stop,read" -actn ace
Of course:
- you replace Otomatic by the name of the user you want to allow to start the services.
- you replace service names by wampapache64, wampmysqld64 and wampmariadb64 if uou use Wampserver 64 bit.
The user account must exist before performing the commands.

By connecting with Otomatic session, I can start WampServer, which starts the services and pass the icon green with access to localhost and phpMyAdmin.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Windows user not administrator ??? Strange errors
Posted by: giovannino (---.51-151.wind.it)
Date: August 07, 2018 06:37PM

Great reply ;-)) Many thanks !!!
I will implemenr it tomorrow

If I go to services as adminstrator and then I go to change the account on each of three running services specifing that one of administrator is it not the same ? Sorry for stupid question but I'm not a programmer....

Options: ReplyQuote
Re: Windows user not administrator ??? Strange errors
Posted by: Otomatic (Moderator)
Date: August 07, 2018 07:19PM

Hi,

> If I go to services as adminstrator and then I go to change the account on each of three
> running services specifing that one of administrator is it not the same ?
If, after a lot of time and testing, I came to use setacl, it's because I didn't find any other solution; which doesn't mean that there wouldn't be another one.

And, as marked in red, this means that to use setacl, you must open an administrator session under the same account with which you installed Wampserver, so created the services.
That's the way I did it. Maybe there are other ways, but I don't know, never having tried it.

All the answers I give in the Wampserver forums have all been actually checked, unless otherwise duly mentioned.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Windows user not administrator ??? Strange errors
Posted by: giovannino (---.51-151.wind.it)
Date: August 08, 2018 05:18PM

Hello Otomatic,
I did it now and it seems to work ;-)))))
Many thanks again
Giovanni

Options: ReplyQuote


Sorry, only registered users may post in this forum.