"Save" on php.ini file won't stick
Posted by: adhdcelt (---.hsd1.tn.comcast.net)
Date: August 05, 2018 06:43AM

Can someone please address this question for me?

I have a WAMP 4.9.7 local install.
I opened the php.ini file in the apache2.4.33/bin folder and changed the max_upload_filesize setting so I could upload files that exceed the 2M default.

Every time I do this, save the file, Exit WAMP, and restart WAMP, that setting I saved reverts back to the default. The other php.ini files in the wamp/php folder don’t do this.

After I save the file and restart WAMP, wordpress tells me that the upload limit is still 2M and won't let me upload a 6M file.

I have never seen this in the past with other local installs I've done in WAMP. This is chimpanzee stuff: You just change the upload_max_filesize setting, save the file, and you can upload files to the limit you set. Simple.

Why is the php.ini file reverting back to the default after I save it?

Any help here is greatly appreciated.

Options: ReplyQuote
Re: "Save" on php.ini file won't stick
Posted by: Otomatic (Moderator)
Date: August 05, 2018 09:14AM

Hi,

Left-Click Wampmanager tray icon -> PHP -> PHP settings -> upload_max_filesize -> Value you want

Note : WAMP 4.9.7 doesn't exist.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: "Save" on php.ini file won't stick
Posted by: adhdcelt (---.hsd1.tn.comcast.net)
Date: August 05, 2018 07:22PM

DUH!!!
That's the latest version of wordpress!
Sorry 'bout that.

Options: ReplyQuote
Re: "Save" on php.ini file won't stick
Posted by: adhdcelt (---.hsd1.tn.comcast.net)
Date: August 05, 2018 08:04PM

OMG!!!!!!!!

O---M---G!!!!!!!!!!

WHO ARE YOU?!!!!
I don't care; male or female: I LOVE YOU JUST THE SAME!

Thank you so much!
Where would the rest of us chimps be without with wizards like you?!
There'll be a little somethin' extra in your check next week!

Options: ReplyQuote
Re: "Save" on php.ini file won't stick
Posted by: Otomatic (Moderator)
Date: August 05, 2018 08:22PM

Hi,

> WHO ARE YOU?!!!!

Who am I? Who am I? You didn't make the connection with my nickname!
Left-click on the Wampmanager tray icon and what can you read at the top?

It is easier to answer certain questions when you are the product designer winking smiley

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.