Latest Error installling wampServer apache service not running
Posted by: SPKASHYAP (---.130.71.182.airtel.in)
Date: July 29, 2018 12:36PM

Hello Sir, I installed WAMP server but only two services were installed.
wampapache64 service is not running.
On starting the service it is giving error like this:

"Could not execute menu item (internal error)
[exception ] could not performed service action:
The service did not respond to the start or control request in a timely fashion"

Please try to resolve

Options: ReplyQuote
Re: Latest Error installling wampServer apache service not running
Posted by: Otomatic (Moderator)
Date: July 29, 2018 01:36PM

Hi,

- 1 - READ (and answer) BEFORE YOU ASK A QUESTION

- 2 - - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

- 3 - TROUBLESHOOTING TIPS

This forum is not just a forum for writing.
You have every right to search and READ the answers already given.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.34 - PHP 7.2.8/7.1.20/7.0.31/5.6.37 - MySQL 5.7.23 - MariaDB 10.3.8
Wampserver 3.1.3 64 bit - Apache 2.4.34 - PHP 7.2.8/7.1.20/7.0.31/5.6.37 - MySQL 5.7.23 - MariaDB 10.3.8
PhPMyadmin 4.8.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Latest Error installling wampServer apache service not running
Posted by: rhf (136.53.10.---)
Date: July 29, 2018 02:11PM

I had the same problem updating from php 7.0.4 (which works fine) to 7.2.8. The icon stays orange.
Running WAMPserver Tools: Check state of services and Check httpd.conf syntax. I get Error on line 183- could not load modules/mod_ssl.so. (The module is there.)
If I comment that line out, the apache server will load, but I get several errors in the Windows Event Viewer; such as
php[11000] PHP Warning: PHP Startup: Unable to load dynamic library 'curl' (tried: c:/wamp64/bin/php/php7.2.8/ext/curl (The specified module could not be found.), c:/wamp64/bin/php/php7.2.8/ext/php_curl.dll (The specified module could not be found.)) (C:\wamp64\bin\apache\apache2.4.18\bin\httpd.exe -d C:/wamp64/bin/apache/apache2.4.18)
I also get similar errors for openssl and ldap.
By the way, I did run check_vcredist.exe and all VC++ packages are installed correctly.

Options: ReplyQuote
Re: Latest Error installling wampServer apache service not running
Posted by: Otomatic (Moderator)
Date: July 30, 2018 09:57AM

Hi,

Is Apache 2.4.18 compatible with PHP 7.2.8?

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.34 - PHP 7.2.8/7.1.20/7.0.31/5.6.37 - MySQL 5.7.23 - MariaDB 10.3.8
Wampserver 3.1.3 64 bit - Apache 2.4.34 - PHP 7.2.8/7.1.20/7.0.31/5.6.37 - MySQL 5.7.23 - MariaDB 10.3.8
PhPMyadmin 4.8.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Latest Error installling wampServer apache service not running
Posted by: rhf (136.53.10.---)
Date: July 30, 2018 03:53PM

That was it!
I upgraded to Apache 2.4.34, and everything now appears to work properly.
Thank you very much!

Options: ReplyQuote


Sorry, only registered users may post in this forum.