can not visit from internet. please help. suddenly can not visit
Posted by: cnah66 (60.173.239.---)
Date: June 20, 2018 05:23AM

after reinstall can not visit too.

3.1.3 64bit
win10

green local server - all services are running

Your port 80 is actually used by :

Server: Apache/2.4.33 (Win64) PHP/5.6.35

--------------------------------------------------
<Directory />
    AllowOverride none
#   Require all denied
    Require all granted
</Directory>


#   onlineoffline tag - don't remove
#   Require local
    Require all granted
-------------------------------------------------------------------------------
# Virtual Hosts
#
<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
#		Require local
		Require all granted
  </Directory>
</VirtualHost>
#
<VirtualHost *:80>
	ServerName www.engxx.com
	DocumentRoot "h:/web/engxx"
	<Directory  "h:/web/engxx/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
#		Require local
		Require all granted
	</Directory>
</VirtualHost>
#
<VirtualHost *:80>
	ServerName www.4chan.site
	DocumentRoot "h:/web/4chan"
	<Directory  "h:/web/4chan/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
#		Require local
		Require all granted
	</Directory>
</VirtualHost>
#


#
<VirtualHost *:80>
	ServerName www.1se.top
	DocumentRoot "h:/web/1se"
	<Directory  "h:/web/1se/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
#		Require local
		Require all granted
	</Directory>
</VirtualHost>



Edited 1 time(s). Last edit at 06/20/2018 11:11AM by RiggsFolly.

Options: ReplyQuote
Re: can not visit from internet. please help. suddenly can not visit
Posted by: RiggsFolly (Moderator)
Date: June 20, 2018 11:21AM

Hi,

You do not give us much information to help us help you! Did you reinstall Windows or just WAMPServer?

However here are some suggestions.

First this section of httpd.conf that you changed

<Directory />
    AllowOverride none
#   Require all denied
    Require all granted
</Directory>


#   onlineoffline tag - don't remove
#   Require local
    Require all granted


should not have been changed, so change it back to

<Directory />
    AllowOverride none
   Require all denied
</Directory>


#   onlineoffline tag - don't remove
    Require local

as your change will allow access to ALL THE DRIVE that Apache is installed onto !!!!

Access to your virtual host sites is controlled from httpd-vhosts.conf for all virtual hosts.


Now the Virtual Host definition controlling `localhost` should also NOT be accessible from the internet so change

# Virtual Hosts
#
<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
#		Require local
		Require all granted
  </Directory>
</VirtualHost>

TO

# Virtual Hosts
#
<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
    Require local
  </Directory>
</VirtualHost>


Now the other Virtual Hostsed sites should work so I would check your Firewall settings as that is the most likely thing that would block access from the internet.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.