Customize doesn't commit changes to front end
Posted by: martinvanstein (---.cm-3-4b.dynamic.ziggo.nl)
Date: May 25, 2018 10:50PM

Hi all,

I am having a bit of an issue with "customize" on any theme

I have checked if it worked on the live site and there i can import a logo, change its size, reposition it and other than logo related stuff I can basically adjust everything, see it in the preview and when I hit save/publish , it commits to the front end.

However when I export the exact same site and try to do it locally it doesn't work and I have tried multiple themes at this point to make sure this is true across the board.

So for some reason the changes I make in customize on a local site, don't stick.

I have created a virtual host, but that doesn't do anything either .... and I am still unsure as to why this is so important to create as it works exactly the same for me as if I didn't use it.

At any rate I would be very grateful if someone could help me out with this one, as this past week I have only been dealing with issues trying to get things to work locally and it is very annoying not making any progress.

Options: ReplyQuote
Re: Customize doesn't commit changes to front end
Posted by: Otomatic (Moderator)
Date: May 26, 2018 11:21AM

Hi,

> I am having a bit of an issue with "customize" on any theme
My crystal ball and my pendulum suggest that it could be, among hundreds of CMS and thousands of Web applications, Wordpress.
Keep in mind that Wordpress writes the url of its installation to the database and you have to modify this path between the remote installation and the local installation.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Customize doesn't commit changes to front end
Posted by: martinvanstein (---.cm-3-4b.dynamic.ziggo.nl)
Date: May 26, 2018 12:00PM

Okay, so I have done the following.

I made changes in the back end, through the "customize" feature in the backend of the local site.
Changes made show up in the backend preview, but do not get committed to the local front end site.
At first I thought it was a bug in the theme I used, so I tried other themes and they displayed the same behaviour.

So what I did next, I uploaded these exact same files to another domain I have( but haven't really used yet) and the changes I made in the back end, do show up in the front end on the live site.

So if my logic is correct, it isn't a theme related issue as it is with multiple other themes as well, it can't be a wordpress specific issue as then the changes I mad would not have come through on the live site.

So it has to be something in WAMP/local environment that causes this behaviour, or am I missing something here?

Options: ReplyQuote
Re: Customize doesn't commit changes to front end
Posted by: martinvanstein (---.cm-3-4b.dynamic.ziggo.nl)
Date: May 26, 2018 03:10PM

I think I have found something... though it doesn't get my any further.
For some reason everytime I load the local website, it creates a WP-Content folder on my root drive C:/
I delete it, but at every reload/refresh of the webpage it comes back up again.

The fun part is that when I copy and past the folder and its contents into the one on teh C drive, changes do get committed

Will look further to see what is going wrong here...I disabled real time scanning/skype/firewall and it still keeps creating this folder on the C drive.

And I installed it using duplicator pro, manually aswell as using the default path duplicator has put in as I thought it had something to do with WP not having a path, but that didn't work either..
Any ideas are of course appreciated..

I have done the virtualhost thing but when I click on that one, it also creates a wp-content folder on teh root drive

Options: ReplyQuote
Re: Customize doesn't commit changes to front end
Posted by: Otomatic (Moderator)
Date: May 26, 2018 03:33PM

Hi,

See thois thread -> [forum.wampserver.com] as it is used Duplicator Pro.

I repeat, once again, that this is a problem due to Wordpress hard writing its url in the database.
So, after transferring the site locally, the installation url is no longer the same and, if you do not change it yourself, Wordpress will not do it for you.
End of my explanations which largely went beyond the role of this forum.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Customize doesn't commit changes to front end
Posted by: martinvanstein (---.cm-3-4b.dynamic.ziggo.nl)
Date: May 27, 2018 12:35PM

I have made a bit of progress in my investigation of the problem.
And it seems it can be boiled down to with the theme ( not just the theme I use but also when I install another).

For some reason ( no matter where or how I install), when I create a local site….some process creates a wp-content folder on the root of the drive I installed WAMP on .
In that folder are certain themify css files and the image upload.

Every time I make a change I have to copy the contents of the folder on the root to its corresponding webdirectory and then hard refresh the site and then changes I've made stick.

As to the directories thing , I have done multiple installations, on multiple drives and all kinds of variables and all produce the same result .
Atm I have a virtual host running and although I don't see much difference compared to a localhost install I don't want to tempt fate too much.

I know it is a bit of a broken workflow atm, with the copying of things, but at some point you have to move on and at least I can do things now..even though it is very tedious to manualy copy over files all teh time

Options: ReplyQuote
Re: Customize doesn't commit changes to front end
Posted by: Otomatic (Moderator)
Date: May 28, 2018 04:19PM

Hi,

Result of:
Right-Click -> Tools -> Show VirtualHost examined by Apache

Content of files :
- wamp\bin\apache\apache2.4.33\conf\extra\httpd-vhosts.conf

- C:\Windows\System32\drivers\etc\hosts

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.