How to apply 3.1.3 update on 3.1.0?
Posted by: momon (---.213.95.88.customer.cdi.no)
Date: March 28, 2018 06:20PM

Hello,

I have installed WampServer 3.1.0 (x64) and tried to install the 3.1.3 update over it when the setup wizard refused to continue:

"The installation folder chosen is not that of Wampserver version 3."

I am just trying to follow the instructions of the readme:

"##### After installing Wampserver 3.1.0, you are strongly encouraged to apply the 3.1.3 update which, among other things, fixes an XSS vulnerability."

More specifically, these are the files I have:
- wampserver3.1.0_x64.exe
- wampserver3_x86_x64_update3.1.3.exe

Windows version: Windows 10 Pro version 1709.



Edited 1 time(s). Last edit at 03/28/2018 06:21PM by momon.

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: Otomatic (Moderator)
Date: March 28, 2018 06:46PM

Hi,

In which folder is your version 3.1.0 of Wampserver installed?

If it's in J:\wamp64, that's what you need to see in the form before you validate Next to proceed with the installation.



------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: momon (---.213.95.88.customer.cdi.no)
Date: March 28, 2018 06:53PM

Thank you for youre reply!

It's a fresh OS installation and fresh installation of WampServer, so I am only trying to install the update in the directory where I initially installed WampServer (C:\wamp64). C:\wamp does not exist, so there is no confusion.



Edited 1 time(s). Last edit at 03/28/2018 06:54PM by momon.

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: momon (---.213.95.88.customer.cdi.no)
Date: March 28, 2018 07:05PM

This was unexpected but I figured out how to install the update. I had to run wampmanager once before being able to install the update.

Since this makes initial installation more complicated (I am writing instructions for students), I hope this can be fixed in the future.

Thank you!



Edited 2 time(s). Last edit at 03/28/2018 07:05PM by momon.

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: Otomatic (Moderator)
Date: March 28, 2018 07:37PM

Hi,

You are right, after the installation, you must have launched Wampserver at least once for the detection of the installation folder to be correct for updates.
Indeed, the update checks that in the selected folder there are the files :
- wampmanager.exe
- wampmanager.conf
- wampmanager.tpf
- wampmanager.ini

So far, so good, these four files are present just after the installation.

But then, the update will check that in the wampmanager.ini file there is the string :
WampServer Version 3
but, this string is created only at the first launch of Wampserver.

I'll look for another way of checking that doesn't involve running Wampserver at least once.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: momon (---.213.95.88.customer.cdi.no)
Date: March 28, 2018 07:44PM

Thank you, I appreciate it! smiling smiley

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: Otomatic (Moderator)
Date: March 29, 2018 12:25PM

Hi,

It's always called the same way:
On 'http://wampserver.aviatechno.net'
wampserver3_x86_x64_update3.1.3.exe

or on Sourceforge
wampserver3_x86_x64_update3.1.3.exe

But this 3.1.3 update has been modified to be installed on Wampserver 3.1.0 right after its installation and without the need to run it before applying the update.

Of course, you are obliged to re-download this update whose MD5 has also been changed.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 03/29/2018 12:25PM by Otomatic.

Options: ReplyQuote
Re: How to apply 3.1.3 update on 3.1.0?
Posted by: momon (---.213.95.88.customer.cdi.no)
Date: March 29, 2018 09:17PM

Hello,

I can confirm that the 3.1.3 update can now be applied over a fresh 3.1.0!

Thank you very much!

Options: ReplyQuote


Sorry, only registered users may post in this forum.