how to avoid the https prefix obligation in browsers?
Posted by: LivingThis (---.cm-6-1d.dynamic.ziggo.nl)
Date: March 15, 2018 10:56AM

I have an https / apache problem I can't solve and I would like to receive some help if possible.

My virtual hosts cant be reached anymore (except with localhost) in 2 browsers (Firefox and Chrome).

I assume the reason is that both browsers now oblige to use https, but I dont want to install a certificate for my virtual hosts.

Are there any settings I can adjust in the apache configuaration files or should I solve this 'browserside' (which I didnt manage) ?


Please help.

Options: ReplyQuote
Re: how to avoid the https prefix obligation in browsers?
Posted by: RiggsFolly (Moderator)
Date: March 15, 2018 11:20AM

Hi

Its not a problem at the WAMPServer end. This is purely the browser.

Are you using a .dev extension on your Virtual Hosts. We all used to do that and you will find posts here suggesting that.

However, recently Google purchased and now owns the .dev tLD so you should consider using something else instead, specially if you are using Chrome browser as google could add anything in there to pick up the use of .dev and, well, do anything.


Also as of V63 Chrome does in fact force a redirection of .dev and attempts to assume a HTTPS connection.

The simplest solution is to change your Virtual Host and HOSTS file and use something other than .dev as the domain extension.

I have started using .test or you might like .local, these are just examples you can pick anything you like.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: how to avoid the https prefix obligation in browsers?
Posted by: LivingThis (---.cm-6-1d.dynamic.ziggo.nl)
Date: March 15, 2018 12:13PM

I made a new virt host called *.test and one called *.ddev, but both didnt work.


I also tried *.localhost as virtual tld, BUT .. I had to use a Empty Cache Hard Reload in Chrome before I got it working.

So it seems to work only for one tld.



Edited 1 time(s). Last edit at 03/15/2018 12:31PM by LivingThis.

Options: ReplyQuote
Re: how to avoid the https prefix obligation in browsers?
Posted by: RiggsFolly (Moderator)
Date: March 15, 2018 03:16PM

Sorry I dont understand.

Maybe if you show your Virtual Host definitions

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: how to avoid the https prefix obligation in browsers?
Posted by: Otomatic (Moderator)
Date: March 15, 2018 03:27PM

Hi,

What is the result of :
- Right-Click wampmanager tray icon ->Tools -> Sow VirtualHost examined by Apache

Did you perform a DNS restart after modifying the VirtualHost and the hosts file with the related tld
- Right-Click wampmanager tray icon -> Tools -> Restart DNS

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
PhPMyAdmin 4.8.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.