wamp icon orange, Bind port error 3307
Posted by: rpjd (37.228.229.---)
Date: March 10, 2018 03:08AM

Windows10-64bit
wamp version-3.1.0 64bit
apache-2.4.27
php-5.6.31
mysql-5.7.19
icon-orange
127.0.0.1
localhost ::1 localhost,
localhost
-yes
8a-no
9-yes
11-Avira
c:/wamp64

I recently re-installed wampserver and the icon was green. Not sure why, but on subsequent starts its staying orange. After reading some posts on this, the suggested problem is either apache or mysql not starting. I checked the apache service, Start/Resume Service is greyed out so Apache is running.
Under Tools, I clicked Test Port 3306 Post used by MySQL, the output is

***** Test which uses port 3306 *****

===== Tested by command netstat filtered on port 3306 =====


Test for TCP
Your port 3306 is used by a processus with PID = 11840
The processus of PID 11840 is 'mysqld.exe' Session: Services
The service of PID 11840 for 'mysqld.exe' is 'wampmysqld64'
This service is from Wampserver - It is correct

So according wamp to Apache is running and according to netstat MySQL is running, so why is the icon orange? Another post suggested looking at windows services log.

Control Panel->System and Security->Administrative Tools->Event Viewer->Windows Logs->Application
For MySQL

Can't start server: Bind on TCP/IP port. Got error: 10048: Only one usage of each socket address (protocol/network address/port) is normally permitted
Do you already have another mysqld server running on port: 3307 ?
For more information, see Help and Support Center at http
Aborting

In mysql console, show variables displays
bind_address | *

Can anyone explain what this means?


N.B. Not getting any emails about replies to my posts, despite ticking "Email me about replies to this topic" option.

Options: ReplyQuote
Re: wamp icon orange, Bind port error 3307
Posted by: Otomatic (Moderator)
Date: March 10, 2018 09:27AM

Hi,

If the icon is not green, it means that one or more services are not started.
A tool integrated in Wampserver allows you to see it:
Right-Click -> Tools -> Check state of services.

On the other hand, if you don't use MariaDB, it is better to disable it, there also by the parameters integrated in Wampserver:
Right-Click -> Wamp settings -> Allow MariaDB to uncheck it

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.7/7.1.19/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.3.8
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.7/7.1.19/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.3.8
PhPMyAdmin 4.8.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wamp icon orange, Bind port error 3307
Posted by: rpjd (37.228.229.---)
Date: March 10, 2018 05:25PM

Right-Click -> Wamp settings -> Allow MariaDB to uncheck it. Icon changed to green. Thanks. As I mentioned previously, I didn't get an email about replies.

Options: ReplyQuote


Sorry, only registered users may post in this forum.