Trying to update now nothing works
Posted by: joenmalo (---.genericrev.cantv.net)
Date: March 05, 2018 10:36PM

Hi

I just trying to update wampserver from 3.08 to 3.1.0, everything was ok, but icouldn't see my web page from outside my network. I return back to the previous version and was ok. Tried again to install the new version and fail. Now when i trying to go back to the old version 3.08 this also fail. here is my data.

YES i click PUT OLINE button.

He are some answers i pickup from another topic,
1 - Windows version used (Specify version number AND whether 32 or 64 bit) Windows server 2008 64-bit
2 - Version WampServer (Specify version number AND whether 32 or 64 bit) Wampserver64 3.1.0x64
3 - Apache Version 2.4.27
4 - PHP Version 7.1.9
5 - MySQL Version 5.7.19 ( not going to use i would unistall service later )
5a - MariaDB version if applicable 10.2.8 (not going to use i would unistall service later)
6 - What color is the WampServer icon (in the notification area of the taskbar) GREEN

Appache error_log
AH00455: Apache/2.4.27 (Win64) configured -- resuming normal operations
AH00456: Apache Lounge VC15 Server built: Jul 7 2017 12:46:00
AH00094: Command line: 'D:\\wamp64\\bin\\apache\\apache2.4.27\\bin\\httpd.exe -d D:/wamp64/bin/apache/apache2.4.27'
Parent: Created child process 4644
AH00354: Child: Starting 64 worker threads.

7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines?
* Active means no # at the beginning of the line.

127.0.0.1 localhost


9 - Do you have access to phpMyAdmin? Yes

10 - If you refer to an error message, please include the EXACT wording of the error in your post
No error
11 - If you use an Antivirus and / or Firewall, please include the names of these

Symantec Apache is allowed through firewall. I disable just in case this was the problem, bu not solved

12 - What is the full path to the installation of WampServer (eg D:\wamp\)

d:/wamp/

13 - If you have one or more Virtual Hosts defined, please show their definition(s)
None

***** Test which uses port 80 *****

===== Tested by command netstat filtered on port 80
=====


Test for TCP
Your port 80 is used by a processus with PID = 5660

The processus of PID 5660 is 'httpd.exe' Session: Services
The service of PID 5660 for 'httpd.exe' is 'wampapache64'

This service is from Wampserver - It is correct

Test for TCPv6
Your port 80 is used by a processus with PID = 5660

The processus of PID 5660 is 'httpd.exe' Session: Services
The service of PID 5660 for 'httpd.exe' is 'wampapache64'

This service is from Wampserver - It is correct

===== Tested by attempting to open a socket on port 80
=====

Your port 80 is actually used by :

Server: Apache/2.4.27 (Win64) PHP/5.6.31

State of services:

The service 'wampapache64' is NOT started
The service 'wampmysqld64' is NOT started
The service 'dnscache' is NOT started
WampServer (Apache, PHP and MySQL) will not function properly if any service
'wampapache64'
'wampmysqld64'
'dnscache'
is not started.

I have checked manually and service are runnig ok

Please help me here

Options: ReplyQuote
Re: Trying to update now nothing works
Posted by: RiggsFolly (Moderator)
Date: March 06, 2018 12:43AM

Hi,

Couple of points

1. The "Put Online" menu item is now hidden by default for a reason. It's function is no longer of any use

2. Your HOST file should be at a minimum

127.0.0.1 localhost
::1 localhost

3. Virtual Hosts

If you are using WAMPServer 3 then you do have a Virtual Host defined. The localhost domain is a Virtual host in WAMPServer 3.
If you want to allow access from the internet then you need to edit `httpd-vhosts.conf`
There is a menu item to get you there easily under
- wampmanager->Apache->httpd-vhosts.conf

Edit this file and change `Require local` to `Require all granted`

Then of course you will need to Port Forward your router to allow internet traffic into your network.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Trying to update now nothing works
Posted by: Otomatic (Moderator)
Date: March 06, 2018 09:23AM

Hi,

> 5 - MySQL Version 5.7.19 ( not going to use i would unistall service later )
> 5a - MariaDB version if applicable 10.2.8 (not going to use i would unistall service later)

You should not uninstall MySQL and MariaDB services.
Since version 3.0.8, it is possible to deactivate the database managers via the Wampserver tools and thus only work with Apache and PHP.
It is preferable to do this by Wampmanager:
- Right-Click -> Wamp settings -> Allow MySQL to uncheck it
- Right-Click -> Wamp settings -> Allow MariaDB to uncheck it

In this way, the MySQL and MariaDB services are deactivated and deleted correctly and Wampserver "knows" that there are no more database managers.

- Would you like to explain exactly how you went from 3.0.8 to 3.1.0 then back to 3.0.8 and then reinstall the new version?

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.5/7.1.17/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.2.15
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.5/7.1.17/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.2.15
PhPMyAdmin 4.8.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Trying to update now nothing works
Posted by: joenmalo (---.genericrev.cantv.net)
Date: March 06, 2018 09:00PM

Thanks all for your response

I couldn't install the new version.

I uninstall everything and the next day a try to install the 3.1 again. I have some problem with "503 Forbiden Access" I google it, and find there is some problem with `All allow` need to be changed to `Require all granted`,

I double check ->Edit this file and change `Require local` to `Require all granted`, but not sucessfull. I think i miss something or documents are not very clear.

I uninstall again and install 3.0 and erase de folder, then copy the old files ( thanks i have saved the entire folder) and everything works ok.

I still check in the Wampserver utility, for services status, and still says they are not working, but checked manually and use [isup.me] web analyser and everything is ok.


Yes i did this:
- Right-Click -> Wamp settings -> Allow MySQL to uncheck it
- Right-Click -> Wamp settings -> Allow MariaDB to uncheck it

with old version only disable MYSQL

Thanks for the help hope someone find the solution.

Regards
Jorge

Options: ReplyQuote
Re: Trying to update now nothing works
Posted by: Otomatic (Moderator)
Date: March 06, 2018 10:10PM

Hi,

Before you want to access your local sites from the Internet or your network, you should first check that everything is working properly locally. You want to do everything at the same time, so you're doing everything wrong.
Before installing Wampserver 3.1.0 did you check that all prerequisites were met?

And if you find, with the tools built into Wampserver that the services are not started, it means that your previous uninstall did not remove everything that should have been removed.
The uninstall must remove all files and folders from Wampserver, including the installation folder.
The uninstall must remove all services:
- wampapache, wampmysqld, wampmariadb for 32 bit
- wampapache64, wampmysqld64, wampmariadb64 for 64 bit
If these uninstallation processes are not followed, the next installation will be carried out in poor conditions.
You should read WAMPserver 3 - All you need to know to verify that you have applied ALL prerequisites BEFORE installing Wampserver 3.1.0.
Please note that these prerequisites are displayed in the JUST installation process BEFORE it actually starts.

And, for your local sites, you need to use VirtualHost, see: The need for Virtual Host

And never forget that Wampserver installers and all addons and updates must be run "as administrator".

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.5/7.1.17/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.2.15
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.5/7.1.17/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.2.15
PhPMyAdmin 4.8.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 03/06/2018 10:15PM by Otomatic.

Options: ReplyQuote


Sorry, only registered users may post in this forum.