Database file is too big to import with phpmyadmin
Posted by: JuanW (---.umts.vodacom.co.za)
Date: January 31, 2018 03:12PM

Windows version - Windows 8.1 PRO 64 bit
Version WampServer - Wampserver 3.1.1 64 bit
Apache Version - 2.4.27 - PHP 5.6.31
PHP Version - 5.6.31 for CLI (Command-Line Interface)
MySQL Version - 5.7.19
MariaDB - 10.2.8
The WampServer icon is Green
The active lines in the hosts files are these two.
127.0.0.1 localhost
::1 localhost
I have access to the localhost (Homepage WampServer).
I have access to phpMyAdmin
I have Eset Nod 32 as an antivirus, and the Windows firewall is on.
The full path to WAMP is c:\wamp64
I'm in the process of setting up my online website on my local machine.
When I import my database file myphpadmin says that the file is too big. The file size is 1.05 gig.
How can I import the file?

Options: ReplyQuote
Re: Database file is too big to import with phpmyadmin
Posted by: Otomatic (Moderator)
Date: January 31, 2018 04:26PM

Hi,

Modify limit parameters in wamp64/alias/phpmyadmin.conf like this :
# To import big file you can increase values
  php_admin_value upload_max_filesize 1500M
  php_admin_value post_max_size 1500M
  php_admin_value max_execution_time 3600
  php_admin_value max_input_time 3600
You must restart Wampserver.

The most important import I made was with a 652 M SQL file.
I don't know if it'll work with a 1.05 G file.
Otherwise, you will have to import by splitting the file to import table by table.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
PhPMyAdmin 4.8.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Database file is too big to import with phpmyadmin
Posted by: RiggsFolly (Moderator)
Date: January 31, 2018 08:13PM

Alternatively import the backup using the mysql command prompt

wampserver->mysql->mysql Console


mysql> use `database-name`
mysql> source path/to/import/file.sql

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.