Can't Access Phpmyadmin After Installing Wamp
Posted by: JuanW (---.umts.vodacom.co.za)
Date: January 23, 2018 12:07PM

I can't log into myphpadmin
(sorry for the long post but I decided to include all the steps that I already took to speed things up.

I installed Wamp a few days ago and the icon was
orange with only two out of three services running. But after uninstalling Wamp,
installing all the files mentioned when installing Wamp and then doing a fresh install the
Wamp icon turned green.

Now I can't log into phpmyadmin.
As username I used 'root' and I left the password blank.
After reading up on the internet
about other people with the same problem I did the following steps.

I added lines in the config.inc file, see number 1. and 2.

1. I added these lines:
$cfg['Servers'][$i]['AllowRoot'] = TRUE;
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = TRUE;
(it didn't work so I removed these lines)

2. I then added these lines:
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'YOUR_Password'; (I put 12345 in as a password)
(it also didn't work so I removed these lines as well)

3. I removed the # sign that was in front of the ::1 line in the hosts file and
saved the file as an administrator. I've flushed the DNS.
::1 localhost
27.0.0.1 localhost
(I'm keeping this setting, it seems that it is needed)

4. I tested port 80 and 3306 by right clicking on the wamp icon and selecting tools
the ports are fine and is being used by Wamp.


I am now at wits end, can you please assist me as I have tried everything that I could
find on the internet yesterday and today without any luck.

Thanks in advance.

Windows 8.1 pro
WampServer Version 3.1.0 (64bit)
Apache 2.4.27 - PHP 5.6.31
MySQL 5.7.19



Edited 1 time(s). Last edit at 01/23/2018 02:07PM by Otomatic.

Options: ReplyQuote
Re: Can't Access Phpmyadmin After Installing Wamp
Posted by: Otomatic (Moderator)
Date: January 23, 2018 02:14PM

Hi,

First, you're opening a new discussion and you're not stepping into a five year old discussion. Since then, things have evolved and even if your problem seems similar, the eventual solution has evolved.

Second, you put things back in exactly the same state as before all your changes.

Thirdly, after having put things back in their original state, you answer to READ (and answer) BEFORE YOU ASK A QUESTION

Fourth, and perhaps most importantly, don't believe everything you can find on the Internet about Wampserver; at 99.9% it's a bunch of crap.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
PhPMyAdmin 4.8.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Can't Access Phpmyadmin After Installing Wamp
Posted by: JuanW (---.umts.vodacom.co.za)
Date: January 24, 2018 08:50AM

Hi thanks for coming back to me. I will do so.

Options: ReplyQuote
Re: Can't Access Phpmyadmin After Installing Wamp
Posted by: JuanW (---.umts.vodacom.co.za)
Date: January 24, 2018 01:54PM

I've created a new post as requested.

Options: ReplyQuote


Sorry, you can't reply to this topic. It has been closed.