Apache problema
Posted by: plazma (---.dynamic.sbb.rs)
Date: January 20, 2018 10:51AM

Hi,

I have installed WAMP for the first time on my Win7 64b and Apache isn't working.

When I start WAMP there is a message:
The application was unable to start correctly (0xc000007b). Click OK to close the application

Read other topics, installed all VC's, checked with suggested tool, pinged 127.0.0.1 and ::1, didn't found any of php.ini nor my.ini and Apache error log is empty. My host file is ok as RiggsFolly described. Also updated to 3.1.1 version. Skype is closed and configured to not use port 80 or 443

Please HELP!!!!

Options: ReplyQuote
Re: Apache problema
Posted by: RiggsFolly (Moderator)
Date: January 20, 2018 04:19PM

Did you install both the 32bit and 64bit MSVC runtimes.

There is a tool Oto wrote for checking this which can be found on our backup repo here

Look at the bottom of this page, the checking tool is called "Checks VC++ packages installed "

Or just download and install "One by One" all the runtimes in the zip file installed by `All Visual C++ Redistribuable Packages (x86_x64) (32 & 64bits)`

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Apache problema
Posted by: plazma (---.dynamic.sbb.rs)
Date: January 20, 2018 06:17PM

thank you for your prompt reply, i really appreciate it

i have used that tool and all MSVC are installed. i've checked port 80 and here is what i've got:


***** Test which uses port 80 *****

===== Tested by command netstat filtered on port 80 =====


Test for TCP
Port 80 is not found associated with TCP protocol
Port 80 is not found associated with TCP protocol

===== Tested by attempting to open a socket on port 80 =====

Your port 80 is not actually used.


i have read almost all of yr topics and tried everything, but it isn't working... any recommendation?

Options: ReplyQuote
Re: Apache problema
Posted by: RiggsFolly (Moderator)
Date: January 20, 2018 07:09PM

Okk,

Please check your "Windows Event Viewer" for messages from APACHE

Let us know what you see, IF it is not obvious what the error is

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.