err connection refused
Posted by: Jayne (---.17-4.cable.virginm.net)
Date: January 08, 2018 03:02PM

Hi,

I recently migrated a site using Updraft Plus from my Wamp Server to SiteGround. I've just come back to Wamp to continue working on it but am now getting an error message saying the site cannot be reached. andrewmarkperry.dev refused to connect. Try checking the firewall and connection. Err connection refused.

I am running another Wordpress site on Wamp with no problems so I don't think I am having any connection or firewall problems. After previous problems with anti virus and wamp I'm confident that that isn't an issue either.

Please can you suggest any steps I could take to fix this?

Kind regards,
Jayne

Options: ReplyQuote
Re: err connection refused
Posted by: Otomatic (Moderator)
Date: January 08, 2018 04:59PM

Hi,

Google has appropriated the tld .dev and obliges the users of this tld to connect in https, even for local use where Internet DNS are not used.
The solution is to throw Chrome in the trash can and use Firefox.

Chrome is definitely banned from all my systems and I will not run any more Wampserver tests with Chrome.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
PhPMyAdmin 4.8.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: err connection refused
Posted by: RiggsFolly (Moderator)
Date: January 09, 2018 09:43AM

Alternatively, use another tld like "test" or "local"

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: err connection refused
Posted by: Jayne (---.17-4.cable.virginm.net)
Date: January 09, 2018 11:03AM

So that's what it is - thank you.

Is there a way for me to get Wamp to open up in Firefox without me having to reinstall it?

Options: ReplyQuote
Re: err connection refused
Posted by: Otomatic (Moderator)
Date: January 09, 2018 11:33AM

Hi,

- Exit Wampserver

Edit, with a correct text editor (i. e. not with Windows Notepad)(*) the file wamp/wampmanager.conf and rplace the line navigator= by the complete path to Firefox, like this:
;Path of the Browser used by Wampserver
;May be modfied with the absolute path of the browser exe file
;(Use / instead of \)
navigator ="J:/Com/Net/Firefox/firefox.exe"
Save the modified file.
Launch Wampserver.

(*) To edit the files, you must use a text editor, but not just any one. Some text editors, such as Notepad (notepad.exe) in Windows, are not able to correctly view files with Unix line breaks*, others recode surreptitiously the line of type Unix in type Windows/DOS, others still change the used character sets or add headers ; However, it is imperative that the end-of-line types or the character sets of the Wampserver files are not altered, otherwise it will generate impossibilities and errors when it is used. That's why I strongly recommend to use a free, powerful text editor like Notepad++ that you can find at Notepad++ (If you use a text editor like UtraEdit, it will not be a problem).

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.4/7.1.16/7.0.29/5.6.35 - MySQL 5.7.22 - MariaDB 10.2.14
PhPMyAdmin 4.8.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: err connection refused
Posted by: Jayne (---.17-4.cable.virginm.net)
Date: January 12, 2018 11:01AM

Thank a lot for great advice!

Options: ReplyQuote


Sorry, only registered users may post in this forum.