wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 14, 2017 03:14PM

I have used wampserver 3.0 with ssl same way now this new version is not starting. This is due to a VC++ redistribute package issue I guess.

Windows Event Log:
Faulting application name: httpd.exe, version: 2.4.27.0, time stamp: 0x595f6436
Faulting module name: VCRUNTIME140.dll, version: 14.11.25325.0, time stamp: 0x59273894
Exception code: 0xc0000005
Fault offset: 0x0000000000001240
Faulting process id: 0x568
Faulting application start time: 0x01d374db7dcc4191
Faulting application path: E:\wamp64\bin\apache\apache2.4.27\bin\httpd.exe
Faulting module path: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
Report Id: 5f4dcb13-5250-48ae-baac-30080766372e
Faulting package full name:
Faulting package-relative application ID:

Anyone found this matter and fix?

VC 2017 - 14.11.25325 is installed as latest for today.

Please help to resolve.

Re: wampserver 3.1.0 SSL is not starting
Posted by: Otomatic (Moderator)
Date: December 14, 2017 03:42PM

Hi,

> VC 2017 - 14.11.25325 is installed as latest for today.
Latest is 14.12.25810

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

Do not use the previously loaded tool. Make a new download to make sure you are using the correct version.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 14, 2017 06:51PM

I updated the version VC14, issue exists.
Checked VC libraries, all are there.

Event Log.
Faulting application name: httpd.exe, version: 2.4.27.0, time stamp: 0x595f6436
Faulting module name: VCRUNTIME140.dll, version: 14.12.25810.0, time stamp: 0x59dd7da2
Exception code: 0xc0000005
Fault offset: 0x0000000000001246
Faulting process id: 0x39a4
Faulting application start time: 0x01d37502f5ec71f6
Faulting application path: E:\wamp64\bin\apache\apache2.4.27\bin\httpd.exe
Faulting module path: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
Report Id: 05f1c41b-23ad-4650-b0f6-adc2a0d16539
Faulting package full name:
Faulting package-relative application ID:

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 14, 2017 06:54PM

---------------------------
Setup
---------------------------
All VC++ packages needed to Wampserver are installed correctly

_____________________________________________________

INSTALLED PACKAGES - X86

- Visual C++ 2008 SP1 Redistributable Package (x86)

- Visual C++ 2008 SP1 ATL Security Update Redistributable Package (x86)

- Visual C++ 2008 SP1 MFC Security Update Redistributable Package (x86)

- Visual C++ 2010 SP1 Redistributable Package (x86)

- Redistribuable Visual C++ pour Visual Studio 2012 Update 4

- Microsoft Visual C++ 2012 x86 Additional Runtime - 11.0.61030.0 (Update 4)

- Visual C++ Redistributable Packages for Visual Studio 2013

- Microsoft Visual C++ 2017 x86 Minimum Runtime - 14.12.25810

- Microsoft Visual C++ 2017 x86 Additional Runtime - 14.12.25810

____________________________________________________

INSTALLED PACKAGES - X64

- Visual C++ 2008 SP1 Redistributable Package (x64)

- Visual C++ 2008 SP1 ATL Security Update Redistributable Package (x64)

- Visual C++ 2008 SP1 MFC Security Update Redistributable Package (x64)

- Visual C++ 2010 SP1 Redistributable Package (x64)

- Redistribuable Visual C++ for Visual Studio 2012 Update 4

- Microsoft Visual C++ 2012 x64 Additional Runtime - 11.0.61030.0 (Update 4)

- Visual C++ Redistributable Packages for Visual Studio 2013

- Microsoft Visual C++ 2017 x64 Minimum Runtime - 14.12.25810

- Microsoft Visual C++ 2017 x64 Additional Runtime - 14.12.25810


---------------------------
OK
---------------------------

Re: wampserver 3.1.0 SSL is not starting
Posted by: Otomatic (Moderator)
Date: December 14, 2017 09:31PM

Hi,

I have no problem with Apache 2.4.27 32 or 64 bit regardless of the systems used:
- Windows 7 Pro 64 bit
- Windows 10 Pro 64 bit (1709)
All my systems are totally up to date with Windows Update.

Look at the details of the errors in the Event Viewer.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 14, 2017 09:53PM

hi

That happens only when SSL is enabled. I had no issues with previous version. Main difference is new VC++ version only.

Are you using https /ssl on latest wamp server ?

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 14, 2017 10:10PM

hi can you post your httpd-ssl.conf file please?

Re: wampserver 3.1.0 SSL is not starting
Posted by: Otomatic (Moderator)
Date: December 15, 2017 09:22AM

Hi,

Sorry, I don't use ssl.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: wampserver 3.1.0 SSL is not starting
Posted by: Otomatic (Moderator)
Date: December 15, 2017 10:22AM

Hi,

You can try with Apache 2.4.29 which has had updates for VC15 and also for ssl.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 15, 2017 10:24AM

Oh Issue is only with SSL. Otherwise its working and previous wamp versions had no issues with SSL.

I will check if it fails with openSSL certificates issued with newer version.

thanks

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.126.---)
Date: December 15, 2017 06:48PM

Hello,

this is just an update.

I have downgraded Apache into previous wamp contained version 2.4.23 and VC++ into 14.0.2415.

Now SSL is working.

Apache/2.4.23 (Win64) OpenSSL/1.0.2m PHP/7.0.26 - Port defined for Apache: 80


I think issue should be resolved Vc++ 14. / above versions or in Apache. no idea where the issue is.

Thanks

Re: wampserver 3.1.0 SSL is not starting
Posted by: Otomatic (Moderator)
Date: December 15, 2017 07:13PM

Hi,

> I have downgraded Apache into previous wamp
There was no need to change Wampserver version.
Wampserver 3 supports Apache 2.4.23 (VC14) as addon.
See : WAMPserver 3 - All you need to know and http://wampserver.aviatechno.net/

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: wampserver 3.1.0 SSL is not starting
Posted by: amilaudana (123.231.122.---)
Date: April 02, 2018 09:48AM

Dear, it seems using plugin is not supporting. Its better finding the problem and update on next version with SSL as its perfect on previous 3.0.6.

Thank you.

Re: wampserver 3.1.0 SSL is not starting
Posted by: WarriorGov9791 (---.hawaii.res.rr.com)
Date: April 03, 2018 12:50PM

SSL is running fine on my setup:

• Windows 7 Ultimate 64-bit
• WampServer 3.1.3 (and all add-ons 64-bit)
• Apache 2.4.33
• OpenSSL 1.1.0h
• PHP 7.2.4 (plus 5.6.35 - CLI, 7.0.29, 7.1.16)
• MariaDB 10.2.14
• MySQL 5.7.21

with a custom httpd-ssl file and the most current VC++ packages.

If you've updated your software (especially Apache), perhaps you can check that your certificates and keys have been copied to the new locations and the corresponding lines in your httpd-ssl file point to the updated Apache version. Then run the httpd.conf syntax checker for any errors and make the necessary corrections.

Hope this helps. Aloha!

Sorry, only registered users may post in this forum.