[SOLVED] MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 02, 2017 12:04PM

hi,

my service won't start: wampmysqld64

i tried a lot of things and read through your forum for solutions.
installed VC9, VC10, VC11, VC13 , VC14 and VC15 for both x86 x64

tried installing wampserver3.1.0_x86.exe and wampserver2.5-Apache-2.4.9-Mysql-5.6.17-php5.5.12-64b.exe. but get the same problem.

and i tried to updated to wampserver3_x86_x64_update3.1.1.exe

also tried the wampserver3_repair_wampini.exe but the wampini_repair.bat file can't find wampmanager.exe.

a previous version of wampserver (2.5) was running fine until i tried to update to you newer versions and a reinstall of 2.5 won't fix the problem either.

i'm at a loss at what i can do else. i would appreciate some help, thank you in advance.

mysql.log:
2017-12-02T10:41:41.401003Z 0 [ERROR] InnoDB: Header page consists of zero bytes in datafile: .\ibdata1, Space ID:0, Flags: 0. Please refer to [dev.mysql.com] for how to resolve the issue.
2017-12-02T10:41:41.404004Z 0 [ERROR] InnoDB: Corrupted page [page id: space=0, page number=0] of datafile '.\ibdata1' could not be found in the doublewrite buffer.
2017-12-02T10:41:41.405004Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Data structure corruption
2017-12-02T10:41:41.608016Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2017-12-02T10:41:41.608016Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2017-12-02T10:41:41.609016Z 0 [ERROR] Failed to initialize plugins.
2017-12-02T10:41:41.611016Z 0 [ERROR] Aborting


Event viewer error log:

Log Name: Application
Source: MySQL
Date: 12/2/2017 11:32:54 AM
Event ID: 100
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer:
Description:
Aborting
For more information, see Help and Support Center at [www.mysql.com].
Event Xml:
<Event xmlns="[schemas.microsoft.com];
<System>
<Provider Name="MySQL" />
<EventID Qualifiers="49152">100</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-12-02T10:32:54.850437200Z" />
<EventRecordID>6641</EventRecordID>
<Channel>Application</Channel>
<Computer></Computer>
<Security />
</System>
<EventData>
<Data>Aborting
</Data>
</EventData>
</Event>



Edited 2 time(s). Last edit at 12/04/2017 02:02PM by isz.

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: Otomatic (Moderator)
Date: December 02, 2017 02:05PM

Hi,

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

Open a command windows "as an administrator" (The word administrator MUST be in the title bar) and type:
fsutil fsinfo volumeinfo c:
There MUST be the word "NTFS" in the result.
If there is no NTFS, it is not worth continuing, Wampserver can only work on an NTFS disk

We will now look at the characteristics of NTFS formatting as the sizes of physical and logical sectors, with the command:
fsutil fsinfo ntfsinfo c:
What is the result ?

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 02, 2017 05:11PM

Hi Otomatic,

Thank you for the help. Here are the results for the commands.


fsutil fsinfo volumeinfo c:

Volume Name : Warpdrive
Volume Serial Number : 0xfefd0683
Max Component Length : 255
File System Name : NTFS
Is ReadWrite
Supports Case-sensitive filenames
Preserves Case of filenames
Supports Unicode in filenames
Preserves & Enforces ACL's
Supports file-based Compression
Supports Disk Quotas
Supports Sparse files
Supports Reparse Points
Returns Handle Close Result Information
Supports POSIX-style Unlink and Rename
Supports Object Identifiers
Supports Encrypted File System
Supports Named Streams
Supports Transactions
Supports Hard Links
Supports Extended Attributes
Supports Open By FileID
Supports USN Journal

fsutil fsinfo ntfsinfo c:
Error: Access is denied.

the tool to check VC++ packages installed is very helpful. But i keep getting "NOT INSTALLED" for two packaged no matter if I have it installed. I tried repair, uninstall and reinstall, but it keep getting the same message:


VC_2013_REDIST_X86_MIN ID={13A4EE12-23EA-3371-91EE-EFB36DDFFF3E}
Visual C++ Redistributable Packages for Visual Studio 2013
**** NOT INSTALLED ****
see: [www.microsoft.com]
----------------------------------------
VC_2013_REDIST_X64_MIN ID={A749D8E6-B613-3BE3-8F5F-045C84EBA29B}
Visual C++ Redistributable Packages for Visual Studio 2013
**** NOT INSTALLED ****
see: [www.microsoft.com]
----------------------------------------


Also as a test, I previously tried to install the standalone MSQL installer and it went without any problem.



Edited 1 time(s). Last edit at 12/02/2017 05:12PM by isz.

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: Otomatic (Moderator)
Date: December 02, 2017 06:10PM

Hi,

> fsutil fsinfo ntfsinfo c:
> Error: Access is denied.
The problem may be there!
You do not have the required rights to access volume c:
Mysql, during the installation of Wampserver, proceeds to the creation of the data folder and related files and, if the rights are not sufficient, the creation will fail.

For VC 2013 packages, have you tried with the files you can download on the same page as the verification tool :[wampserver.aviatechno.net] at the bottom of the page : Visual C++ 2013 Redist. Package (x86) and Visual C++ 2013 Redist. Package (x64)

To continue in the best conditions, thank you for READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 03, 2017 01:57PM

> The problem may be there!

My bad, I've run command prompt again with administrator rights and the command executes correctly.
Besides that I've also made the mistake of running the wampini_repair.bat from windows. Now I've run wampini_repair.bat within command prompt under admin rights within the correct file path. But it still didn't help in any of my case.

I've run a complete clean uninstall/reinstall for the required Visual C++ Redistributable Packages and got a pass with your checking tool.

(For anyone who doesn't pass the requirements, should run the tool and do a complete uninstall/reinstall, some packages request a repair instead of a complete installation, this step should not be passed)

Anyhow even passing the required Visual C++ Redistributable Packages my problem still persist.

wampmysqld64 won't run. wampapache64 is running and I can access localhost and phpmyadmin just fine.
The database within wampserver still refuses to run. That is very strange because a standalone installation of MSQL is running fine. (MSQL was completely uninstalled before running wampserver installation under admin rights)

I will still try a new wampsever x86 installation later, but I don't expect it to work.



Edited 1 time(s). Last edit at 12/03/2017 07:58PM by isz.

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: Otomatic (Moderator)
Date: December 03, 2017 04:09PM

Hi,

Even if Mysql refuses to run, MariaDB is OK and run. It can replace MySQL so :
- Right-Click Wampmanager tray icon -> Wamp settings -> Allow Mysql to uncheck it

Then you have to verify that MariaDB use the default port i.e. 3306.

- Right-Click -> Tools -> Port used by MariaDB
If the port is 3306 -> do nothing
else
- Right-Click -> Tools -> Use a port other than xxxx (May be 3307) and choose 3306

After that, all your operations on the databases will be completely "transparent", as if you were using MySQL.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 03, 2017 08:40PM

Thnx for the suggestion Otomatic,

I've unchecked MSQL and ran MariaDB on port 3306, it sounded hopeful for a second.

So sad it doesn't work and I get a bunch of error reports from the log.


A snipped from the log points out perhaps a bug or even a hardware malfunction:

2017-12-03 20:05:29 11832 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2017-12-03 20:05:29 11832 [Note] InnoDB: Uses event mutexes
2017-12-03 20:05:29 11832 [Note] InnoDB: Compressed tables use zlib 1.2.3
2017-12-03 20:05:29 11832 [Note] InnoDB: Number of pools: 1
2017-12-03 20:05:29 11832 [Note] InnoDB: Using generic crc32 instructions
2017-12-03 20:05:29 11832 [Note] InnoDB: Initializing buffer pool, total size = 32M, instances = 1, chunk size = 32M
2017-12-03 20:05:29 11832 [Note] InnoDB: Completed initialization of buffer pool
2017-12-03 20:05:29 11832 [Note] InnoDB: Highest supported file format is Barracuda.
2017-12-03 20:05:29 11832 [Warning] InnoDB: Retry attempts for reading partial data failed.
2017-12-03 20:05:29 11832 [ERROR] InnoDB: Tried to read 512 bytes at offset 0, but was only able to read 0
2017-12-03 20:05:29 11832 [ERROR] InnoDB: File (unknown): 'read' returned OS error 0. Cannot continue operation
171203 20:05:29 [ERROR] mysqld got exception 0x80000003 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.

To report this bug, see [mariadb.com]

We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

Server version: 10.2.8-MariaDB
key_buffer_size=67108864
read_buffer_size=262144
max_used_connections=0
max_threads=65537
thread_count=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 70631 K bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
mysqld.exe!my_parameter_handler()[my_init.c:259]
mysqld.exe!raise()[signal.cpp:516]
mysqld.exe!abort()[abort.cpp:71]
mysqld.exe!os_file_handle_error_cond_exit()[os0file.cc:5207]
mysqld.exe!os_file_read_page()[os0file.cc:5089]
mysqld.exe!os_file_read_func()[os0file.cc:5429]
mysqld.exe!fil_io()[fil0fil.cc:5398]
mysqld.exe!log_group_header_read()[log0log.cc:1564]
mysqld.exe!recv_find_max_checkpoint()[log0recv.cc:949]
mysqld.exe!recv_recovery_from_checkpoint_start()[log0recv.cc:3151]
mysqld.exe!innobase_start_or_create_for_mysql()[srv0start.cc:2219]
mysqld.exe!innobase_init()[ha_innodb.cc:4428]
mysqld.exe!ha_initialize_handlerton()[handler.cc:512]
mysqld.exe!plugin_initialize()[sql_plugin.cc:1413]
mysqld.exe!plugin_init()[sql_plugin.cc:1694]
mysqld.exe!init_server_components()[mysqld.cc:5256]
mysqld.exe!win_main()[mysqld.cc:5848]
mysqld.exe!mysql_service()[mysqld.cc:6107]
mysqld.exe!thread_start<void (__cdecl*)(void * __ptr64)>()[thread.cpp:115]
KERNEL32.DLL!BaseThreadInitThunk()
ntdll.dll!RtlUserThreadStart()
The manual page at [dev.mysql.com] contains
information that should help you find out what is causing the crash.

I should mention that I'm running RAM Disk. Also running Razer Synapse and Logitech Gaming Software, which on a previous test I've stopped all their background services.

I'll try to look into the crash reports myself, but if you or anyone else sees the problem within this report at glance, I would appreciate the heads up. In any case my last resort would be getting my hands dirty with a less streamlined installation of apache/msql/php.



Edited 1 time(s). Last edit at 12/03/2017 08:41PM by isz.

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: Otomatic (Moderator)
Date: December 03, 2017 09:02PM

Hi,

> Tried to read 512 bytes at offset 0, but was only able to read 0
Having already encountered a similar problem for another user, I suspect that the disk or partition on which Wampserver is installed is NTFS (we have seen this previously by the result of the fsutil fsinfo volumeinfo command) but that "factory" formatting is with physical and logical sectors of 4096 bytes.

That's why I'm asking you to run - in a command window - the command:
fsutil fsinfo ntfsinfo c:
and give here the result.
Of course, in this command, the drive letter "c:" must be replaced, if necessary, by the drive letter on which Wampserver is installed.

Just say it right away, if the result gives 4096 for physical sectors and 4096 for logical sectors, it is a "4K native" formatting and, mysql or mariadb can not be installed on such a type of formatting .
Microsoft has released an update for MySQL Server and "native 4K", but not yet MySQL or MariaDB.
Since this is a "factory" formatting (what in the past was called "low level formatting" ) it is not possible to reformat at home.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 03, 2017 10:36PM

aha, thank you for informing me. yea the results are for my d drive (which is a hard disk drive) is:

Bytes Per Sector: 4096
Bytes Per Physical Sector: 4096
Bytes Per Cluster: 4096
Bytes Per FileRecord Segment: 4096

my c drive is an ssd however with the following results:

Bytes Per Sector: 512
Bytes Per Physical Sector: 512
Bytes Per Cluster: 4096
Bytes Per FileRecord Segment: 1024


I used to have wampserver 2.5 working on my d drive however, sadly I didn't backup. (current installation of 2.5 versions failed to work however)

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 04, 2017 02:01PM

[solved]

Because wampserver used to work I've tried installing different MSQL versions and I got Wampserver working with MSQL 5.5.57: [wampserver.aviatechno.net]

Thanks anyhow for going through this with me, hope this could be of help for your other wamp users.

edit: still getting error reports for mysql.log however.

171204 14:18:53 [Note] Plugin 'FEDERATED' is disabled.
171204 14:18:53 InnoDB: The InnoDB memory heap is disabled
171204 14:18:53 InnoDB: Mutexes and rw_locks use Windows interlocked functions
171204 14:18:53 InnoDB: Compressed tables use zlib 1.2.3
171204 14:18:53 InnoDB: Initializing buffer pool, size = 16.0M
171204 14:18:53 InnoDB: Completed initialization of buffer pool
InnoDB: Error: space header page consists of zero bytes in data file .\ibdata1
171204 14:18:53 InnoDB: Could not open or create data files.
171204 14:18:53 InnoDB: If you tried to add new data files, and it failed here,
171204 14:18:53 InnoDB: you should now edit innodb_data_file_path in my.cnf back
171204 14:18:53 InnoDB: to what it was, and remove the new ibdata files InnoDB created
171204 14:18:53 InnoDB: in this failed attempt. InnoDB only wrote those files full of
171204 14:18:53 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
171204 14:18:53 InnoDB: remove old data files which contain your precious data!
171204 14:18:53 [ERROR] Plugin 'InnoDB' init function returned error.
171204 14:18:53 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
171204 14:18:53 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3308
171204 14:18:53 [Note] - '0.0.0.0' resolves to '0.0.0.0';
171204 14:18:53 [Note] Server socket created on IP: '0.0.0.0'.
171204 14:18:53 [Note] Event Scheduler: Loaded 0 events
171204 14:18:53 [Note] wampmysqld64: ready for connections.
Version: '5.5.57' socket: '' port: 3308 MySQL Community Server (GPL)



Edited 1 time(s). Last edit at 12/04/2017 02:20PM by isz.

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: Otomatic (Moderator)
Date: December 04, 2017 03:02PM

Hi,

InnoDB is not working. You will only be able to use the MyISAM engine.
With MySQL 5.5, it possible to disable InnoDB by uncomment the line in my.ini file
# skip-innodb
to have
skip-innodb

-------------------------------
Otherwise, I just finished a procedure to try to install MySQL 5.7.20 "by hand" and that works perfectly on my SSD, but which is not formatted "4K native"

We will try to install MySQL 5.7.20 64 bit, but with an installer that does not launch the creation of the data folder, which we will then do manually. To do this, follow the procedure below, which I perform in real time and without cheating.
Warning : My 64 bit Wampserver installation is in j:\wamp64\, so wherever you see j:\wamp64\ you will need to replace it with your installation path.

- Exit Wampserver
- Open a command windows "as an administrator" (The word administrator must be in the title bar)
In this command windows type:
net stop wampmysqld64
May be a warning message: The wampmysqld64 service is not started.
then type:
sc delete wampmysqld64
Microsoft Windows [version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.

C:\Windows\System32>net stop wampmysqld64
Le service wampmysqld64 n'est pas lancé.

C:\Windows\System32>sc delete wampmysqld64
[SC] DeleteService réussite(s)

C:\Windows\System32>
Into the command windows go to the location of the mysql versions of Wampserver, like:
cd /d j:\wamp64\bin\mysql\
then type:
dir
to see all directories and if there ise mysql5.7.20
if there is mysql5.7.20, we have to delete this directory by the command
rd /s /q mysql5.7.20
C:\Windows\System32>cd /d j:\wamp64\bin\mysql\

j:\wamp64\bin\mysql>dir
 Le volume dans le lecteur J s'appelle SATA_1_J
 Le numéro de série du volume est DD8A-2E62

 Répertoire de j:\wamp64\bin\mysql

04/12/2017  13:15    <REP>          .
04/12/2017  13:15    <REP>          ..
24/10/2017  19:55    <REP>          mysql5.6.37
12/11/2017  11:20    <REP>          mysql5.7.19
04/12/2017  13:15    <REP>          mysql5.7.20
               0 fichier(s)                0 octets
               5 Rép(s)  89 933 660 160 octets libres

j:\wamp64\bin\mysql>rd /s /q mysql5.7.20

j:\wamp64\bin\mysql>dir
 Le volume dans le lecteur J s'appelle SATA_1_J
 Le numéro de série du volume est DD8A-2E62

 Répertoire de j:\wamp64\bin\mysql

04/12/2017  13:31    <REP>          .
04/12/2017  13:31    <REP>          ..
24/10/2017  19:55    <REP>          mysql5.6.37
12/11/2017  11:20    <REP>          mysql5.7.19
               0 fichier(s)                0 octets
               4 Rép(s)  91 855 187 968 octets libres

j:\wamp64\bin\mysql>
Do not exit the command window.
Download the file:
http://wampserver.aviatechno.net/files/mysql/wampserver3_x64_addon_mysqlnodata5.7.20.exe
Then run it "as an administratror"
After the installation of MySQL 5.7.20 (no data) addon go to the command windows and type
dir
to see that there is now a new mysql5.7.20 directory the go into the bin directory of mysql 5.7.20 by the command
cd mysql5.7.20\bin
Now we create the data directory by the command
mysqld.exe --initialize-insecure
That takes about 30 seconds. To verify that it is OK type the commands:
cd..
dir
and we will see data directory.
j:\wamp64\bin\mysql>dir
 Le volume dans le lecteur J s'appelle SATA_1_J
 Le numéro de série du volume est DD8A-2E62

 Répertoire de j:\wamp64\bin\mysql

04/12/2017  13:36    <REP>          .
04/12/2017  13:36    <REP>          ..
24/10/2017  19:55    <REP>          mysql5.6.37
12/11/2017  11:20    <REP>          mysql5.7.19
04/12/2017  13:37    <REP>          mysql5.7.20
               0 fichier(s)                0 octets
               5 Rép(s)  89 919 021 056 octets libres

j:\wamp64\bin\mysql>cd mysql5.7.20\bin

j:\wamp64\bin\mysql\mysql5.7.20\bin>mysqld.exe --initialize-insecure

j:\wamp64\bin\mysql\mysql5.7.20\bin>cd..

j:\wamp64\bin\mysql\mysql5.7.20>dir
 Le volume dans le lecteur J s'appelle SATA_1_J
 Le numéro de série du volume est DD8A-2E62

 Répertoire de j:\wamp64\bin\mysql\mysql5.7.20

04/12/2017  13:43    <REP>          .
04/12/2017  13:43    <REP>          ..
04/12/2017  13:36    <REP>          bin
13/09/2017  16:48            17 987 COPYING
04/12/2017  13:43    <REP>          data
04/12/2017  13:36    <REP>          docs
04/12/2017  13:36    <REP>          include
04/12/2017  13:37    <REP>          lib
04/12/2017  13:37             6 662 my.ini
13/09/2017  16:48             2 478 README
04/12/2017  13:37    <REP>          share
11/12/2015  11:55               346 wampserver.conf
               4 fichier(s)           27 473 octets
               8 Rép(s)  89 791 180 800 octets libres

j:\wamp64\bin\mysql\mysql5.7.20>
If there is no data folder, there is no possibility to continue.
I'm sorry, but - for the moment - I have no solution other than to install on a disk that is not "native 4K".

Otherwise, we will still check if the data folder has the right files, so always in the command window, type:
cd data
dir
pour voir qu'il y a bien les fichiers ibdata1, ib_buffer_pool, ib_logfile0, ib_logfile1 ainsi que les dossiers mysql, performance_schema et sys.
j:\wamp64\bin\mysql\mysql5.7.20>cd data

j:\wamp64\bin\mysql\mysql5.7.20\data>dir
 Le volume dans le lecteur J s'appelle SATA_1_J
 Le numéro de série du volume est DD8A-2E62

 Répertoire de j:\wamp64\bin\mysql\mysql5.7.20\data

04/12/2017  13:43    <REP>          .
04/12/2017  13:43    <REP>          ..
04/12/2017  13:43                56 auto.cnf
04/12/2017  13:43               859 DOMI.err
04/12/2017  13:43        12 582 912 ibdata1
04/12/2017  13:43               505 ib_buffer_pool
04/12/2017  13:43        50 331 648 ib_logfile0
04/12/2017  13:43        50 331 648 ib_logfile1
04/12/2017  13:43    <REP>          mysql
04/12/2017  13:43    <REP>          performance_schema
04/12/2017  13:43    <REP>          sys
               6 fichier(s)      113 247 628 octets
               5 Rép(s)  89 791 180 800 octets libres

j:\wamp64\bin\mysql\mysql5.7.20\data>
It's over with the command window, which you can now close.

Before launching Wampserver, we need to check and possibly modify the file:
J:\wamp64\wampmanager.conf
So, edit this file and if necessary modify to get (I only put the parts to check and not the complete file)
SupportMySQL = "on"
SupportMariaDB = "off"
[mysql]
mysqlVersion = "5.7.20"
[mysqloptions]
mysqlPortUsed = "3306"
mysqlUseOtherPort = "off"
Don't forget to save the modified file.

Launch Wampserver 64bit
Nota : There may be an error during the first launch, ignore or cancel it and start Wampserver a second time.

Since there is no wampmysqld64 service, the Wampmanager icon will not be green.
- Left-Click Wampmanager tray icon -> MySQL -> Service administration 'wampmysqld64' -> Install service
- Left-Click Wampmanager tray icon -> MySQL -> Service administration 'wampmysqld64' -> Start/Resume service

The service starts and the icon turns green. MySQL 5.7.20 is operational.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: MSQL wampmysqld64 won't start no matter what
Posted by: isz (---.upc-d.chello.nl)
Date: December 04, 2017 11:00PM

Otomatic Thnx!

Currently everything is running smoothly without any error logs.

I might try what you suggest at a later stage and backup, but for now working with "don't fix what is not broken" ;-)

Current working wampserver is 3.1.0 64 bit with 3.1.1 update.

Apache 2.4.27
PHP 5.6.32
MySQL 5.5.57
MariaDB disabled

MYSQL configuration my.ini
default-storage-engine=MYISAM
skip-innodb



Edited 1 time(s). Last edit at 12/04/2017 11:00PM by isz.

Options: ReplyQuote


Sorry, only registered users may post in this forum.