php_curl not working in WAMP 3.1.0 x64
Posted by: orbitm1 (94.59.181.---)
Date: November 13, 2017 11:16PM

Hi,

I recently installed WAMP and I was looking for x64 version. This WAMP 3.1.0 came with three versions of PHP. The setup was completed and the server is working, but unfortunately, the extension php_curl.dll seems not working properly. The extension is un-commented in php.ini. what could be the issue, and please advice in how to enable this extension to work.

Thanks

Re: php_curl not working in WAMP 3.1.0 x64
Posted by: Otomatic (Moderator)
Date: November 14, 2017 09:26AM

Hi,

> the extension php_curl.dll seems not working properly
Explain.

And, please READ (and answer) BEFORE YOU ASK A QUESTION



------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: php_curl not working in WAMP 3.1.0 x64
Posted by: orbitm1 (94.59.181.---)
Date: November 14, 2017 02:29PM

Actually it was working but no response was coming from the server.

I just set CURLOPT_SSL_VERIFYPEER to false

My mistake, thanks

Sorry, only registered users may post in this forum.