The requested URL /my_curso was not found on this server.
Posted by: leobezr (---.98.108.dynamic.adsl.gvt.net.br)
Date: October 03, 2017 11:49PM

Can't access my data base.

1- Windows 10, 64bit
2- Version: 3.1.0
3- Apache V: 2.4.27
4- PHP: 5.6.31
5- MySQL V: 5.7.19
6- Wampa Color: Green
-------------------------------------------------------
7-
# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost
127.0.0.1 systweak.com
127.0.0.1 updateservice1.systweak.com
127.0.0.1 www.systweak.com
127.0.0.1 systemspeedup.systweak.com
127.0.0.1 systweak.com/STCheckGenuineness
-------------------------------------------------------
8- Yes
9- Yes
-------------------------------------------------------
10- at the link: <localhost:8080/my_curso>
Not Found
The requested URL /my_curso was not found on this server.
Apache/2.4.27 (Win64) PHP/5.6.31 Server at localhost Port 8080
-------------------------------------------------------
at the link: <localhost/my_curso>
This site can’t be reached
localhost refused to connect.
Search Google for localhost curso
ERR_CONNECTION_REFUSED
-------------------------------------------------------
11- Malware Bytes / Firewall desabled
12- F:\Downloadz\wamp\wamp64
13- Null



Edited 5 time(s). Last edit at 10/05/2017 07:17AM by leobezr.

Options: ReplyQuote
Re: Wamp
Posted by: Otomatic (Moderator)
Date: October 04, 2017 10:00AM

Hi,

- 1 - READ (and answer) BEFORE YOU ASK A QUESTION

- 2 - TROUBLESHOOTING TIPS

- 3 - What is the résult of:
Right-Click wampmanager tray icon -> Tools -> Test port 80

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.0 64 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp
Posted by: leobezr (---.98.108.dynamic.adsl.gvt.net.br)
Date: October 05, 2017 06:58AM

I found out what was making my Wamp not connect to the port, i had a virus that is now cleaned.

What i cant figure out now is how i access my data base, i'm using the link:

localhost/my_curso

The Data Base is called: my_curso.

Im connected with wamp at port 8080 with apache, i tried using <localhost:8080/my_curso> but it keeps failing telling me i got disconnected

What can i do to connect to my data base?

Options: ReplyQuote
Re: Wamp
Posted by: Otomatic (Moderator)
Date: October 05, 2017 09:26AM

Hi,

> What can i do to connect to my data base?
Begin by answering the questions that have been asked.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.0 64 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp
Posted by: leobezr (---.41.47.165.static.host.gvt.net.br)
Date: October 05, 2017 07:40PM

I edit the info on my first post

and for the

3-

***** Test which uses port 80 *****

===== Tested by command netstat filtered on port 80 =====


Test for TCP
Port 80 is not found associated with TCP protocol

Test for TCPv6
Port 80 is not found associated with TCP protocol

===== Tested by attempting to open a socket on port 80 =====

Your port 80 is not actually used.


- Edit.
I connected to port 80 but i got the same result, Page not found



Edited 1 time(s). Last edit at 10/05/2017 07:43PM by leobezr.

Options: ReplyQuote
Re: Wamp
Posted by: Otomatic (Moderator)
Date: October 05, 2017 09:16PM

Hi,

It is easy to see when there is a new message, but it is impossible to see that a read message has been edited. So, when you edit one of your messages, you have to say it in a new reply.

> 7 hosts file
You remove all the "tricks" that have nothing to do in this file whose goal is not to filter the url to put EXCLUSIVELY that:
127.0.0.1 localhost
::1 localhost
and nothing else before the creation of VirtulalHost.

then, for this modification of the hosts file to be taken into account, you have two solutions:
- Restart the PC
- Click-Right wampmanager tray icon -> Tools -> Restart DNS

After that do :
- Right-Click wampmanager tray icon -> Refresh
then
- What is the résult of:
Right-Click wampmanager tray icon -> Tools -> Test port 80

which should give a good result, since you wrote in 8 and 9 that you had access to localhost (Wampserver home page) and PhpMyAdmin.

And only after all the above gives good results, we will take care of the access to your local site and the connection to the database. Until these prerequisites are resolved, it is not worth trying to go further.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.0 64 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp
Posted by: leobezr (---.41.47.165.static.host.gvt.net.br)
Date: October 05, 2017 11:35PM

Sorry about the edit in the wrong place!

Here's the result:

***** Test which uses port 80 *****

===== Tested by command netstat filtered on port 80 =====


Test for TCP
Your port 80 is used by a processus with PID = 7952
The processus of PID 7952 is 'httpd.exe' Session: Services
The service of PID 7952 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct

Test for TCPv6
Your port 80 is used by a processus with PID = 7952
The processus of PID 7952 is 'httpd.exe' Session: Services
The service of PID 7952 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct

===== Tested by attempting to open a socket on port 80 =====

Your port 80 is actually used by :

Server: Apache/2.4.27 (Win64) PHP/5.6.31

Options: ReplyQuote
Re: The requested URL /my_curso was not found on this server.
Posted by: Otomatic (Moderator)
Date: October 06, 2017 09:52AM

Hi,

Now, it seems that wampserver is working properly, so for your local site "my_curso":
> at the link: <localhost/my_curso>
works correctly too, you must use the VirtualHost: see The need for Virtual Host

If your local site is based on a web application such as Wordpress, Drupal, Joomla or other, you must create the VirtualHost BEFORE installing the application.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.0 64 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: The requested URL /my_curso was not found on this server.
Posted by: leobezr (---.41.47.165.static.host.gvt.net.br)
Date: October 06, 2017 08:02PM

Ok what should i do if my D: wont open?
I did everything in the topic and still cant access my data base.

Note: Just didn't create the D: folder since it wont open, is their some other place i can create these:
D:
MD websites
CD websites
MD example.com
CD example.com
MD www

Options: ReplyQuote
Re: The requested URL /my_curso was not found on this server.
Posted by: Otomatic (Moderator)
Date: October 06, 2017 08:23PM

Hi,

A database can not be accessed via a folder or disk.
A database is accessed by:
- a database manager such as PhpMyAdmin or Adminer
- a PHP script

A database is not created by the creation of a folder, but here again by one of the two items above.

> Ok what should i do if my D: wont open?
Please explain what you mean by "wont open"

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.0 64 bit - Apache 2.4.29 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: The requested URL /my_curso was not found on this server.
Posted by: leobezr (---.41.47.165.static.host.gvt.net.br)
Date: October 06, 2017 09:54PM

Thanks alot for the help, i found out how to open my data base! Forget about my last question.

Options: ReplyQuote


Sorry, only registered users may post in this forum.