Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 22, 2017 05:25PM

Hi,

I've developed a website locally on my personal device(win7) and everything runs smoothly. I've been tasked to transfer all it's resource and database to a server so my team could access it. I've setup wamp on the server the same way I've set it up on my device, mirrored folder names and locations. I've imported its database into phpmyadmin with the same syntax (5 letter table code).

-localhost is accesible
-localhost/"sitename"/administrator is accessible (its content is present)
but when accessing "localhost/sitename" a "page can't be displayed" appears.

I've tried the suggested 'create a virtual host' for the website. and the same 'page cant be displayed appears'.I'd like to note that I'm also using a Joomla CMS (if that has any relevance)

Any suggestions are appreciated. Thanks in advance!
-CJ

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 22, 2017 05:36PM

Hi,

Use VirtualHost The need for Virtual Host

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 25, 2017 08:07AM

Hi,

I've followed the instructions to create a virtual host and my project appears under the "your virtual host" section in my wamp menu. I'm still experiencing the "page can't be displayed" page

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 25, 2017 09:43AM

Hi,

What is the EXACT error message ?

Have you tried with other browsers?

What are the error messages in apache_error.log and access.log?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 25, 2017 03:56PM

Hi,

yes I've tried in

-Explorer: "This page can’t be displayed"
-Chrome : "This site can’t be reached"

Most recent apache_error.logs (notices)

[Mon Sep 25 21:48:49.277615 2017] [mpm_winnt:notice] [pid 6888:tid 536] AH00418: Parent: Created child process 7060
[Mon Sep 25 21:48:50.199520 2017] [mpm_winnt:notice] [pid 7060:tid 468] AH00354: Child: Starting 64 worker threads.

Most recent apache_error.logs (error)

[Mon Sep 25 21:20:10.308438 2017] [authz_core:error] [pid 2704:tid 956] [client 10.128.176.180:53161] AH01630: client denied by server configuration: C:/wamp64/www/HRTrends/test.html
[Mon Sep 25 21:20:10.386562 2017] [authz_core:error] [pid 2704:tid 956] [client 10.128.176.180:53161] AH01630: client denied by server configuration: C:/wamp64/www/favicon.ico, referer: [10.228.102.84]

Most recent apache_access.logs

::1 - - [25/Sep/2017:21:50:49 +0800] "GET /index.php?img=pngPlugin HTTP/1.1" 200 548
::1 - - [25/Sep/2017:21:50:49 +0800] "GET /index.php?img=gifLogo HTTP/1.1" 200 4549

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 25, 2017 04:34PM

Hi,

Content of C:\Windows\System32\drivers\etc\hosts file?

Content of C:\wamp64\bin\apache\apache2.4.xy\conf\extra\httpd-vhosts.conf?

What is result of :
- Right-Clic wampmanager tray icon -> Tools -> Show VirtualHost examined by Apache

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 26, 2017 09:39AM

Hi,



FYI: "hrtrends" = site folder name



Content of C:\Windows\System32\drivers\etc\hosts file:


# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# 127.0.0.1 hrtrends
# ::1 localhost
# ::1 hrtrends

127.0.0.1 hrtrends
::1 hrtrends




Content of C:\wamp64\bin\apache\apache2.4.xy\conf\extra\httpd-vhosts.conf?

# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


<VirtualHost *:80>
ServerName hrtrends
DocumentRoot "c:/wamp64/www/hrtrends"
<Directory "c:/wamp64/www/hrtrends/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


Result of Show VirtualHost examined by Apache:


VirtualHost configuration:

Default server: localhost
Virtual Host: localhost
Virtual Host: hrtrends




Many thanks,

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 26, 2017 09:49AM

Hi,

- 1 - hosts file should be
127.0.0.1 localhost
::1 localhost

127.0.0.1 hrtrends
::1 hrtrends

- 2 - You have to be consistent in case of filenames and folders.
- client denied by server configuration: C:/wamp64/www/HRTrends/test.html
- DocumentRoot "c:/wamp64/www/hrtrends"
<Directory "c:/wamp64/www/hrtrends/">

The folder name MUST be exactly the same and match the folder name on the disk.
Windows may be case insensitive, but Apache and PHP are not.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 26, 2017 04:23PM

Hi,

My hosts file is now:

# 127.0.0.1 localhost
# ::1 localhost

# 127.0.0.1 hrtrends
# ::1 hrtrends

My root, directories and sitefolder are now all lower case "hrtrends"

Unfortunately, I'm still experiencing the same issue in both browsers,

May I ask if the configuration options under my wampmanager.conf is correct?:

wampmanager.conf:

[options]
AliasSubmenu ="off"
NotCheckVirtualHost = "off"
NotCheckDuplicate = "off"
ItemServicesNames = "off"
VirtualHostSubMenu = "on"
ProjectSubMenu = "off"
HomepageAtStartup = "off"
urlAddLocalhost = "off"
MenuItemOnline = "off"
VhostAllLocalIp = "off"
SupportMySQL = "on"
SupportMariaDB = "on"

Many Thanks,

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 26, 2017 05:08PM

Hi,

Quote

My hosts file is now:

# 127.0.0.1 localhost
# ::1 localhost

# 127.0.0.1 hrtrends
# ::1 hrtrends
NOT COMMENTED = WITHOUT # at the beginning of each line.
Should be a blank line at the end of the file.

After modifying hosts file, you have to do:
Ricght-Click wampmanager tray icon -> Tools -> Restart DNS

Never modifiy wampmanager.conf file by hand.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 27, 2017 12:18PM

Hi

I've removed the "#" and left the last line blank for each file.

hosts:

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.

127.0.0.1 localhost
::1 localhost

127.0.0.1 hrtrends
::1 hrtrends


httpd:-vhosts.conf:

# Virtual Hosts
#
<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
    Require local
  </Directory>
</VirtualHost>


<VirtualHost *:80>
	ServerName hrtrends
	DocumentRoot "c:/wamp64/www/hrtrends"
	<Directory  "c:/wamp64/www/hrtrends">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>

Still experiencing the "page cant be displayed"

I've tried temporarily placing a "test.html" in my sitefolder with "<p>test</p>" ,
when accessing "httpd://hrtrends/test.html" the "test" appears.
so I'm thinking its because my index.php isn't being recognized.

many thanks,

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 27, 2017 12:28PM

Hi,

Is there an .htaccess file in the folder hrtrends?

Note : > <Directory "c:/wamp64/www/hrtrends">
The Apache <Directory directive must always contain a final slash (/).

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: cjzp (---.towerswatson.com)
Date: September 27, 2017 12:58PM

Hi,

yes there is a htaccess.txt file in the site folder. this is what it contains:

htaccess.txt:

##
# @package Joomla
# @copyright Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.
# @license GNU

General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The

line 'Options +FollowSymLinks' may cause problems with some server configurations.
# It is required for the use of

mod_rewrite, but it may have already been set by your
# server administrator in a way that disallows changing it in this

.htaccess file.
# If using it causes your site to produce an error, comment it out (add # to the
# beginning of the line),

reload your site in your browser and test your sef urls. If
# they work, then it has been set by your server administrator

and you do not need to
# set it here.
##

## No directory listings
IndexIgnore *

## Can be commented out if causes errors, see

notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block

out some common exploits.
# If you experience problems on your site then comment out the operations listed
# below by

adding a # to the beginning of the line.
# This attempts to block the most common type of exploit `attempts` on Joomla!
#
#

Block any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
#

Block any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
#

Block any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2})

[OR]
# Block any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]

{0,2})
# Return 403 Forbidden header and show the content of the root home page
RewriteRule .* index.php [F]
#
## End -

Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a

canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct

RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment the following line if your webserver's

URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

##

Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path

and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond

%{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond

%{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond

%{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End -

Joomla! core SEF Section.



many thanks,

Options: ReplyQuote
Re: Wamp64 on Windows 10 wamp works but front end can't be displayed
Posted by: Otomatic (Moderator)
Date: September 27, 2017 01:07PM

Hi,

Temporarily, you rename the .htaccess file to what you want, restart Wampserver and you see what happens.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.10/7.0.24/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.