how to change var_dump in php.ini
Posted by: LivingThis (---.cm-6-1d.dynamic.ziggo.nl)
Date: September 18, 2017 01:18PM

Hi,

Then another thing I would like to adjust is the var_dump ouptut.

I like var_dump to give as much info as possible, preferably in another char type and color then plain echo text.

I tried to change de xdebug directives in php.ini, but it doesnt seem to work. In the php extensions list I see a toggled xdebug 2.5.5 .

this are the directives in php.ini

xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir ="C:/wamp/tmp"
xdebug.show_local_vars=2
xdebug.overload_var_dump = 2

Could it be there is a separated script for xdebug?

If not then I would like to know how to change the output of var_dump.

Please help ...

Edit:

and when I go to phpinfo() I dont see any xdebug at the page shown.



Edited 1 time(s). Last edit at 09/18/2017 01:22PM by LivingThis.

Options: ReplyQuote
Re: how to change var_dump in php.ini
Posted by: Otomatic (Moderator)
Date: September 18, 2017 02:39PM

Hi,

See [forum.wampserver.com]

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.2.0/7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: how to change var_dump in php.ini
Posted by: LivingThis (---.cm-6-1d.dynamic.ziggo.nl)
Date: September 18, 2017 03:42PM

Okay this seems to work.

I see xdebug is loaded in phpinfo()

Thanks for helping me out.

You guys are fantastic !!

Options: ReplyQuote


Sorry, only registered users may post in this forum.