WAMPserver on Microsoft Windows 10.0.15063 / Windows 10 Pro
Posted by: prospurring (---.nc.res.rr.com)
Date: August 31, 2017 05:41AM

Hello.

Answering questions from [forum.wampserver.com]

1. Windows 10.0.15063 / Windows 10 Pro 64-bit
2. WAMPserver 3.0.4 x64
3. Apache 2.4.18
4. PHP 5.6.19
5. MySQL 5.7.11
6. WampServer icon is RED
a. Apache error log: no errors
b. MySQL error log: no errors
c. PHP error log: no errors
d. Windows Event Viewer > Logs > Applications: no relevant error logs or application error logs
7. C:\Windows\System32\drivers\etc\hosts file lists the following IPs withOUT the #:
127.0.0.1 localhost
::1 localhost
8. WampServer icon is RED
8a. WampServer icon is RED
9. No
10. No error message
11. Bitdefender Total Security 2016
12. C:\Users\prospurring\Documents\wamp64
13. I don't even know what a Virtual Host is, much less how to define one

From troubleshooting tips: [forum.wampserver.com]

1. WampServer 3.0.4 x64 was previously working just fine on my computer, prior to Microsoft forcing update to 15063.
2. I have been running WampServer as the Administrator.
3. Skype > "Use ports 80 and 443 ..." is UNchecked.
4. Services Manager: neither wampapache or wampmysqld is listed

Since neither seemed to be running, I went to :
WampManager > MySQL > Service Administration > Install. WampServer icon changed to ORANGE.
WampManager > Apache > Service Administration > Install.
Got an error message:
"Windows could not start the wampapache64 on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1."

Services Manager now shows both wampapache64 and wampmysqld64.
Windows Event Viewer now shows 2 Application Errors for Apache.
The first error says:
"The Apache service named reported the following error:
>>> AH00526: Syntax error on line 251 of
C:/Users/prospurring/Documents/wamp64/bin/apache/apache2.4.18/conf/httpd.conf: ."
The second error says:
"The Apache service named reported the following error:
>>> DocumentRoot must be a directory ."

Line 251 of my httpd.conf file says:
DocumentRoot "C:/Users/prospurring/Documents/wamp64/www"

WHAT SHOULD I CHANGE LINE 251 TO READ?

Additional Notes:
8 - IIS is turned off
9 - Ping tests work for IPv4 and IPv6
I repaired all Visual C++ Redistributables and restarted my system.

Any assistance in troubleshooting would be most appreciated.

Options: ReplyQuote
Re: WAMPserver on Microsoft Windows 10.0.15063 / Windows 10 Pro
Posted by: Otomatic (Moderator)
Date: August 31, 2017 09:20AM

Hi,

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- Apply Update 3.0.9 to your version of Wampserver
Wampserver update 3.0.9

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.11/7.0.25/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.11/7.0.25/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WAMPserver on Microsoft Windows 10.0.15063 / Windows 10 Pro
Posted by: prospurring (---.nc.res.rr.com)
Date: August 31, 2017 02:40PM

Hi, Otomatic.

Thank you for a quick reply.
As stated at the end of my previous post in the additional notes, ALL VC++ packages are installed.

After getting some sleep and coming back to the problem this morning, I made a discovery. I thought that I had made a copy of my www folder - but I had, in fact, MOVED my www folder out of my wamp64 folder. So, the Apache error I was getting was about the fact that there was literally no www folder / directory there.

Added a www folder under wamp64 and Apache now runs. Problem solved.

****Please consider this topic resolved and closed. Thank you!****

Options: ReplyQuote


Sorry, only registered users may post in this forum.