Question about installing; issue with PHProxy
Posted by: skorzeni (---.hsd1.co.comcast.net)
Date: August 23, 2017 12:26PM

I've got a question about setting up this server, as described on [lifehacker.com]

I've installed WAMPSERVER 3.0.6 64-bit on my Windows 7 Service Pack 1 64-bit desktop machine. I got to the step about dragging my PHProxy folder into my C:\wamp64\www folder and was trying to verify that [localhost] would work, and it doesn't (I get a webpage not found).

My [localhost] page says I'm running

Apache Version:2.4.23
PHP Version:5.6.25
Software:Apache/2.4.23 (Win64)
PHP/5.6.25 - Port defined for Apache: 80

The is no error message at the bottom of the page. I haven't explicitly set up any Virtual Hosts of which I am aware. Is the step for copying over the PHProxy folder obsolete? The localhost page says I've got PHP Version 5.6.25.

I didn't read through all 600+ posted threads. I'm sort of eager to set up this proxy server and it is a bit of a pain with all the Visual C++ install prerequisites and such. I'd appreciate your help.

Derek

Options: ReplyQuote
Re: Question about installing; issue with PHProxy
Posted by: Otomatic (Moderator)
Date: August 23, 2017 01:06PM

Hi,

> and it is a bit of a pain with all the Visual C++ install prerequisites

Not that much, if you use the tools created to do it!
- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

> as described on [lifehacker.com]
seven years old!

And I think that with PHP 64 bit, you must imperatively install a PHPproxy 64 bit.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.11/7.0.25/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.11/7.0.25/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 2 time(s). Last edit at 08/23/2017 01:13PM by Otomatic.

Options: ReplyQuote


Sorry, only registered users may post in this forum.