url wrong after wamp upgrade to 64bits
Posted by: sonchoix (---.dsl.bell.ca)
Date: August 22, 2017 05:00AM

I used to have wamp 32 installed under c:\wamp, due to the need to fix the port conflict issue, I installed wamp64 today and it was installed under c:\wamp64, after the successful installation, I moved all the folder content of \www under the old wamp to under new wamp64.

All the projects are listed if I go to [localhost], however, if I click on any of the project, e.g. website1, presumably it should take me to localhost/website1, in fact, the URL in browser (I default it to Chrome) becomes website1 instead of localhost/website1, off course the site won't show up.

If I forcely type in localhost/website1, it gives me Error establishing a database connection.

How do I fix the url issue and the following database connection issue?

Thank you very much. Any clue is appreciated.

Options: ReplyQuote
Re: url wrong after wamp upgrade to 64bits
Posted by: RiggsFolly (Moderator)
Date: August 22, 2017 10:00AM

You will have to backup your old databases, and restore them to the new installation.

I assume you still have access to the old WAMPServer 32bit install. Start that, backup your databases.
Then stop the old WAMPServer 32bit and start the WAMPServer 64bit, then restore the databases.

To fix your URL issue, please read THE NEED for VIRTUAL HOSTS

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.