images inside wamp dir loading extremely slow. How to solve?
Posted by: LivingThis (---.cm-6-1d.dynamic.ziggo.nl)
Date: August 11, 2017 03:28PM

I have a problem that seems to be related to WAMP.

My images for site dev are placed in a separate image directory inside the wamp directroy.

If I show an image in the browser (regardless if is Chrome or Firefox) then this image is either slow (like several seconds) shown or not showing at all in 5% of the calls or so.


First I was thinking maybe it is a php image library problem, so I placed the images outside the wamp directory. This seems not cause any problem at all, gives great speed.

So my question is; how is WAMP handling images and what would you recommend to solve the error and or is this some kind of known bug maybe?

Options: ReplyQuote
Re: images inside wamp dir loading extremely slow. How to solve?
Posted by: RiggsFolly (Moderator)
Date: August 11, 2017 09:11PM

Hi

Please remember WAMPServer is a mashup of Apache / PHP / MySQL and maybe MariaDB.

Therefore if there is an issue serving images it is not WAMPServer you are trying to blame, but a version of Apache or PHP or maybe MySQL.
So it is unlikely to be caused by any of these applications per se.

However the way you write your code and maybe even the way you configured Apache could be at fault. Also the PC that you have installed all these onto may also be having some effect i.e. short of resources etc.

The first thing we ask people to check in these situation is ... Have you created a Virtual Host to run your site in, as this will allow you to configure the site in a way that more accurately mimics the live site you have downloaded or the live site you will eventually upload the site to.

So please start by reading THE NEED for VIRTUAL HOSTS

Then try TROUBLESHOOTING TIPS and if you are using WAMPServer 3 also read WAMPServer 3 All you need to know

If these do not help you fix your issue then please let us know the answers to ALL these questions READ (and answer) BEFORE YOU ASK A QUESTION

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: images inside wamp dir loading extremely slow. How to solve?
Posted by: LivingThis (---.cm-6-1d.dynamic.ziggo.nl)
Date: August 13, 2017 11:31AM

I have virtual hosts configured.

What I did a few months ago was testing how to make a script show a .swf file I downloaded from the internet.

I dont know much from .swf but a fast look at internet tells that flash and .swf is more vulnerable for malicious programming. Right?

Back to my present situation.

What I did is that I copied the images to a separate dir, removed the old directory and removed the .swf content and now the jpgs en gifs back to the dir inside the wamp environment.

I hope this solves the issue.



Edited 2 time(s). Last edit at 08/13/2017 11:51AM by LivingThis.

Options: ReplyQuote


Sorry, only registered users may post in this forum.