Block WampServer 3 homepage from remote machine
Posted by: ranasrule (182.180.103.---)
Date: August 10, 2017 10:14PM

Is there any way that I can block WampServer home page to be accessible from a remote machine (over a LAN) but still I want folders to be accessible.

Eg : I want : 192.168.0.100 to be blocked

and 192.168.0.100/easyappointments/ to be accessible


btw this is what my httpd-vhosts.conf file currently looks like

<VirtualHost *:80>
ServerName localhost
DocumentRoot c:/wamp64/www
<Directory "c:/wamp64/www/">
#Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require all granted
</Directory>
</VirtualHost>
#
<VirtualHost *:80>
ServerName easyappointments
DocumentRoot c:/wamp64/www/easyappointments
<Directory "c:/wamp64/www/easyappointments/">
AllowOverride All
Require all granted
</Directory>
</VirtualHost>



Edited 2 time(s). Last edit at 08/10/2017 10:52PM by ranasrule.

Options: ReplyQuote
Re: Block WampServer 3 homepage from remote machine
Posted by: RiggsFolly (Moderator)
Date: August 10, 2017 11:46PM

Yes

DONT GRANT ACCESS TO IT IN THE localhost Virtual Host. It was not set to be accessible in the install, why did you grant access to it?

<VirtualHost *:80>
    ServerName localhost
    DocumentRoot c:/wamp64/www
    <Directory "c:/wamp64/www/">
        #Options +Indexes +Includes +FollowSymLinks +MultiViews
        AllowOverride All


        Require local

    </Directory>
</VirtualHost>

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Block WampServer 3 homepage from remote machine
Posted by: ranasrule (182.180.103.---)
Date: August 11, 2017 03:31AM

RiggsFolly Wrote:
-------------------------------------------------------
> Yes
>
> DONT GRANT ACCESS TO IT IN THE localhost Virtual
> Host. It was not set to be accessible in the
> install, why did you grant access to it?
>
>
> <VirtualHost *:80>
>     ServerName localhost
>     DocumentRoot c:/wamp64/www
>     <Directory "c:/wamp64/www/">
>         #Options +Indexes +Includes
> +FollowSymLinks +MultiViews
>         AllowOverride All
> 
> 
>         Require local
> 
>     </Directory>
> </VirtualHost>
>

Thanks for the reply. When I do what you said ie only allow local access to localhost(192.168.0.100) I cant access 192.168.0.100/easyappointments/ either. Apache says I don't have permission.

Options: ReplyQuote


Sorry, only registered users may post in this forum.