Just installed Webserver and getting : Forbidden
Posted by: matrixebiz (205.189.202.---)
Date: July 06, 2017 06:09PM

Hello, sorry if this has be asked before but I just installed the Webserver and copied an index.html file to the www folder, the port 80 checks all pass but still getting this error when I try to access the server remotely;


Forbidden

You don't have permission to access / on this server.
Apache/2.4.23 (Win64) PHP/5.6.25 Server at myservername.com Port 80


Is there something else I have to enable? Thank you

Options: ReplyQuote
Re: Just installed Webserver and getting : Forbidden
Posted by: RiggsFolly (Moderator)
Date: July 06, 2017 06:16PM

Hi,

1) You should not put anything in the \www\ folder that is where the WAMPManager homepahe lives. Its called index.php

2) Access is controlled by the localhost Virtual Host. Edit by using the menu.

wampmanager ->Apache->httpd-vhost.conf

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Just installed Webserver and getting : Forbidden
Posted by: matrixebiz (205.189.202.---)
Date: July 06, 2017 06:33PM

See Below



Edited 1 time(s). Last edit at 07/06/2017 08:01PM by matrixebiz.

Options: ReplyQuote
Re: Just installed Webserver and getting : Forbidden
Posted by: matrixebiz (205.189.202.---)
Date: July 06, 2017 06:44PM

Put Server Online and restarted services but still getting forbidden from outside my network

Here is my httpd-vhosts.conf;
#
# Virtual Hosts
#

<VirtualHost *:80>
ServerName localhost
DocumentRoot c:/wamp64/www
<Directory "c:/wamp64/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>
#
<VirtualHost *:80>
ServerName Test
DocumentRoot C:/wamp64/www/Test
<Directory "C:/wamp64/www/Test">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require all granted
</Directory>
</VirtualHost>
#



Edited 5 time(s). Last edit at 07/06/2017 08:11PM by matrixebiz.

Options: ReplyQuote
Re: Just installed Webserver and getting : Forbidden
Posted by: Otomatic (Moderator)
Date: July 06, 2017 08:41PM

Hi,

A final slash for <Directory directive.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Just installed Webserver and getting : Forbidden
Posted by: matrixebiz (205.189.202.---)
Date: July 06, 2017 08:58PM

Sorry, not sure what you mean.

Options: ReplyQuote
Re: Just installed Webserver and getting : Forbidden
Posted by: Otomatic (Moderator)
Date: July 06, 2017 09:13PM

Hi

<Directory "c:/blabla/foo/">
Full path with / at the end.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.