HTTP 500 error That’s odd... the website can’t display this page
Posted by: zvi (---.red.bezeqint.net)
Date: June 28, 2017 09:18AM

Installed the WampServer and the server is running (green)

To start wordpress installation I login in to [localhost]

and then I get the error....

HTTP 500 error
That’s odd... the website can’t display this page

Any Idea ?

Options: ReplyQuote
Re: HTTP 500 error That’s odd... the website can’t display this page
Posted by: Otomatic (Moderator)
Date: June 28, 2017 09:30AM

Hi,

You MUST use VirtualHost : The need for Virtual Host

The VirtualHost devoted to WordPress must be created and be valid BEFORE the installation of WordPress.

Why do you want to use port 8080?

Port 80 is the port reserved for the HTTP protocol.
If another application uses port 80, it is this application that must change ports, not the HTTP protocol.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
Wampserver 3.0.9 64 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
PhPMyAdmin 4.7.1 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: HTTP 500 error That’s odd... the website can’t display this page
Posted by: zvi (---.red.bezeqint.net)
Date: June 28, 2017 10:07AM

When I use localhost with out 8080 i ger error HTTP 404 error
That’s odd... Microsoft Edge can’t find this page

so that why i changed to 8080 .

you mention "You MUST use VirtualHost : The need for Virtual Host

The VirtualHost devoted to WordPress must be created and be valid BEFORE the installation of WordPress"

could you explain what i need to do step by step.

Options: ReplyQuote
Re: HTTP 500 error That’s odd... the website can’t display this page
Posted by: RiggsFolly (Moderator)
Date: June 28, 2017 10:41AM

Hi

1. Make a folder whereever you want to locate the webite.
- EG C:\websites\project1\www

2. Start WAMPServer
3. Go to `localhost`
4. On the homepage you will find a link under Tools called Add a Virtual Host Click it
5. Follow the instruction on the page that loads

We made it as simple as possible, I hope.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.