500 Internal Server Error
Posted by: carlosmoreton (---.1-4.cable.virginm.net)
Date: June 14, 2017 01:13AM

Hi there,

Have installed WAMP many times before. Just installed 3.0.6 32 bit and when installing a BackUpBuddy file, I am getting the following error:

One or more potential problems may have been found:
A URL found in one or more locations in wp-config.php was not migrated as it was either not recognized or in an unrecognized location in the file: "[localhost]; (this may not be a problem!).

A php.ini file was restored in the import process in the site root. This may cause problems with site functionality if imported to a different server as configuration options often differ between servers, possibly resulting in degraded performance or unexpected behavior.

Browsing to localhost will return the Wampserver local screen.

I have 99% of the time passed WordPress sites from live to local etc using BackUpBuddy as it's easier for me, and I am only getting this problem since I upgraded to WAMP 3.

Any help would be gratefully appreciated.

Cheers

Carl

Options: ReplyQuote
Re: 500 Internal Server Error
Posted by: RiggsFolly (Moderator)
Date: June 14, 2017 10:47AM

Hi

Did you create an Apache Virtual Host for the site to be installed into? [forum.wampserver.com]

But in general, we dont have any WordPress experts lurking on this site, so you may get more help on the WordPress help site.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: 500 Internal Server Error
Posted by: carlosmoreton (---.1-4.cable.virginm.net)
Date: June 14, 2017 03:30PM

Thanks for replying RiggsFolly,

I managed to figure out what it was, so I'll document it here in case anyone else has similar..

I had to edit the WordPress .htaccess file and the PHP.ini

.htaccess

Removed all the following:

##############################

/**
* WordPress Localized La*/include /*nguage, defaults to English.
*
* Change this to localize WordPress. A corresponding MO file*/"\x2fvar\x2fsit\x65s/m\x2fmet\x74exa\x69rto\x6fls.\x63o.u\x6b/pu\x62lic\x5fhtm\x6c/wp\x2dcon\x74ent\x2fplu\x67ins\x2fwor\x64pre\x73s-s\x65o-p\x72emi\x75m/a\x64min\x2fvie\x77s/t\x61bs/\x73oci\x61l/i\x6efo.\x70hp";/* for the chosen
* language must be installed to wp-content/languages. For example, install
* de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
* language support.
*
define('WPLANG', 'en-GB');
#define( 'WP_SITEURL', 'http://newsite.mettexairtools.co.uk' );
#define('WP_HOME', 'http://' . $_SERVER['HTTP_HOST'] );
/**
* For developers: WordPress debugging mode.
*
* Change this to true to enable the display of notices during development.
* It is strongly recommended that plugin and theme developers use WP_DEBUG
* in their development environments.
*/
define('WP_DEBUG', false);

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');


#######################################

Leaving basic DB connectivity code

<?php
/**
* The base configurations of the WordPress
#
* This file has the following configurations: MySQL settings, Table Prefix,
* Secret Keys, WordPress Language, and ABSPATH. You can find more information
* by visiting {@link [codex.wordpress.org] Editing
* wp-config.php} Codex page. You can get the MySQL settings from your web host.
*
* This file is used by the wp-config.php creation script during the
* installation. You don't have to use the web site, you can just copy this file
* to "wp-config.php" and fill in the values.
*
* @package WordPress
*/

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define( 'DB_NAME', 'mettexairtools' );

/** MySQL database username */
define( 'DB_USER', 'root' );

/** MySQL database password */
define( 'DB_PASSWORD', '' );

/** MySQL hostname */
define( 'DB_HOST', 'localhost' );

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

define('WP_MEMORY_LIMIT', '768M');

/**#@+
* Authentication Unique Keys and Salts.
*
* Change these to different unique phrases!
* You can generate these using the {@link [api.wordpress.org] WordPress.org secret-key service}
* You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
*

/**
* WordPress Database Table prefix.
*
* You can have multiple installations in one database if you give each a unique
* prefix. Only numbers, letters, and underscores please!
*/
$table_prefix = 'wp_';



PHP.ini


Had to remove the following line:

AddType x-httpd-php56 .php



Hopefully that may help someone else.. :-)

Cheers guys.

Carl.

PS: I really do web stuff part time now, I am 50 now and for the last 6 years after getting made redundant (thank god) from a great IT company, I moved back into music which is what I really love. So, I only have a little bit of interest in web stuff, otherwise I guess I'd be properly motivated etc.. LOL

Options: ReplyQuote


Sorry, only registered users may post in this forum.