wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Sonja M. (---.adslplus.ch)
Date: May 13, 2017 06:23PM

Hello wamp installation cracks :-)

I have a problem with the following configuration:

1 - Windows version used (Specify version number AND whether 32 or 64 bit)
W 7 Pro 64 bit, service pack 1.

2 - Version WampServer (Specify version number AND whether 32 or 64 bit)
Wampserver 3.0.6 64 bit

3 - Apache Version
Apache 2.4.23

4 - PHP Version
PHP 5.6.25

6 - What color is the WampServer icon (in the notification area of the taskbar)
it is GREEN, that works fine.

7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines with the name [localhost] in them?
* Active means no # at the beginning of the line.
in c:\windows\system32\drivers\etc\hosts, the active lines are:
127.0.0.1 localhost
::1 localhost
127.0.0.1 localhost


If the WampServer icon is green:

8 - Do you have access to localhost (Homepage WampServer)?
YES
8a - If so, is there an error message at the bottom of the page?
NO

9 - Do you have access to phpMyAdmin?
NO. A blank (white) page appears, with a sandclock cursor, which converts into a normal cursor when I move the mouse.

10 - If you refer to an error message, please include the EXACT wording of the error in your post

11 - If you use an Antivirus and / or Firewall, please include the names of these
this PC is for PHP development only, so it is not connected to the internet and has no antivirus.

12 - What is the full path to the installation of WampServer (eg D:\wamp\)
c:\wamp64\

13 - If you have one or more Virtual Hosts defined, please show their definition(s):
-

Error history:
On this PC, I was working successfully with wamp2.5/32 bit during many months.
The upgrade to wamp3/64 bit was not a success:
I deinstalled the old Wampserver and installed the 10 prerequisites from microsoft, then the new wampserver (first, wamp3.0.6-64, then I tried wamp3.0.8-64, then I tried your PHP 7.0.19 addon,
the result was the same each time: I do have access to localhost, but I get an empty (white) page when trying to go to phpMyAdmin.
After each step, I rebooted.

Could you give me any help of what might be the problem ? What additional infos might help solving the problem ?

Best regards, Sonja

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Otomatic (Moderator)
Date: May 14, 2017 09:46AM

Hi,

> this PC is for PHP development only, so it is not connected to the internet
In the file wamp64\apps\phpmyadmin4.x.y\config.inc.php insert before ?>
$cfg['VersionCheck'] = false;

If the problem is the same, try :
in file wamp64\apps\phpmyadmin4.x.y\libraries\vendor_config.php
replace
define('VERSION_CHECK_DEFAULT', true);
by
define('VERSION_CHECK_DEFAULT', false);

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
Wampserver 3.0.9 64 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
PhPMyAdmin 4.7.1 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Sonja M. (---.adslplus.ch)
Date: May 16, 2017 12:18AM

Hi Otomatic,


thank you for your fast and precise answer !
I retried with your latest packages:

----------------------------------
02 wamp server 3.0.8 64 bit

01 W 7 Pro 64 bit Service pack 1
03 A 2.4.23
05 M 5.7.14
04 P 7.0.19

06 GREEN icon

07 c:\Windows\System32\drivers\etc\hosts:
127.0.0.1 localhost
::1 localhost
127.0.0.1 localhost

8 - Do you have access to localhost (Homepage WampServer)?: YES
8a - If so, is there an error message at the bottom of the page?: NO

9 - Do you have access to phpMyAdmin?
NO. A blank (white) page appears, with a sandclock cursor, which converts into a normal cursor when I move the mouse.

10
11 - If you use an Antivirus and / or Firewall, please include the names of these
this PC is for PHP development only, so it is not connected to the internet and has no antivirus.

12 - What is the full path to the installation of WampServer (eg D:\wamp\)
c:\wamp\

13
-----------------------------------
I made the changes you proposed in the 2 files, but phpMyAdmin still gives a blank page.

So whatelse could it be ? Is there any logfile which would guide us to the bug ?


Kind regards, Sonja

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Otomatic (Moderator)
Date: May 16, 2017 09:52AM

Hi,

PhpMyAdmin is very well launched even with no Internet connection.
Have you tried changing your browser?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
Wampserver 3.0.9 64 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
PhPMyAdmin 4.7.1 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Sonja M. (---.adslplus.ch)
Date: May 16, 2017 07:27PM

Hi Otomatic,


this time, it was a full success - thank you so much for your advice !

Here is the list of browsers I tested, and the results regarding phpMyAdmin:

wampserver 2.5:
* Firefox 2004: running with some difficulties
* MSIE 2009: running fine
* Safari 2012: running fine
* Vivaldi 2017: running fine

wampserver 3.0.8:
* Firefox 2004: error message
* MSIE 2009: blank page
* Safari2012: blank page
* Vivaldi 2017: running fine

Of course, it would be great if the wampserver could test the browser to issue a more precise error message than just a blank page.


Kind regards, Sonja

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: RiggsFolly (Moderator)
Date: May 16, 2017 07:33PM

Hi

phpMyAdmin is not WAMPServer, its a tool you will find on almost all hosting packages.

It is rather unusual to find a PC nowadays that has managed to download WAMPServer but does not hjave an internet connection.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Sonja M. (---.adslplus.ch)
Date: May 17, 2017 07:34PM

Hi Riggsfolly,

> It is rather unusual to find a PC nowadays that has managed to download WAMPServer but does
> not have an internet connection.
haha, do you like viruses on your system ? Do you know how fast W7 can start if not littered with all kind of updates ? The secret is to have 2 PCs, one on the internet and theother (the development machine) separated. I can recommand it to anyone.

Anyway, wampserver 3.0.8 works now perfectly on my system; thank you and Otomatic for your help :-)

Best, Sonja

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: RiggsFolly (Moderator)
Date: May 17, 2017 07:56PM

Glad its all working!

RE: Virus's

Never had one. Even though my PC is connected to the Internet.
Look up what Routers and NAT do for you. +Virus Checkers and Firewalls

Also, specially recently you should have heard what happens to PC's that are not properly patched and up to date.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: wampserver 3.0: localhost works fine, phpMyAdmin gives empty page
Posted by: Otomatic (Moderator)
Date: May 17, 2017 09:33PM

Hi,

The best antivirus and antimalware is intelligence located between the chair and the keyboard.

But, in the recent problems of data encryption and ransom demand, this intelligence has been below all.

Default known for over four months and corrected by Microsoft three months ago, and even recently for XP.
Those who have had themselves are themselves responsible for what happens to them.
The IT managers of the affected companies are incapable. It was enough to apply the updates.

Windows not up to date for the default corrected on the SMBv1 protocol are vulnerable to opening a trapped e-mail.
The patch released in March was for Windows Vista, Windows 7, Windows 8.1, Windows 10, Windows Server 2008, Windows Server 2012, and Windows Server 2016.

And even without applying this patch, it was enough to follow the recommendations of Microsoft: disable the SMBv1 protocol, which is an old protocol replaced by SMBv2 and v3 which they do not possess this exploited fault at the moment.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
Wampserver 3.0.9 64 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
PhPMyAdmin 4.7.1 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.