Does not work correct with Listen 80 port
Posted by: evdokimovm (217.150.77.---)
Date: May 13, 2017 04:38AM

Windows 10 Version 1703 Build 15063.296
WAMP 3.0.8 32-bit

I have real (static) IP address.

My problem is that when I use

Listen 0.0.0.0:80
Listen [::0]:80

or just

Listen 80

in httpd.conf file and press "Put Online" button, to my server cannot access from internet. Screenshot: [i.imgur.com]

But if I use any other port, for example:

Listen 0.0.0.0:8080
Listen [::0]:8080

or just

Listen 8080

It's work correctly. Screenshot: [i.imgur.com]

Note:

Port 80 is not used by any application. For example: If I use XAMPP, port 80 work correctly.

When I use WAMP, XAMPP is disabled.



Edited 2 time(s). Last edit at 05/13/2017 06:53AM by evdokimovm.

Options: ReplyQuote
Re: Does not work correct with Listen 80 port
Posted by: RiggsFolly (Moderator)
Date: May 13, 2017 01:46PM

Hi,

The Put Online menu is basically defunct as of WAMPServer 3 thats why it is not visible by default.

Instead look at the httpd-vhosts.conf file and make your access changes in there. Leave httpd.conf as it was.
Theer is a link to this file in the menu system just below the one for httpd.conf

#
# Virtual Hosts
#

<VirtualHost *:80>
	ServerName localhost
	DocumentRoot D:/wamp/www
	<Directory  "D:/wamp/www/">
		Options +Indexes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>

Can I also suggest you read THE NEED for VIRTUAL HOSTS

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-



Edited 1 time(s). Last edit at 05/13/2017 01:46PM by RiggsFolly.

Options: ReplyQuote
Re: Does not work correct with Listen 80 port
Posted by: evdokimovm (217.150.77.---)
Date: May 14, 2017 04:13AM

RiggsFolly Wrote:
-------------------------------------------------------
> Hi,
>
> The Put Online menu is basically defunct as of
> WAMPServer 3 thats why it is not visible by
> default.
>
> Instead look at the httpd-vhosts.conf file and
> make your access changes in there. Leave
> httpd.conf as it was.
> Theer is a link to this file in the menu system
> just below the one for httpd.conf
>
>
> #
> # Virtual Hosts
> #
> 
> <VirtualHost *:80>
> 	ServerName localhost
> 	DocumentRoot D:/wamp/www
> 	<Directory  "D:/wamp/www/">
> 		Options +Indexes +FollowSymLinks +MultiViews
> 		AllowOverride All
> 		Require local
> 	</Directory>
> </VirtualHost>
>
>
> Can I also suggest you read
> [url=http://forum.wampserver.com/read.php?2,127757
> ]THE NEED for VIRTUAL HOSTS[/url]

Thanks. I changed

Require local

to

Require all granted

in httpd-vhosts.conf file and access to 80 port now from internet.

But I have question. Why in this case in httpd.conf works any other ports exclude 80? And how can I fix it.



Edited 1 time(s). Last edit at 05/14/2017 04:14AM by evdokimovm.

Options: ReplyQuote
Re: Does not work correct with Listen 80 port
Posted by: RiggsFolly (Moderator)
Date: May 15, 2017 10:31AM

If you want to use a Non Standard Port number for Apache (And I do not recommend it) use the wampmanager menus system to make the changes.

(right click) wampmanager->Tools -> Use a port other than 80

This will make the required chnages in ALL the RIGHT places

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.