an error
Posted by: arbor (---.dhcp.embarqhsd.net)
Date: May 12, 2017 05:25PM

I need help any help is appreciated I get an error when downloading wamp the error is the error says " The program can't start because VCRUNTIME140.dll is missing from your computer. Try reinstalling the program to fix this problem." and I've attempted to install VS 2012 which is why I'm after this post going to Microsoft and asking for help as it doesn't seem to of downloaded but it says so on the installer if reinstalled wamp but get the same error every time how do I fix this?

Options: ReplyQuote
Re: an error
Posted by: RiggsFolly (Moderator)
Date: May 12, 2017 05:32PM

Please read WAMPServer 3 All you need to know

Specifically the first section in RED

Then you will have to uninstall WAMPServer and only install it again when you have all the MSVC Runtimes installed.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-



Edited 1 time(s). Last edit at 05/12/2017 07:13PM by RiggsFolly.

Options: ReplyQuote
Re: an error
Posted by: Otomatic (Moderator)
Date: May 12, 2017 06:16PM

Hi,

> how do I fix this?
When you install a program, you never read the warning messages displayed before the installation actually starts?
You click Next or Install without worrying about what these warnings say!
And yet, what is displayed in the Wampserver installation message?

--- Installation of Wampserver ---
BEFORE proceeding with the installation of Wampserver, you must ensure that certain elements are installed on your system, otherwise Wampserver will absolutely not run, and in addition, the installation will be faulty and you need to remove Wampserver BEFORE installing the elements that were missing.
Make sure you are "up to date" in the redistributable packages VC9, VC10, VC11, VC13 and VC14

Then there are all the download links of the VC ++ packages as well as the explanations to install them.

I wonder why I bother to spend time writing these warnings and explanations.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.