error 0xc000007b
Posted by: shane-77 (---.bas512.cwt.btireland.net)
Date: May 07, 2017 12:15PM

Hi.
I'm trying to install wamp and I keep getting the error the application was unable to start correctly 0x00007b. Looking at various answers on google it seems to suggest to check all the prerequisites before installing which I have done. I have checked and doubled checked all my C/C++ Runtime Libraries and they are all installed correctly. I have also downloaded check_vcredist and after I run it I get the message all "VC++ packages needed to run wampserver are installed correctly". I have also turned off Skype and amended the SKYPE ports just to be safe and I've also disabled IIS. But every time I try to install wamp I still get the error 0x00007b.

Any idea what could cause this if its not my runtime library

Thanks

Options: ReplyQuote
Re: error 0xc000007b
Posted by: RiggsFolly (Moderator)
Date: May 07, 2017 02:45PM

Hi

Well you seem to have done quite a bit of research.

To help us to help you can you READ (and answer) BEFORE YOU ASK A QUESTION so we know a little more about your environment

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: error 0xc000007b
Posted by: shane-77 (---.bas512.cwt.btireland.net)
Date: May 07, 2017 05:49PM

Hi.
Sorry I'm using windows 10 and its a 64 bit system. I'm trying to install the latest version of wamp Wampserver 3.0.6 64 bit x64 – Apache 2.4.23 – PHP 5.6.25/7.0.10 – MySQL 5.7.14 . As soon as I try to open wamp I get the error 0xc000007b and the wamp icon will stay at amber.

When I check the apache error log I get the message cannot find the c:\wamp64\logs\apache_error.log file and I get the same result for the apache access log cannot find the c:\wamp64\logs\access.log file

For the mysql error log I get the following message.

2017-05-07T15:25:18.839405Z 0 [Warning] InnoDB: Resizing redo log from 2*3072 to 2*320 pages, LSN=2526070
2017-05-07T15:25:19.071217Z 0 [Warning] InnoDB: Starting to delete and rewrite log files.
2017-05-07T15:25:19.800961Z 0 [Warning] InnoDB: New log files created, LSN=2526070

For the PHP error log I have the following

[07-May-2017 15:25:14 UTC] No error - Only to create the file

The active lines with the name [localhost] in system 32 is the following

127.0.0.1 localhost
127.0.0.1 localhost
127.0.0.1 localhost


Thanks

Options: ReplyQuote
Re: error 0xc000007b
Posted by: RiggsFolly (Moderator)
Date: May 07, 2017 06:11PM

This sounds like Apache has not started.

There are a number of reasons this can happen all of which normally mean that something else is using TCP Port 80.

As its windows 10 you are using it is likely to be either SKYPE or IIS.

Windows 10 installs IIS (MS's WebServer) by default (for reasons only known to MS) If you are not using it I suggest you uninstall it as it is not required for normal operation of Windows.



So go to Start -> Control Panel -> Programs and Features
Click the 'Turn windows features on and off' link in the left hand menu.
Wait for the list to load and then find 'Internet Information Services'

Un check the check boxes for the following items ( you may not see all of them ), and there may be others I done know about. You may have all of these or just some of these.

1. IIS
2. Web Deploy 2.0 (Web Deployment Agent Service)
3. MS Sql Server Reporting service.
4. BranchCache ( Windows 8.1 )
5. SQL Server VSS Writer




Windows will then have a think for a while and then remove those applications, you will probably be asked to reboot to complete the uninstalls.
Reboot anyway when the uninstalls are complete.

Then try wamp again.


Alternativeley just disable it/them.

Start -> Control Panel -> Administrative Tools -> Services

Find IIS in the list of services.
Left Click that line and select Properties
Change the 'Startup Type' to disabled.
Ditto for the other possibilities if you see them.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.