missing php files on install revisited
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 29, 2017 10:36PM

1 - Windows version used (Specify version number AND whether 32 or 64 bit)
Win 10 x64
2 - Version WampServer (Specify version number AND whether 32 or 64 bit)
WAMP 2.5 x86
3 - Apache Version
Apache 2.4.9
4 - PHP Version
PHP 5.5.12
5 - MySQL Version
MySQL 5.6.17
6 - What color is the WampServer icon (in the notification area of the taskbar)
Green.

When all goes well it should be green, but it may be red or orange.

If the WampServer icon is NOT GREEN please ensure you have looked at these files :-

The icon IS GREEN

a - Apache error log
-- ( wampmanager -> Apache -> Apache error log )
-- ( wampmanager -> Apache -> Apache access log )
b - MySQL error log ( wampmanager -> MySQL -> MySQL log )
c - PHP error log ( wampmanager -> PHP -> PHP error log )

This is curious. These DLLs have repeatedly failed to install.

[29-Apr-2017 19:27:54 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.
in Unknown on line 0
[29-Apr-2017 19:27:54 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.
in Unknown on line 0
[29-Apr-2017 19:27:54 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.
in Unknown on line 0
[29-Apr-2017 19:27:54 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.
in Unknown on line 0

Depending on the error, one or all of the above may be empty so also look at
d - The windows event viewer
--- Windows Key + R to launch the run dialog then enter eventvwr.exe and press the OK button
--- - On the left side of the windows click 'Windows Logs -> Applications'
--- - Look for the names 'Apache Service' or 'MySQL' in the Source column which have a error symbol in the first column.

If you find any errors that you cannot fix for yourself please post the COMPLETE EXACT error message in your question.
Nothing related to WAMP operations shows here.

7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines with the name [localhost] in them?

* Active means no # at the beginning of the line.
<VirtualHost *:80>
DocumentRoot "c:/wamp/www/"
ServerName localhost
ServerAlias localhost
<Directory "c:/wamp/www">
AllowOverride All
Require local
</Directory>
</VirtualHost>
If the WampServer icon is green:

8 - Do you have access to localhost (Homepage WampServer)?

Yes, but it cannot be navigated from page to page. The dashboard cannot be accessed and therefore the site cannot be maintained or edited on my local machine.

8a - If so, is there an error message at the bottom of the page?

No.

9 - Do you have access to phpMyAdmin?

Yes.

10 - If you refer to an error message, please include the EXACT wording of the error in your post

11 - If you use an Antivirus and / or Firewall, please include the names of these

Windows Defender only. No conflicts.

12 - What is the full path to the installation of WampServer (eg D:\wamp\)

C:/wamp

13 - If you have one or more Virtual Hosts defined, please show their definition(s)

There are NO VIRTUAL HOSTS.

TIA.

Options: ReplyQuote
Re: missing php files on install revisited
Posted by: RiggsFolly (Moderator)
Date: April 30, 2017 06:15PM

Please confirm the following:

1 Does this file exists `c:/wamp/bin/php/php5.5.12/ext/php_intl.dll`

2 Does this file exists `c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll`

?

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: missing php files on install revisited
Posted by: Otomatic (Moderator)
Date: May 01, 2017 11:17AM

Hi,

In wamp/script/config.inc.php file replace all array:
$phpDllToCopy = array (
	'icudt....',
	...,
	...,
	);
by
//dll to create symbolic links from php to apache/bin
// // Versions of ICU are 38, 40, 42, 44, 46, 48 to 57
$icu = array(
  'number' => array('57', 56','55','54','53','52','51','50','49','48','46','44','42','40','38'),
  'name' => array('icudt', 'icuin', 'icuio', 'icule', 'iculx', 'icutest', 'icutu', 'icuuc'),
);
$php_icu_dll = array();
foreach($icu['number'] as $icu_number) {
  foreach($icu['name'] as $icu_name) {
    $php_icu_dll[] = $icu_name.$icu_number.".dll";
  }
}

$phpDllToCopy = array_merge(
  $php_icu_dll,
  array (
    'libmysql.dll',
    'libeay32.dll',
    'libsasl.dll',
    'libpq.dll',
    'libssh2.dll', //For php 5.5.17
    'php5isapi.dll',
    'php5nsapi.dll',
    'ssleay32.dll',
    'php5ts.dll',
    'php7ts.dll', //For PHP 7
)
);
Save modified file.

Restart Wampserver.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.9 32 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
Wampserver 3.0.9 64 bit - Apache 2.4.26 - PHP 7.1.7/7.0.21/5.6.31 - MySQL 5.7.18 - MariaDB 10.2.6
PhPMyAdmin 4.7.1 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Windows 10 x64 does not play nicely with WAMP
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: May 19, 2017 07:01PM

Thanks for your continued efforts Oto!

Just so you know, I tried the Windows UserCRT package and Windows would not allow a single one to be installed. ALL the other VC packages are installed.

I also copied the PHP code into the page you gave me and it did not help.

All behaved as it did before.

I can get localhost to show me its two folders, my site and an install of wordpress 4.7.4. I can click on either but none require me to login; consequently, I cannot get into the backend of wordpress to change any settings or edit a site.

I am persuaded that there is some inherent conflict between Windows 10 x64 and WAMP. When I still had my 32 bit version (x86) of Windows 10, WAMP worked just fine.

MIA, Merci in advance.



Edited 2 time(s). Last edit at 05/24/2017 04:41AM by decombs21.

Options: ReplyQuote


Sorry, only registered users may post in this forum.