just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 25, 2017 07:26AM

Greetings:

I've just recently acquired and installed Windows 10 Pro x64, installed WAMP 2.5 x32 and was happy to see a green icon!

Not looking a gift horse in the mouth I installed my WordPress 4.7.3 website (version at the time I used Duplicator to copy it) and it didn't work. It hangs on an error reported on line 15 of my index.php file.

Now I read that when running x64 Windows I need to install install all of the run-time libraries (VC9 - VC14) in BOTH x32 and x64 executables.

Previously I didn't understand that I needed both x32 and x64 VC distributables when running x64 Windows 10. Do I understand that correctly?

Ultimately I hope that doing so may correct the problem encountered above.

Also I see that installing the wampserver 3.0.8 update is strongly advised. I
see too that it will install newer versions of Apace, PHP and MySql but won't activate them. I definitely want that because I don't want any problems running the database created in the original WAMP 2.5 x32 install.

Would this be a sound strategy to follow or no? I would like to apply the update but it isn't absolutely necessary, getting the site to run is.


Adieu,

Dave

Options: ReplyQuote
Re: just double checking on my next move
Posted by: Otomatic (Moderator)
Date: April 25, 2017 09:42AM

Hi,

See WAMPserver 3 - All you need to know

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 27, 2017 03:56AM

Dominique,

I installed as administrator only wamp 2.5 and my WP site, however I can't sign in. I've followed all the instructions and have a green icon.

Every time I try to access localhost I get an fatal error to the call stack at line 15 in index.php.

Any help would be appreciated.

Merci.

Options: ReplyQuote
Re: just double checking on my next move
Posted by: Otomatic (Moderator)
Date: April 27, 2017 09:35AM

Hi,

Why Wampserver 2.5 and not Wampserver 3.0.6?

Please READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 27, 2017 10:23PM

I built the site with wamp 2.5 and wanted to minimize any chance of errors.

In answer to the 13 questions I have the following the most important would seem to be a missing dll file.

1 - Windows version used (Specify version number AND whether 32 or 64 bit)

Win 10 x64

2 - Version WampServer (Specify version number AND whether 32 or 64 bit)

WAMP 2.5 x86

3 - Apache Version

Apache 2.4.9

4 - PHP Version

PHP 5.5.12

5 - MySQL Version

MySQL 5.6.17

6 - What color is the WampServer icon (in the notification area of the taskbar)

A nice pretty green.

When all goes well it should be green, but it may be red or orange.

If the WampServer icon is NOT GREEN please ensure you have looked at these files :-
a - Apache error log
-- ( wampmanager -> Apache -> Apache error log )
-- ( wampmanager -> Apache -> Apache access log )
b - MySQL error log ( wampmanager -> MySQL -> MySQL log )
c - PHP error log ( wampmanager -> PHP -> PHP error log )

Found in the PHP log. How do I find this DLL? I’ll bet this is the problem.

[27-Apr-2017 00:41:26 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found. in Unknown on line 0

Depending on the error, one or all of the above may be empty so also look at
d - The windows event viewer
--- Windows Key + R to launch the run dialog then enter eventvwr.exe and press the OK button
--- - On the left side of the windows click 'Windows Logs -> Applications'
--- - Look for the names 'Apache Service' or 'MySQL' in the Source column which have a error symbol in the first column.

None seen.

If you find any errors that you cannot fix for yourself please post the COMPLETE EXACT error message in your question.

Nothing related to WAMP operations shows here.

7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines with the name [localhost] in them?
* Active means no # at the beginning of the line.

127.0.0.1 localhost
127.0.0.1 threestrikes

::1 localhost
::1 threestrikes
127.0.0.1 localhost
127.0.0.1 localhost

If the WampServer icon is green:

8 - Do you have access to localhost (Homepage WampServer)?

No. I get this –

Fatal error: Call to undefined function get_header() in C:\wamp\www\wp-content\themes\threestrikes\index.php on line 15

8a - If so, is there an error message at the bottom of the page?

No.

9 - Do you have access to phpMyAdmin?

Yes.

10 - If you refer to an error message, please include the EXACT wording of the error in your post
11 - If you use an Antivirus and / or Firewall, please include the names of these

Windows Defender only.

12 - What is the full path to the installation of WampServer (eg D:\wamp\)

C:\wamp

13 - If you have one or more Virtual Hosts defined, please show their definition(s)

None listed.

Options: ReplyQuote
Re: just double checking on my next move
Posted by: RiggsFolly (Moderator)
Date: April 28, 2017 01:09AM

Hi
To clear that issue, do this

Start WAMPServer.
Using the wampmanager menus
left click wampmanager->Apache->Version-> click on the version number.

Stop WAMPServer

Start WampServer

Check the error log. Make sure you are looking for NEW errors, and not seeing the old ones.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 28, 2017 06:01AM

Riggs,

Thanks for your reply.

I restarted WAMP and saw no errors for Apache or Access (access).

I did find the same error in the PHP error log -

[27-Apr-2017 00:41:26 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

in Unknown on line 0

[27-Apr-2017 00:41:26 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

in Unknown on line 0

[27-Apr-2017 00:41:27 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

in Unknown on line 0

[27-Apr-2017 00:41:27 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

I see 2 missing DDL files not just one. Great.

What next?

TIA.

Options: ReplyQuote
Re: just double checking on my next move
Posted by: RiggsFolly (Moderator)
Date: April 28, 2017 01:58PM

Restarted WAMPServer, BUT did you also do as suggested i.e. clicking on the Apache Version number in the menus as specified?

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 28, 2017 07:52PM

Sorry, I forgot.

It is Apache 2.4.9.

Options: ReplyQuote
Re: just double checking on my next move
Posted by: RiggsFolly (Moderator)
Date: April 28, 2017 10:58PM

Thats not an answer to the question

Start WAMPServer.
Using the wampmanager menus
left click wampmanager->Apache->Version-> 2.4.9 (click on the version number)

Stop WAMPServer

Start WampServer

Check the error log. Make sure you are looking for NEW errors, and not seeing the old ones.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 29, 2017 07:27AM

Riggs:

I did as you said and found errors only in the PHP error log-

[29-Apr-2017 07:20:58 Europe/Paris] PHP Fatal error: Call to undefined function get_header() in C:\wamp\www\wp-content\themes\threestrikes\index.php on line 15

[29-Apr-2017 07:20:58 Europe/Paris] PHP Stack trace:

[29-Apr-2017 07:20:58 Europe/Paris] PHP 1. {main}() C:\wamp\www\wp-content\themes\threestrikes\index.php:0

[29-Apr-2017 07:20:58 Europe/Paris] PHP Fatal error: Call to undefined function get_header() in C:\wamp\www\wp-content\themes\threestrikes\index.php on line 15

[29-Apr-2017 07:20:58 Europe/Paris] PHP Stack trace:

[29-Apr-2017 07:20:58 Europe/Paris] PHP 1. {main}() C:\wamp\www\wp-content\themes\threestrikes\index.php:0

TIA.

Options: ReplyQuote
Re: just double checking on my next move
Posted by: Otomatic (Moderator)
Date: April 29, 2017 09:28AM

Hi,

> 29-Apr-2017 07:20:58 Europe/Paris] PHP Fatal error: Call to undefined function get_header()
> in C:\wamp\www\wp-content\themes\threestrikes\index.php on line 15


This is quite normal, since the get_header() function does not exist.
The PHP function is get_headers ()

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: just double checking on my next move
Posted by: decombs21 (---.hsd1.ca.comcast.net)
Date: April 29, 2017 10:07AM

That may be Oto but it stops me cold. I can't get past that error. It won't load.

But it does exist on that page -

<?php
/**
* The main template file.
*
* This is the most generic template file in a WordPress theme
* and one of the two required files for a theme (the other being style.css).
* It is used to display a page when nothing more specific matches a query.
* E.g., it puts together the home page when no home.php file exists.
*
* @link [codex.wordpress.org]
*
*/

get_header(); ?>

<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">

And then there's the matter of the missing DLL file noted in the above posts.

TIA.



Edited 1 time(s). Last edit at 04/29/2017 10:34AM by decombs21.

Options: ReplyQuote


Sorry, only registered users may post in this forum.