Upgraded WampServer, now can't start MySQL
Posted by: SRD (---.lns4.way.bigpond.net.au)
Date: April 23, 2017 03:14PM

I moved my WampServer www and SQL/data to Dropbox, and WampServer was working fine like this.

I noticed I was using an old version of WampServer on my desktop, while using the latest version of WampServer on my laptop.

I uninstalled WampServer on my desktop, and installed wampserver3.0.6_x86_apache2.4.23_mysql5.7.14_php5.6.25-7.0.10 on my desktop.

I edited my.ini: datadir="D:/Dropbox/WAMP/SQL"

When I load [localhost] in my browser, I attempt to login, but receive the error:

No connection could be made because the target machine actively refused it. — The server is not responding (or the local server's socket is not correctly configured).

If I check C:\wamp\logs\mysql.log I see:

wampmysqld: Table 'mysql.plugin' doesn't exist
2017-04-15T11:43:23.372042Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2017-04-15T11:43:23.373043Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2017-04-15T11:43:23.378046Z 0 [Warning] Failed to open optimizer cost constant tables

2017-04-15T11:43:23.384551Z 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2017-04-15T11:43:23.386553Z 0 [ERROR] Aborting

If I look in the folder D:\Dropbox\WAMP\SQL\data\mysql, I see the files:

plugin.frm
plugin.MYD
plugin.MYI
user.frm
user.MYD
user.MYI
If I run the following in a cmd window:

C:\wamp\bin\mysql\mysql5.7.14\bin> mysql_upgrade.exe

I receive the error:

mysql_upgrade: Got error: 2003: Can't connect to MySQL server on 'localhost' (10061) while connecting to the MySQL server Upgrade process encountered error and will not continue.

If I go to System Tray > Wamp > MySQL > Version, I see only one option: 5.7.14.

If I try to start MySQL from Wamp icon, or services.msc, it won't start, and the errors above repeat.

Update: if I run [localhost] on my laptop, which uses www and SQL data in Dropbox too, phpMyAdmin produces no error, and detects the databases fine, and lists them down the left hand side.

What do I need to do from here?

Options: ReplyQuote
Re: Upgraded WampServer, now can't start MySQL
Posted by: Otomatic (Moderator)
Date: April 23, 2017 03:49PM

Hi,

> datadir="D:/Dropbox/WAMP/SQL"
It is absolutely impossible to use the same "datadir" with different MySQL versions.
It should not be forgotten that datadir includes databases internal to MySQL (mysql, performance_schema and sys) as well as the files ib_buffer_pool, ib_logfile0, ib_logfile1, ibdata1and that these databases and files are incompatible between different versions of MySQL.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 04/23/2017 03:51PM by Otomatic.

Options: ReplyQuote


Sorry, only registered users may post in this forum.