WAMP 3 x64 needs VC9 x86 and x64 and others VCs only x64?
Posted by: cintya.t (---.dsl.telesp.net.br)
Date: March 21, 2017 04:18PM

To install and run WAMP 3 x64, should I install ALL required Microsoft Visual C/C++ Redistributable packages, both versions x86 and x64, or ONLY for VC9 - i.e, Microsoft Visual C/C++ Redistributable 2008 x86 and x64, and the others (VC10, VC11, VC13 and VC14) only the x64 version?

Options: ReplyQuote
Re: WAMP 3 x64 needs VC9 x86 and x64 and others VCs only x64?
Posted by: RiggsFolly (Moderator)
Date: March 21, 2017 04:38PM

- - - - - - - YES - - - - - - -

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: WAMP 3 x64 needs VC9 x86 and x64 and others VCs only x64?
Posted by: Otomatic (Moderator)
Date: March 21, 2017 06:12PM

Hi,

What is noted, in the prerequisites, at the end of the part

--- Visual C++ Packages --- ?
If you have a 64-bit Windows, you must install both 32 and 64bit versions, even if you do not use Wampserver 64 bit.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.12/7.0.26/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WAMP 3 x64 needs VC9 x86 and x64 and others VCs only x64?
Posted by: denver49 (---.hsd1.co.comcast.net)
Date: March 21, 2017 11:21PM

For Windows 10 users, the wording at the following Microsoft link seems to indicate to me that the Universal C Runtime are built into a Windows 10 operating system. Yet they are not listed under Control Panel / Programs.

[support.microsoft.com]

Which leaves me somewhat reluctant to install Universal C Runtime, for fear of messing up other applications.

Options: ReplyQuote
Re: WAMP 3 x64 needs VC9 x86 and x64 and others VCs only x64?
Posted by: RiggsFolly (Moderator)
Date: March 22, 2017 12:46AM

As is documented in WAMPServer 3 All you need to know


If you are running WIndow pre windows 10, and you are running a component that uses Apache/Mysql/PHP compiled with MSVC 2015(VC14) you will also need to install the `Universal C Runtime` This can be download via the standard Windows Update according to this document on the microsoft site


Therefore if you are using Windows 10 you do not need to install the Univrsal C Runtime.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote


Sorry, only registered users may post in this forum.