New Wamp 2.0 Install Gives Script Errors Old 2.0 Install Did Not Give
Posted by: TonyTee (---.hsd1.ga.comcast.net)
Date: March 18, 2017 11:20PM

Since I don't have Wamperserver 3.0 installed most of the "READ AND ANSWER BEFORE ASKING A QUESTION" items don't apply. I just installed Wampserver 2.0 on my Windows 10 machine.
I tried the lastest version but had issues. I have Wampserver 2.0 on an old Windows 7 computer and it works fine for me. The question I have is how do I get previous (or newer)
versions of Apache, PHP and MysSQL mysqlnd to match what I have on my working Windows 7 machine? I tried SourceForge but don't see how to get other versions.This what I have
installed currently on each machine:

Windows 7 machine:
Apache 2.2.13
PHP 5.2.5
MySQL mysqlnd 5.0.37
PHP Extension mysqli
phpMyAdmin 3.2.01

Windows 10 machine:
Apache 2.2.11 (win32)
PHP 5.3.0
MySQL mysqlnd 5.0.5
PHP Extension mysqli
phpMyAdmin 3.2.01

PHP and MySQL scripts that work perfectly with Wampserver 2.0 on my Windows 7 machine get the following errors on my new Wampserver install on my Windows 10 machine:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'xyz_tony1'@'localhost' (using password: YES) in C:\wamp\www\aaa\mobile\m_index.php on line 13

Warning: mysql_select_db() expects parameter 2 to be resource, boolean given in C:\wamp\www\aaa\mobile\m_index.php on line 15

Notice: Use of undefined constant userid - assumed 'userid' in C:\wamp\www\aaa\mobile\m_index.php on line 18

Notice: Use of undefined constant passwrd - assumed 'passwrd' in C:\wamp\www\aaa\mobile\m_index.php on line 19

Warning: mysql_query() expects parameter 2 to be resource, boolean given in C:\wamp\www\aaa\mobile\m_index.php on line 25
Invalid query: Access denied for user 'xyz_tony1'@'localhost' (using password: YES)

I don't get these errors on my Windows 7 machine with the same, exact script!

I can get into my database via phpMyAdmin just fine. I know I'll should upgrade to Wampserver 3 at some point but I have a project I need to complete and test and don't
have a lot of time to try to get the new version to work.

Any insight to my problem would be greatly appreciated.

Options: ReplyQuote
Re: New Wamp 2.0 Install Gives Script Errors Old 2.0 Install Did Not Give
Posted by: Otomatic (Moderator)
Date: March 19, 2017 09:25AM

Hi,

Completely obsolete and unsupported, in any way.

See : Install a new release of Wampserver

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.8 32 bit - Apache 2.4.25 - PHP 7.1.3/7.0.17/5.6.30 - MySQL 5.7.17 - MariaDB 10.1.21
Wampserver 3.0.8 64 bit - Apache 2.4.25 - PHP 7.1.3/7.0.17/5.6.30 - MySQL 5.7.17 - MariaDB 10.1.22
PhPMyAdmin 4.6.6 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.