Using Wampserver to run Intranet
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 17, 2017 04:34PM

1 – Windows Server 2008 R2 Standard x64
2 - Wamp x86is on 3.0.8
Wamp x64 is on 3.0.6 (I ran the 3.08 update as recommended but it applied the update to the x86 version. Do I need to down this to the Wamp64 folder as well?)

3 - Apache 2.4.23
4 - PHP - Looks like both 5.6.25 and 7.0.10 are in the folder, but the 5.6.25 is active
5 - MySQL 5.7.14
6 – Icon is green

7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines with the name [localhost] in them?

127.0.0.1 localhost
::1 localhost


8 - Do you have access to localhost (Homepage WampServer)? yes
8a - If so, is there an error message at the bottom of the page? no

9 - Do you have access to phpMyAdmin? yes

10 – no errors

12 - What is the full path to the installation of WampServer?
C:\wamp
C:\wamp64


So my goal in downloading and setting up WampServer, is to run a Wordpress site. The Wordpress site is going to be a company intranet site. It looks as if I have everything working properly. I have a green icon, I have wordpress installed and in the correct www folder location inside: wamp64/www/mysite

When I pull up the browser on the local webserver machine and type in mysite, it loads the website as it should.

The problem I am running into, is that I would like someone from another machine on our network to be able to access the site.

So if I go to another machine on our network and type in the ip address of the server and the website name for example: 192.xxx.xx.xx/mysite

The browser loads a 403 error. It states:

"Forbbiden
you don't have permission to access /mysite on this server.
Apache/2.4.23 (Win64) PHP/5.6.25 Server at 192.XXX.XX.XX Port 80"

Is anyone familiar with this type of set up and what could be denying me access to the site from a non-local machine?

Options: ReplyQuote
Re: Using Wampserver to run Intranet
Posted by: RiggsFolly (Moderator)
Date: March 17, 2017 11:29PM

Hi

Why have you got both the 32bit and 64bit WAMPServer installed on the same machine.

it is possible, but only for those that know what they are doing!! And understand what they are doing!!!!

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Using Wampserver to run Intranet
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 20, 2017 04:12PM

The install directions said that even if you are running Wamp 64 that you also needed to install Wamp 32 prior to 64.

Options: ReplyQuote
Re: Using Wampserver to run Intranet
Posted by: RiggsFolly (Moderator)
Date: March 20, 2017 04:45PM

No they did not.

They said that you will need to install ALL the MSVC Runtime libraries for BOTH 32bit and 64bit Windows.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.7.5> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Using Wampserver to run Intranet
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 23, 2017 02:08PM

I guess I misread the instructions. I wiped the products and reinstalled. Everything is functioning again.

As far as making t

Options: ReplyQuote


Sorry, only registered users may post in this forum.