Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 10, 2017 05:03PM

Good morning,

I am new to the forum so please bare with me. I've installed Wampserver64 3.0.6 on Windows Server 2008. All of the services are running and it appears I'm good to go.

However, when I try to navigate to the system tray Wampserver icon >> Apache >> httpd.conf file, so that I can adjust the httpd.config file, I get an error message.

It tells me:

"Aestan Tray Menu
Could not execute menu item (internal error)
[Exception] Could not execute run action:
The system cannot find the file specified"

So now I"m confused. When I installed Wamp64 it automatically installs the files itself.
Apache is installed in: C:/wamp64/bin/apache/apache2.4.23/conf

In fact, if I navigate to that folder I can find the httpd.conf file and open it manually.

Anyone have a suggestion on this issue or had something similar happen?

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: RiggsFolly (Moderator)
Date: March 10, 2017 05:11PM

Hi

Did you ensure, as noted in the Install dialogs, that your system had all the Microsoft Visual C/C++ runtime libraries installed?

See All you ned to know about WAMPServer 3

Also note as you are using a Windows 64bit OS you will need to install the 32bit runtime libraries AS WELL as the 64bit runtime libraries. Specifically as wampmanager.exe is still a 32 bit Application.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: Otomatic (Moderator)
Date: March 10, 2017 06:29PM

Hi,

Wampserver works only on NTFS disk. Not on FAT32 or exFAT.

- 1 - Please READ (and answer) BEFORE YOU ASK A QUESTION

- 2 - What are the 15 first lines of wamp64\wampmanager.conf file?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.8 32 bit - Apach 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
Wampserver 3.0.8 64 bit - Apache 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
PhPMyAdmin 4.7.0 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 10, 2017 08:37PM

Just to be sure I completed the process correctly, I went back and uninstalled everything.

I then ran all Microsoft updates on the machine, installed all of the VC links for both x86 and x64 versions. I then reinstalled Wampx86 and reinstalled Wampx64. Installation went fine. I get a green icon on my system tray Wamp icon.

However, if I try to open an Apache config file from the system tray Wamp icon I still get the exact same message.

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 10, 2017 09:00PM

Otomatic Wrote:
-------------------------------------------------------
> Hi,
>
> Wampserver works only on NTFS disk. Not on FAT32
> or exFAT.
>
> - 1 - Please
> [url=http://forum.wampserver.com/read.php?2,129067
> ]READ (and answer) BEFORE YOU ASK A
> QUESTION[/url]
>
> - 2 - What are the 15 first lines of
> wamp64\wampmanager.conf file?

1 – Windows Server 2008 R2 Standard x64
2 - Wamp x86is on 3.0.8
Wamp x64 is on 3.0.6 (I ran the 3.08 update as recommended but it applied the update to the x86 version. Do I need to down this to the Wamp64 folder as well?)

3 - Apache 2.4.23
4 - PHP - Looks like both 5.6.25 and 7.0.10 are in the folder, but the 5.6.25 is active
5 - MySQL 5.7.14
6 – Icon is green

7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines with the name [localhost] in them?

127.0.0.1 localhost
::1 localhost


8 - Do you have access to localhost (Homepage WampServer)? yes
8a - If so, is there an error message at the bottom of the page? no

9 - Do you have access to phpMyAdmin? yes

10 – no errors

12 - What is the full path to the installation of WampServer?
C:\wamp
C:\wamp64

13 - If you have one or more Virtual Hosts defined, please show their definition(s) – I have not defined any


For the record, yes this machine is NFTS.

First 15 lines of code of wampmanager.conf

"[main]
language ="english"
status = "offline"
wampserverVersion ="3.0.6"
installDir ="c:/wamp64"
;Path of the Browser used by Wampserver
;May be modfied with the absolute path of the browser exe file
;(Use / instead of \)
navigator ="C:/Program Files (x86)/Internet Explorer/iexplore.exe"
;Path of the Text Editor used by Wampserver
;May be modfied with the absolute path of the Text Editor exe file
;(Use / instead of \)
editor ="C:/Windows/notepad.exe"
defaultLanguage = english
wampserverMode ="64bit"

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 10, 2017 09:59PM

Also for the record, I just updated Wamp64 to 3.0.8 as well.

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: Otomatic (Moderator)
Date: March 10, 2017 10:02PM

Hi,

Are there same error when you navigate into Wampmanager tray menus to open php.ini or my.ini ?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.8 32 bit - Apach 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
Wampserver 3.0.8 64 bit - Apache 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
PhPMyAdmin 4.7.0 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 10, 2017 10:19PM

Yes, identical message for PHP.ini, PHP error log, my.ini, MySQL log files. I attempt to open them from the Wamp tray menu icon and get the same message.

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: Otomatic (Moderator)
Date: March 10, 2017 10:39PM

Hi,

Does c:\Windows\Notepad.exe exist ?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.8 32 bit - Apach 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
Wampserver 3.0.8 64 bit - Apache 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
PhPMyAdmin 4.7.0 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 10, 2017 11:04PM

It exists but it is located in c:\windows\system32 folder.

The machine also has notepad++ which is what I typically use, which is in C:\Program Files x86\

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: Otomatic (Moderator)
Date: March 10, 2017 11:15PM

Hi,

Modify the line
editor=
Of Wampmanager.conf file with the correct path of the text editor you want to use.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.0.8 32 bit - Apach 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
Wampserver 3.0.8 64 bit - Apache 2.4.25 - PHP 7.1.5/7.0.19/5.6.30 - MySQL 5.7.18 - MariaDB 10.1.23
PhPMyAdmin 4.7.0 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: Archaismic (---.hfc.comcastbusiness.net)
Date: March 13, 2017 06:00AM

Yeah. For whatever reason WAMP doesn't automatically create the proper link to the default program (notepad).

So do what Otomatic said: change the path to include the system 32 path

so change from this
editor ="C:/Windows/notepad.exe"
to
editor ="C:/Windows/system32/notepad.exe"

The other way to get around this is to manually select notepad on install even though it's already listed as the default program.

I had the same issue a few times.

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 17, 2017 03:56PM

I have modified the path for Notepad++ in the Wampconfig file for both the 32 and 64 versions of Wamp per your suggestion. However, when I restart services and try to access one of the Apache files from the system tray icon, I still get the same error message.


"Aestan Tray Menu:
Could not execute menu item (internal error)
[Exception] Could not execute run action:
The system cannot find the file specified"

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: RiggsFolly (Moderator)
Date: March 17, 2017 11:15PM

Are you sure that you installed all the MSVC runtime libraries as notified to you in the first Install Dialog?

See POINT 20 in the TROUBLESHOOTING TIPS

As you are using Windows 64bit, you will need to install ALL of these for BOTH 32bit and 64bit

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Wampserver, Apache error
Posted by: MemphisKid (---.cws.sco.cisco.com)
Date: March 23, 2017 02:05PM

Just to be 100% sure, I wipe it and did a clean install again of all of the products. I no longer get the error mentioned. Thanks for the help. I guess I missed something in my installation process.

Options: ReplyQuote


Sorry, only registered users may post in this forum.