Pages: 12Next
Current Page: 1 of 2
Upgrade issues from 2.5 to 3.0.6
Posted by: ohios (197.210.226.---)
Date: February 21, 2017 12:02PM

Hello,
I recently uninstalled wampserver 2.5 and installed 3.0.6 on windows 10. Everything looked fine until i wanted to login to one of my sites and it showed error connecting to database (Same error for all my local sites).
I checked my bin directory and found 2 folders MySQL 5.6.17(I guess its for Wampserver 2.5) which contained all my databases and another folder MySQL 5.7.14 which am certain is for the new wamp installation.
Am having a challenge setting this up so i my wordpress sites can connect to their databases again. I would appreciate any help in this regard. thanks a lot

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: RiggsFolly (Moderator)
Date: February 21, 2017 12:32PM

Hi

Which MYSQL version is currently being used (started) by WAMPServer? It sounds like it has moved to using the newer version of MYSQL


So to switch it back to the old MYSQL do the following:

Left click wampmanager icon -> MYSQL -> Version -> click on 5.6.17

Wait a moment while wampserver restarts and now it will have started your old version of MYSQL so your code will be able to see the old databases and old credentials

It is then up to you if you want to backup all these old databases (only yours, not mysql's own ones) and then switch to the newer MYSQL by doing the above again and selecting the newer version, and then restoring the backed up databases to the newer version of MYSQL.

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: ohios (197.211.56.---)
Date: February 21, 2017 01:21PM

Hello,
Thanks for your response.
I followed your instruction but I can only see Version MySQL5.7.14 showing. Would appreciate further help. Thanks for your time.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: RiggsFolly (Moderator)
Date: February 21, 2017 02:51PM

Did you install the new WAMPServer over an existing one, or into a seperate folder?

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: ohios (197.211.56.---)
Date: February 21, 2017 04:27PM

I uninstalled wampserver 2.5 before installing 3.0.6.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: Otomatic (Moderator)
Date: February 21, 2017 05:24PM

Hi,

Please, write here the full paths of the two mysql versions, like c:\wamp\bin\mysql\mysql5.7.14\

then the content of files :
- mysql5.6.17\my.ini
- mysql5.6.17\wampserver.conf

Note: You have not seen a Wampserver 2.5 update to Wampserver 3.0.3 without losing any of your local sites and databases; But it's too late.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 02/21/2017 05:28PM by Otomatic.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: ohios (197.211.56.---)
Date: February 22, 2017 01:51PM

Paths

C:\wamp\bin\mysql\mysql5.6.17
C:\wamp\bin\mysql\mysql5.7.14

Contents
C:\wamp\bin\mysql\mysql5.6.17

- C:\wamp\bin\mysql\mysql5.6.17\data
- C:\wamp\bin\mysql\mysql5.6.17\my.ini



C:\wamp\bin\mysql\mysql5.7.14
- C:\wamp\bin\mysql\mysql5.6.17\data
- C:\wamp\bin\mysql\mysql5.7.14\bin
- C:\wamp\bin\mysql\mysql5.7.14\lib
- C:\wamp\bin\mysql\mysql5.7.14\share
- C:\wamp\bin\mysql\mysql5.7.14\wampserver.conf
- C:\wamp\bin\mysql\mysql5.7.14\COPYING
- C:\wamp\bin\mysql\mysql5.7.14\README
- C:\wamp\bin\mysql\mysql5.7.14\my.ini
- C:\wamp\bin\mysql\mysql5.7.14\my-default.ini

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: Otomatic (Moderator)
Date: February 22, 2017 02:39PM

Hi,

then the content of files :
- mysql5.6.17\my.ini
- mysql5.6.17\wampserver.conf

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: ohios (197.211.63.---)
Date: February 22, 2017 03:05PM

No file as wampserver.conf in Mysql5.6.17

Contents of my.ini below






# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is C:\mysql\data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password = your_password
port = 3306
socket = /tmp/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[wampmysqld]
port = 3306
socket = /tmp/mysql.sock
key_buffer_size = 16M
max_allowed_packet = 1M
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
basedir=c:/wamp/bin/mysql/mysql5.6.17
log-error=c:/wamp/logs/mysql.log
datadir=c:/wamp/bin/mysql/mysql5.6.17/data

lc-messages-dir=c:/wamp/bin/mysql/mysql5.6.17/share

# Change your locale here !
lc-messages=fr_FR

# Avoid warning
explicit_defaults_for_timestamp = TRUE

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking

# Disable Federated by default
skip-federated

# Replication Master Server (default)
# binary logging is required for replication
log-bin=mysql-bin

# binary logging format - mixed recommended
binlog_format=mixed

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)


# New for MySQL 5.6 if no slave
skip-slave-start

#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Point the following paths to different dedicated disks
#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = C:\mysql\data/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = C:\mysql\data/
#innodb_log_arch_dir = C:\mysql\data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 16M
#innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 5M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

[mysqld]
port=3306
explicit_defaults_for_timestamp = TRUE

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: Otomatic (Moderator)
Date: February 22, 2017 03:32PM

Hi,

> No file as wampserver.conf in Mysql5.6.17
It seems that there is only
C:\wamp\bin\mysql\mysql5.6.17\data
and no other directory or files.

The uninstallation left only this folder. This is the one that contains your old databases.
It will therefore be necessary to reinstall a version 5.6.17 of MySQL, but without overwriting your databases.
BUT... on http://wampserver.aviatechno.net/ there are only mysql 5.6.12 then 5.6.28 to 5.6.35.

It is imperative that the version to be reinstalled is the same as the original version.
I suggest you create an installer for version 5.6.17 and, when ready, give you the procedure of reinstallation without losing your databases.
Do you agree ?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: poisson8528 (---.w92-160.abo.wanadoo.fr)
Date: April 21, 2017 03:35PM

Bonjour, j'ai le même soucis que ohios.

Sur mon site e-commerce, j'ai 2 erreurs dans mon panier :

"Warning: PDO::query(): SQLSTATE[HY000]: General error: 3065 Expression #1 of ORDER BY clause is not in

SELECT list, references column 'chezrobisa.panier.id' which is not in SELECT list; this is incompatible with

DISTINCT in C:\wamp\www\panier.php on line 34"

"Fatal error: Call to a member function rowCount() on boolean in C:\wamp\www\panier.php on line 41"

sur mon pc portable en version windows 10, wampserver version 3.0.6 alors que

sur mon pc fixe windows 7, wampserver version 2.5, tout fonctionne très bien alors que c'est le même code.


Chemins complets :

C:\wamp\bin\mysql\mysql5.7.14\bin\mysql_config.pl

C:\wamp\bin\mysql\mysql5.7.14\bin\mysqld.pdb

C:\wamp\bin\mysql\mysql5.7.14\bin\mysqld_multi.pl

C:\wamp\bin\mysql\mysql5.7.14\bin\mysqldumpslow.pl



Fichiers :

C:\wamp\bin\mysql\mysql5.7.14\bin

C:\wamp\bin\mysql\mysql5.7.14\data

C:\wamp\bin\mysql\mysql5.7.14\lib

C:\wamp\bin\mysql\mysql5.7.14\share

C:\wamp\bin\mysql\mysql5.7.14\COPYING

C:\wamp\bin\mysql\mysql5.7.14\my (Paramètres de configuration)

C:\wamp\bin\mysql\mysql5.7.14\my-default (Paramètres de configuration)

C:\wamp\bin\mysql\mysql5.7.14\README

C:\wamp\bin\mysql\mysql5.7.14\wampserver (Fichier CONF)



Merci par avance pour votre aide.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: poisson8528 (---.w92-160.abo.wanadoo.fr)
Date: April 21, 2017 03:39PM

Hello, I have the same worries as ohios.

On my e-commerce site, I have 2 errors in my cart:

"Warning: PDO :: query (): SQLSTATE [HY000]: General error: 3065 Expression # 1 of ORDER BY clause is not in

SELECT list, references column 'at home.panier.id' which is not in SELECT list; This is incompatible with

DISTINCT in C: \ wamp \ www \ panier.php on line 34 "

"Fatal error: Call to a member function rowCount () on boolean in C: \ wamp \ www \ panier.php on line 41"

On my laptop in windows 10, wampserver version 3.0.6 while

On my pc fixed windows 7, wampserver version 2.5, everything works very well while it is the same code.


Complete paths:

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ bin \ mysql_config.pl

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ bin \ mysqld.pdb

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ bin \ mysqld_multi.pl

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ bin \ mysqldumpslow.pl



Files:

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ bin

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ data

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ lib

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ share

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ COPYING

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ my (Configuration Settings)

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ my-default (Configuration Settings)

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ README

C: \ wamp \ bin \ mysql \ mysql5.7.14 \ wampserver (CONF file)



Thank you in advance for your help.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: RiggsFolly (Moderator)
Date: April 21, 2017 03:49PM

Hi

These are PHP coding errors!

---------------------------------------------------------------------------------------------
(Windows 7 Pro 32bit) (Wampserver 3.0.6 32bit)
<Apache 2.4.23/2.2.31> <PHP 7.1.2/7.0.16/5.6.28/5.5.38/5.4.45/5.3.29> <MySQL 5.7.10/5.6.17/5.5.28>
<MariaDB 10.1.21> <phpMyAdmin4.6.5.2> <MySQL Workbench 6.3.6.511>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin -- WAMPServer alternate Repo
-?-?-?- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -?-?-?-



Edited 1 time(s). Last edit at 04/21/2017 03:50PM by RiggsFolly.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: poisson8528 (---.w92-160.abo.wanadoo.fr)
Date: April 21, 2017 04:01PM

Errors ! Not since on my other pc, everything works

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: poisson8528 (---.w92-160.abo.wanadoo.fr)
Date: April 21, 2017 04:32PM

I have errors since the new version wampserver 3.0.6 but with the same coding, it works very well on

wampserver 2.5



Edited 1 time(s). Last edit at 04/21/2017 04:44PM by poisson8528.

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: Otomatic (Moderator)
Date: April 21, 2017 04:58PM

Hi,

> I have errors since the new version wampserver 3.0.6 but with the same coding,
> it works very well on wampserver 2.5

Is it the same PHP and MySQL versions ?

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: poisson8528 (---.w92-160.abo.wanadoo.fr)
Date: April 21, 2017 05:12PM

No, since I have created my site on wampserver 2.5 so php and mysql have changed on wampserver 3.0.6

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: Otomatic (Moderator)
Date: April 21, 2017 05:19PM

Hi,

Try :
Left-Click Wampmanager tray icon -> MySQL -> MySQL Settings -> sql-mode -> sql-mode -> none

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: poisson8528 (---.w92-160.abo.wanadoo.fr)
Date: April 21, 2017 05:25PM

It works, I do not have any more error by cons I still can not add an item in my basket

Options: ReplyQuote
Re: Upgrade issues from 2.5 to 3.0.6
Posted by: Otomatic (Moderator)
Date: April 21, 2017 05:35PM

Hi,

See if it should not update your application (e-commerce) according to the PHP and MySQL versions used, especially with PHP 7 and MySQL 5.7.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


Sorry, only registered users may post in this forum.