The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: rejv (---.dynamic.amis.net)
Date: December 07, 2016 04:56PM

Hello,

I know this might be a newbish questions, but I am quite new to WordPress.

I got my WAMP all set up on my windows 10 PC, but when I try to upload a new theme I get the "The uploaded file exceeds the upload_max_filesize directive in php.ini." error. Of course I tried googling it, but all solutions were written with an old version of WAMP(mine looks very different in the task bar - cant find php.ini file there).

I'm sure its and easy fix and would be very grateful for your help.

Cheers,
Denis

Options: ReplyQuote
Re: The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: Otomatic (Moderator)
Date: December 07, 2016 06:58PM

Hi,

Wampmanager Tray Icon -> PHP -> PHP Settings -> upload_max_filesize
Choose the value you need.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: rejv (---.dynamic.amis.net)
Date: December 07, 2016 07:34PM

Thanks for the response, but my WAMP Tray Icon doesnt have that option --> look here:



Also I changed the values in wamp/php/php.ini but the problems still exists(3 php files are in that folder - "php ini development"/ "php ini production" and "php" - I changed values of upload_max_filesize in every file but it still doesnt work).

Options: ReplyQuote
Re: The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: Otomatic (Moderator)
Date: December 07, 2016 07:38PM

Hi,

Left-click

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: rejv (---.dynamic.amis.net)
Date: December 07, 2016 09:47PM

Haha, thanks smiling smiley Works perfectly.

Options: ReplyQuote
Re: The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: Malik Shahzaib (182.182.208.---)
Date: January 07, 2019 05:31PM

This error is because your upload_max_filesize variable in php.ini file is adjusted to 2Mb.. change it to 64Mb!!
[This video tutorial][1] will help you fixing your error in 60 seconds!! Hope it helps



Edited 1 time(s). Last edit at 01/07/2019 05:55PM by Otomatic.

Options: ReplyQuote
Re: The uploaded file exceeds the upload_max_filesize directive in php.ini.
Posted by: Otomatic (Moderator)
Date: January 07, 2019 06:03PM

Hi,

You answer exactly two years and one month after the subject has been resolved.

Besides, there's no need for a video - which tells bullshit - to edit "upload_max_filesize"

Moreover, it takes less than 10 seconds to do so. Much less than the sixty seconds given by the video, to which must be added the time of viewing the said video.

I would never understand putting three-minute videos for things that require two lines of text to be explained.

Left-Click Wampmanager Tray Icon -> PHP -> PHP Settings -> upload_max_filesize
Choose the value you need.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 01/07/2019 06:05PM by Otomatic.

Options: ReplyQuote


Sorry, only registered users may post in this forum.