Wamp 3 does not start mysql
Posted by: CgullZ (---.hff.mweb.co.za)
Date: August 30, 2016 07:56AM

Hello, I am trying to reinstall WAMP on Windows 10.

After the new installation WAMP icon stays Orange.

Here is what I did:

I unistalled the old Wamp.

I change the wamp directory's name to: wampOld

I checked my services there are no mysql or apache on them

I installed all the VC packages needed:

I checked IIS on windows, looks ok to me:
Web Management Tools and everything under it is unticked.

I installed WAMP (wampserver3.0.4_x64_apache2.4.18_mysql5.7.11_php5.6.19-7.0.4)

I tested port 80:
***** Test which uses port 80 *****

===== Tested by command netstat filtered on port 80 =====

Test for TCP
Your port 80 is used by a processus with PID = 4180
The processus of PID 4180 is 'httpd.exe' Session: Services
The service of PID 4180 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct

Test for TCPv6
Your port 80 is used by a processus with PID = 4180
The processus of PID 4180 is 'httpd.exe' Session: Services
The service of PID 4180 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct

===== Tested by attempting to open a socket on port 80 =====

Your port 80 is actually used by :

Server: Apache/2.4.18 (Win64) PHP/5.6.19


Apache error log:
[Mon Aug 29 19:43:18.777165 2016] [auth_digest:notice] [pid 4180:tid 496] AH01757: generating secret for digest authentication ...
[Mon Aug 29 19:43:18.839665 2016] [mpm_winnt:notice] [pid 4180:tid 496] AH00455: Apache/2.4.18 (Win64) PHP/5.6.19 configured -- resuming normal operations
[Mon Aug 29 19:43:18.839665 2016] [mpm_winnt:notice] [pid 4180:tid 496] AH00456: Apache Lounge VC14 Server built: Dec 9 2015 11:13:29
[Mon Aug 29 19:43:18.839665 2016] [core:notice] [pid 4180:tid 496] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.18\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.18'
[Mon Aug 29 19:43:18.870917 2016] [mpm_winnt:notice] [pid 4180:tid 496] AH00418: Parent: Created child process 6408
[Mon Aug 29 19:43:19.480326 2016] [auth_digest:notice] [pid 6408:tid 432] AH01757: generating secret for digest authentication ...
[Mon Aug 29 19:43:19.558450 2016] [mpm_winnt:notice] [pid 6408:tid 432] AH00354: Child: Starting 64 worker threads.

Apache access log:
127.0.0.1 - - [29/Aug/2016:19:43:51 +0200] "GET / HTTP/1.1" 200 5145

I tried installing Wamp 32bit version instead, mySql log:
2016-08-29T20:00:38.680630Z 0 [Warning] InnoDB: New log files created, LSN=45790
2016-08-29T20:00:42.132996Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.
wampmysqld: Table 'mysql.plugin' doesn't exist
2016-08-29T20:00:42.566098Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2016-08-29T20:00:42.590113Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 440b9e23-6e23-11e6-ba24-a45d36c709dc.
2016-08-29T20:00:42.703794Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2016-08-29T20:00:43.016750Z 0 [Warning] Failed to open optimizer cost constant tables

2016-08-29T20:00:43.020753Z 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2016-08-29T20:00:43.021754Z 0 [ERROR] Aborting

wampmysqld: Table 'mysql.plugin' doesn't exist
2016-08-29T20:01:02.323383Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2016-08-29T20:01:02.326385Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2016-08-29T20:01:02.328387Z 0 [Warning] Failed to open optimizer cost constant tables

2016-08-29T20:01:02.330389Z 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2016-08-29T20:01:02.331389Z 0 [ERROR] Aborting

wampmysqld: Table 'mysql.plugin' doesn't exist
2016-08-29T20:01:26.201624Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2016-08-29T20:01:26.203625Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2016-08-29T20:01:26.206627Z 0 [Warning] Failed to open optimizer cost constant tables

2016-08-29T20:01:26.208630Z 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2016-08-29T20:01:26.210631Z 0 [ERROR] Aborting

I changed my.ini file:
tmpdir = c:/mysql/tmp/

mysQl log:
2016-08-30T05:43:58.457515Z 0 [ERROR] InnoDB: Unable to create temporary file; errno: 0
2016-08-30T05:43:58.458516Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2016-08-30T05:43:58.459516Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2016-08-30T05:43:58.459516Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2016-08-30T05:43:58.460517Z 0 [ERROR] Failed to initialize plugins.
2016-08-30T05:43:58.460517Z 0 [ERROR] Aborting

Options: ReplyQuote
Re: Wamp 3 does not start mysql
Posted by: Otomatic (Moderator)
Date: August 30, 2016 10:53AM

Hi,

> 2016-08-29T20:00:42.132996Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.
> wampmysqld: Table 'mysql.plugin' doesn't exist

This table 'mysql.plugin' is created at MySQL 5.7.11 installation by the command:
mysqld.exe --initialize-insecure
which is the procedure advocated by MySQL to create the folder 'data'.
If the table does not exist, is that the creation process could not be completed for several reasons: disk problem, Windows problem, corrupted archive, etc.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp 3 does not start mysql
Posted by: malith (123.231.109.---)
Date: March 22, 2022 07:07PM

I'm stuck with this problem also, is there any solution for that? I can't run the MySQL

Options: ReplyQuote
Re: Wamp 3 does not start mysql
Posted by: Otomatic (Moderator)
Date: March 23, 2022 03:08PM

Hi,

You are responding to a message that is six years old and, in six years, a lot has happened and evolved.

Please, READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.