OpenSSL not recognized
Posted by: fbk (89.137.200.---)
Date: January 25, 2016 11:27PM

Hi, I am trying to install composer and laravel on wamp using cmd. I am getting the error that openssl is not loaded, but it is as it's showing both in phpinfo(); and the wampserver homepage and also in the php.ini files in php and apache folders the lines are not commented.

Info:

1 - Windows version used (Specify version number AND whether 32 or 64 bit): Windows 10 PRO 64bits
2 - Version WampServer (Specify version number AND whether 32 or 64 bit): 2.5 64bits
3 - Apache Version: 2.4.9
4 - PHP Version: 5.5.12
5 - MySQL Version: 5.6.17
6 - What color is the WampServer icon (in the notification area of the taskbar) : Green
7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines with the name [localhost] in them?

127.0.0.1 localhost
127.0.0.1 localhost

8 - Do you have access to localhost (Homepage WampServer)? Yes
9 - Do you have access to phpMyAdmin? Yes
10 - If you refer to an error message, please include the EXACT wording of the error in your post

PHP Warning: readfile(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in Command line code on line 1
PHP Warning: readfile(https://getcomposer.org/installer): failed to open stream: Invalid argument in Command line code on line 1

Warning: readfile(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in Command line code on line 1

Warning: readfile(https://getcomposer.org/installer): failed to open stream: Invalid argument in Command line code on line 1


11 - If you use an Antivirus and / or Firewall, please include the names of these: Avast Antivirus
12 - What is the full path to the installation of WampServer (eg D:\wamp\): D:\wamp

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: fbk (89.137.200.---)
Date: January 25, 2016 11:32PM

I took the exact words from the composer download page:

php -r "readfile('https://getcomposer.org/installer');" | php

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: January 26, 2016 01:50AM

There are 2 php.ini file.

The one you need to edit for the PH CLI (Command line interface) is in \wamp\bin\php\php.ini

Make sure that php_openssl is enabled in there

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: fbk (89.137.200.---)
Date: January 26, 2016 09:22AM

Hi RiggsFolly

In D:\wamp\bin\php\php5.5.12 the line is uncommented.
In D:\wamp\bin\apache\apache2.4.9\bin the line is uncommented.

Is there a php.ini in any other place ?

Thanks.

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: January 26, 2016 01:13PM

No not for command line usage.

But if you had tried to install PHP some other way before finding WAMPServer possibly.


Do a search for `php.ini` and if you find one outside the `\wamp\` folder structure delete it

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: fbk (89.137.200.---)
Date: January 26, 2016 06:30PM

EDIT:

It's working, I searched for other php.ini files and I also had EasyPHP and they were in conflict. Thanks.



Edited 1 time(s). Last edit at 01/26/2016 09:20PM by fbk.

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: Asok Asus (---.hsd1.co.comcast.net)
Date: January 01, 2021 07:42AM

for me, this problem resulted from installing versions of PHP subsequent to 7.1 with apache 2.4.23 on wampserver 3.2.4. All versions of PHP after 7.1 produced the error "Unable to find the wrapper "https" - did you forget to enable it when you configured PHP?" and "Fatal error: SOAP Fault: [HTTP] SSL support is not available in this build".

A significant indicator of the problem was that on phpinfo.php, "Registered Stream Socket Transports" showed only TCP & UDP available, with none of the SSL transports available.

Upgrading to apache 2.4.46b resolved all SSL related problems, and "Registered Stream Socket Transports" subsequently included ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2 & tlsv1.3 transports.

Options: ReplyQuote
Re: OpenSSL not recognized
Posted by: Otomatic (Moderator)
Date: January 01, 2021 08:46AM

Hi,

Thanks for the feedback. Apache 2.4.46a includes SSL 1.1.1i.

But are you aware that you have replied to a five year old message?

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.