How Many Components Versions Can/Should Be Installed?
Posted by: »Ð@RK ÐR@GÖN™« (179.43.104.---)
Date: January 07, 2016 07:10PM

Hi to anybody that read this post!
Just wanna make a point clear about installing new components versions of WAMPServer.

How many versions of the basic components can/should be installing without going in to disaster or mashing up servers?
Apache? / php? / MySQL?

I will be please to any answer/recommendation, ´cause I have install three version of php including php7 and just two of them are shown in the server tray. And what´s curious is that in the localhost php Version 7.0.2 – Documentation and Server Software php/x.y.z a previous version installed.

______________________________________________________________________
Powered By: JayManuel-NetWork4.org
©2015-2016 »Ð@RK ÐR@GÖN™«. All Rights Reserved.
______________________________________________________________________
WAMPServer 2.5 32bits
Apache2.4.18 | MySQL5.6.29 | php5.6.18-php5.5.32-php7.0.3
______________________________________________________________________



Edited 1 time(s). Last edit at 01/07/2016 07:13PM by »Ð@RK ÐR@GÖN™«.

Options: ReplyQuote
Re: How Many Components Versions Can/Should Be Installed?
Posted by: Otomatic (Moderator)
Date: January 07, 2016 07:53PM

Hi,

See my signature. Moreover I have PHP 5.5.30, 5.6.16, 7.0.0, 7.0.1 ; Apache 2.4.17.

I think There is no limit if each version is supported by Wampserver criteria.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: How Many Components Versions Can/Should Be Installed?
Posted by: »Ð@RK ÐR@GÖN™« (179.43.104.---)
Date: January 07, 2016 08:30PM

Hi Otomatic, thanks your prompt response,

I had previously installed php5.6.16 along with the default version php5.5.12, also installed Apache2.4.18 and MySQL5.6.28 and everything was working just fine no problem when switching and making all possible combination.
So I decide to go further and install php7.0.2, this version does not show up in the tray and switching versions of any of the components gat stuck. Have any idea why this may happen
to install the php7.0.2 I followed up your post to for php7.0.0a1

I am currently using WAMPServer 2.5 32bits on a Windows Vista™ 32bits built machine

Best regards!

______________________________________________________________________
Powered By: JayManuel-NetWork4.org
©2015-2016 »Ð@RK ÐR@GÖN™«. All Rights Reserved.
______________________________________________________________________
WAMPServer 2.5 32bits
Apache2.4.18 | MySQL5.6.29 | php5.6.18-php5.5.32-php7.0.3
______________________________________________________________________



Edited 1 time(s). Last edit at 02/08/2016 05:03AM by »Ð@RK ÐR@GÖN™«.

Options: ReplyQuote
Re: How Many Components Versions Can/Should Be Installed?
Posted by: Otomatic (Moderator)
Date: January 07, 2016 08:41PM

Hi,

For PHP 7.0.1 and 7.0.2 you need VC14 Update 1.
See TROUBLESHOOTING TIPS point 20 for links.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: How Many Components Versions Can/Should Be Installed?
Posted by: »Ð@RK ÐR@GÖN™« (179.43.104.---)
Date: January 07, 2016 08:59PM

Hi Otomatic! Thanks for the heads up,
I have VC14 already install not too sure about the update 1.
I'll check and see what happens.

______________________________________________________________________
Powered By: JayManuel-NetWork4.org
©2015-2016 »Ð@RK ÐR@GÖN™«. All Rights Reserved.
______________________________________________________________________
WAMPServer 2.5 32bits
Apache2.4.18 | MySQL5.6.29 | php5.6.18-php5.5.32-php7.0.3
______________________________________________________________________



Edited 1 time(s). Last edit at 01/07/2016 09:00PM by »Ð@RK ÐR@GÖN™«.

Options: ReplyQuote


Sorry, only registered users may post in this forum.