Can't start Apache 2.2.14 on Wamp 2.5
Posted by: Bluealek (---.dynamic.sbb.rs)
Date: January 07, 2016 01:22PM

I need PHP 5.3 instead of the default PHP 5.5, so I downloaded PHP 5.3 for Wamp 2.5, as well as Apache 2.2.14, since the default Apache 2.4.9 isn't compatible with PHP 5.3. Upon installing both in Wamp I can get only to the orange main icon stage, since Apache 2.2.14 doesn't seem to work (when I go to the Service menu, all the Start/Resume, Stop and Restart Service icons are grayed out, therefore inaccessible).

Are there any additional steps required in order to enable the usage of Apache 2.2.14?

Options: ReplyQuote
Re: Can't start Apache 2.2.14 on Wamp 2.5
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: January 07, 2016 01:41PM

Hello Alek

Depending on what you do first getting back to a PHP that old that need an Apache switch and a PHP switch can prove a problem unless you have an intermediary version of PHP that works with both Apache's

Try switching to the old PHP a couple of time and then switch Apache backwards. Basically try and beat it into submission.


Alternatively there is now a WAMPServer 3.0.0 and a 3.0.1 update. If you were to install this it also comes with the ability to install ADDONS again easily. There are addons for Apache 2.2 and the latest versions of PHP versions from PHP5.3 to PHP7.0.1 This may be the easiest way to go if you are having switching issues.

If you are going to try and install the WAMPServer3.0.0/1 then please first read through this post on how to upgrade WAMPServer safely without loosing any databases and or websites. Installing a new version of WAMPServer

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Can't start Apache 2.2.14 on Wamp 2.5
Posted by: »Ð@RK ÐR@GÖN™« (179.43.104.---)
Date: January 07, 2016 01:59PM

Hi Bluealek, how are you doing?

In responds to your post if it does help, I have currently upgrade my WampServer2.5 to: Apache2.4.18 / php5.6.16 / MySQL5.6.28 and its works fine no inconvenient issue, I can switch between any of these upgrade and the default version in any combination and still it works fine. The default versions are Apache2.4.9 / php5.5.12 / MySQL5.6.17

Now I am up to upgrade php to php7.0.2 and MySQL5.7.10, I do not have any idea if it will work fine on wampServer 2.5
Best regards!

______________________________________________________________________
Powered By: JayManuel-NetWork4.org
©2015-2016 »Ð@RK ÐR@GÖN™«. All Rights Reserved.
______________________________________________________________________
WAMPServer 2.5 32bits
Apache2.4.18 | MySQL5.6.29 | php5.6.18-php5.5.32-php7.0.3
______________________________________________________________________



Edited 4 time(s). Last edit at 01/07/2016 02:25PM by »Ð@RK ÐR@GÖN™«.

Options: ReplyQuote
Re: Can't start Apache 2.2.14 on Wamp 2.5
Posted by: Bluealek (---.dynamic.sbb.rs)
Date: January 07, 2016 02:04PM

Thanks for the suggestion! You may be right that the best idea would be to upgrade to the latest version of Wampserver, and then configure the older PHP/Apache environment there. I'll do it, and I'll get back with the results.

Options: ReplyQuote
Re: Can't start Apache 2.2.14 on Wamp 2.5
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: January 07, 2016 02:10PM

Remember once you get WAMPServer up and running you can copy any versions of MYSQL / APACHE / PHP from the old install to the new as long as you dont overwrite the old versions or delete them

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.